Re: about add python3 modules


Burton, Ross <ross.burton@...>
 

Hi,

1.7.1 is pretty old, there were some packaging problems.  Try adding python3-misc to the image too.

If that doesn't work, use 'oe-pkgdata-util list-pkg-files -r python3' to list all the files built by the python3 recipe and to find out what files are missing.

Ross

On 30 October 2017 at 20:36, Lai Y.C. <yclai017@...> wrote:
Hi,

I need to include python3 and some modules on my board. We are using yocto 1.7.1 .
I have included python3 and python3-modules into the image.
Python3 is able to run but there are problems with the modules.

1. when I import "subprocess" module,  it gives errors that the module "_posixsubprocess" is not found. How should I include _posixsubprocess ?
2. There are couple of modules that are installed but they are found when I used it. i.e. I have the argparse.py in /usr/lib/python3.3. However, the module is not found when I try to import it. (tested with python3 -c "import argparse"). Any clue what hasn't be set-up properly?

Thanks

//Ying


--
_______________________________________________
yocto mailing list
yocto@...
https://lists.yoctoproject.org/listinfo/yocto


Join yocto@lists.yoctoproject.org to automatically receive all group messages.