Re: Errors building with Windows Subsystem for Linux (aka Bash on Ubuntu on Windows)


Bryan Evenson
 

Alex,

-----Original Message-----
From: yocto-bounces@... [mailto:yocto-bounces@...] On Behalf Of Alexander Kanavin
Sent: Sunday, October 01, 2017 4:20 AM
To: Dominig ar Foll (Intel Open Source) <dominig.arfoll@...>; yocto@...
Subject: Re: [yocto] Errors building with Windows Subsystem for Linux (aka Bash on Ubuntu on Windows)

On 09/29/2017 05:01 PM, Dominig ar Foll (Intel Open Source) wrote:
Due to what our IT department can support, I am issued a Windows laptop for development. In the past I have used VMWare to make a Linux virtual machine for my Yocto Project based image builds and application development. We are starting to get Windows 10 laptops so I am evaluating doing my builds using the Windows Subsystem for Linux (WSL) by building a poky/morty image. Overall it seems to be working. I've had an issue that I've worked through and other issues that I'm not quite sure what is going on.
Hi Brian,

I have been trying the same thing attempting to build Automotive Grade
Linux from Linux for Windows subsystem.
We have many adopter of AGL who also receive Windows PC from their IT
department. While VM work, they impose a serious limitation on memory
and CPU usage.
Does anyone else think doing embedded linux development on windows machines is a ridiculous situation, and needs to be discussed with companies management? IT departments should either support product R&D work (because at the end of the day that is where the company makes money), or stay out of the way and let engineers self-manage their computers, including installing weird operating systems.
Yes, ideally I could just get a Linux laptop and do that for development. Unfortunately, that's not an option for me. Honestly, if WSL works well I wouldn't mind it as a working solution. I started trying this more out of curiosity if it would do anything. I was quite surprised how much did work with very little modification.

With the few changes I have already mentioned, I was able to build my complete image. I then started working on building my development image to create and SDK that has gdb and tools for the Eclipse plugin. That built all the way to rootfs, then failed with a blank error message. I then tried with my VM, and the development image failed in the same manner. I recently updated to a more recent Yocto branch, so I think I broke something with my development image build (unrelated to WSL) that I need to go back and fix.

The biggest issue I had with build times was with antivirus tools. I hadn't setup the Windows antivirus to ignore the WSL working directory, so it was scanning every new file created and modified. Once I told it to ignore the WSL working directory, the build times were comparable to under VMWare.

I don't know how far I'll take this, but I thought others would be interested in the results.

Bryan

Join yocto@lists.yoctoproject.org to automatically receive all group messages.