RPi app built with SDK won't load


Paul D. DeRocco
 

I posted about this a week or so ago, but have narrowed things down
further.

I built a 32-bit non-GUI RPi image which works, built the corresponding
SDK, and used the SDK's toolchain to build an empty C program (just
"return 0;" inside main). When I run it on the target, the shell
complains:

-sh: ./test: No such file or directory

If I run "ldd test", it dies with the same error, without even getting far
enough to trace the search for libc, the only referenced library. (Yes,
the x attribute is set.)

On my host system, I ran arm-poky-linux-objdump -x on the test program,
and then ran it on the version of chmod.coreutils from the rootfs of the
build (because it was the smallest executable in /bin). The only
differences were that chmod referenced a couple more libraries, the
section addresses and sizes were of course different, test had a small
.comment section listing the compiler used, and chmod had a .gnu_debuglink
section. All attributes were the same, even the contents of the
.ARM.attributes section.

Yet despite this, chmod runs fine, but test doesn't.

What else could possibly return an ENOENT error code to the shell so early
in the load process?

--

Ciao, Paul D. DeRocco
Paul mailto:pderocco@ix.netcom.com

Join yocto@lists.yoctoproject.org to automatically receive all group messages.