Any ideas why my RPi app won't load?


Paul D. DeRocco
 

I've built a custom 32-bit non-GUI Raspberry Pi image, built the
corresponding SDK, and used the SDK's toolchain to build an app. When I
run the app on the RPi, from a command prompt as root, the shell
complains:

-sh: /path/to/app: No such file or directory

(with the real app name, obviously). sh is linked to bash. Here's what
I've checked:

1) The app exists, and is the correct executable.

2) Its execute permission bit is set.

3) Its ELF file format is the same as the ELF file format of every other
command in the system.

4) The shared libraries it uses all exist, recursively, in /lib or
/usr/lib. They are all listed by ldconfig -p.

5) There is no LD_LIBRARY_PATH variable.

6) If I run the app with LL_DEBUG=all, I get the same error, so it isn't
even getting as far as loading libraries. (Or perhaps LL_DEBUG isn't
supported on this build.)

Googling didn't turn up any other possibilities. Has anyone seen any other
reasons for this error?

--

Ciao, Paul D. DeRocco
Paul mailto:pderocco@ix.netcom.com

Join yocto@lists.yoctoproject.org to automatically receive all group messages.