Can't enable reverse debugging

Bryan Evenson

I'm on poky/dizzy and I'm getting a segementation fault in my application that I think may be related to a buffer overflow. I'm using the Eclipse plug-in (on Eclipse Kepler) to debug on the hardware with GDB. I'm trying to enable reverse debugging but I have not had any success and I'm looking for some help.

My target processor is an SAM9G25 (ARM926EJ-S core). I have been able to debug through Eclipse on the target hardware without issue. I tried enabling Reverse Debugging by going to Window->Customize Perspective...->Command Groups Availability and selecting "Reverse Debugging". Now there is a "Reverse Toggle" button on my toolbar, but it is always grayed out whether I have a debug session running or not. I have also tried entering the command "record" from the GDB console after my program breaks at main. When I run the program, I get the error message "Process record: failed to record execution log".

Is there something that I'm missing from my build steps or some Eclipse plugin that I may be missing that is causing issues for reverse debugging? Or is there some hardware requirement that my system may not meet?


Join { to automatically receive all group messages.