Re: bitbake problems when testing pre-built images


Pedro I. Sanchez <psanchez@...>
 

Thank you Jessica, it worked.

May I suggest to update the wiki? As written, the instructions there do not work, at least for the section "Using Pre-Built Binaries and QEMU".

Thanks again,

--
Pedro

On 10-11-14 04:20 PM, Zhang, Jessica wrote:
Pedro I. Sanchez wrote:
Hello,

I'm starting to play with Yocto and the first thing I want to do is to
run pre-built images to get a feeling for the system. Unfortunately
I'm getting errors when running the poky-qemu command. My host
machine is Ubuntu 10.04.

I'm following the Wiki instructions at
http://www.yoctoproject.org/docs/yocto-quick-start/yocto-project-qs.html.

The section "Using Pre-Built Binaries and QEMU" lists three steps to
follow in order to test pre-built images, steps which I'm executing as
follows after downloading the following arm-target files:

yocto-eglibc-i586-arm-toolchain-sdk-0.9.tar.bz2
zImage-2.6.34-qemuarm-0.9.bin
yocto-image-minimal-qemuarm-0.9.rootfs.tar.bz2
Please download yocto-image-minimal-qemuarm-0.9.rootfs.ext3


and installing the toolchain with:

$ sudo tar xjf yocto-eglibc-i586-arm-toolchain-sdk-0.9.tar.bz2 -C /
$ source /opt/poky/environment-setup-armv5te-poky-linux-gnueabi

The final step is supposed to be to run the poky-emu command but I get
the following error:

$ poky-qemu zImage-2.6.34-qemuarm-0.9.bin
yocto-image-minimal-qemuarm-0.9.rootfs.tar
The command should be
$poky-qemu qemuarm zImage-2.6.34-qemuarm-0.9.bin
yocto-image-minimal-qemuarm-0.9.rootfs.ext3 ext3

Hope this should get you going...

- Jessica

Join yocto@lists.yoctoproject.org to automatically receive all group messages.