Re: preempt-rt kernel shutdown now command does not work


Darren Hart <darren.hart@...>
 

On 09/29/2011 07:32 PM, Bodke, Kishore K wrote:
Hi Darren,

For the non-rt "shutdown now" works perfectly fine. For the rt
kernel, after the command is issued, it tries to halt the system and
hangs there forever after the connection to the X server is lost.
Sounds like a legitimate bug. It works in qemux86 with -rt. I'll be able
to test an rt image on a meta-intel board in the morning. In the mean
time, please open a bug and let us know how critical you feel it is.

Thanks,

--
Darren


Thanks Kishore.

-----Original Message----- From: Hart, Darren Sent: Thursday,
September 29, 2011 6:44 PM To: Bodke, Kishore K Cc:
yocto@... Subject: Re: preempt-rt kernel shutdown now
command does not work

On 09/29/2011 05:54 PM, Bodke, Kishore K wrote:
Hi,

"shutdown -h now" command is not working on core-image-sato image
with preempt-rt kernel 3.0.4 on Romley and crystal forest BSP

I get Warning**: could not initialize ACPI battery. Xinit:
connection to X server lost. xinit: uexpected signal 15
Hi Kishore,


I don't know that I've tried that specific command.

I see the unexpected signal message when shutting down the qemux86
sato image (non-rt) with that or the halt command, but it does shut
all the way down. In your case does the system continue to be
responsive after issuing the command?


--
Darren Hart
Intel Open Source Technology Center
Yocto Project - Linux Kernel

Join yocto@lists.yoctoproject.org to automatically receive all group messages.