[PATCH 1/1] xpsb-glx: Move the pkgconfig file(s) to the -dev package


tom.zanussi@...
 

From: Tom Zanussi <tom.zanussi@...>

pkgconfig files belong in the -dev package. They automatically add
a runtime dependency (when packaging with RPM) for "pkgconfig", which
is not desired to be installed with this package.

This also fixes another problem in that FILES_{PN} was being assigned
instead of being appended and was adding libdir/*, preventing the
above from taking effect.

Signed-off-by: Tom Zanussi <tom.zanussi@...>
---
.../recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb | 5 +++--
1 files changed, 3 insertions(+), 2 deletions(-)

diff --git a/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb b/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb
index 8fb25d6..f6cee46 100644
--- a/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb
+++ b/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "X11 drivers for Poulsbo (psb) 3D acceleration"
# not Intel proprietary, but it has no obvious license attached to it.
LICENSE = "Intel-binary-only"
LIC_FILES_CHKSUM = "file://${WORKDIR}/${PN}-${PV}/COPYING;md5=02c597a2f082b4581596065bb5a521a8"
-PR = "r8"
+PR = "r9"

inherit autotools

@@ -38,7 +38,8 @@ EXTRA_OEMAKE = "linux-dri-x86"

DEPENDS += "libxfixes libxdamage libdrm-poulsbo libxxf86vm dri2proto libxmu libxi glproto makedepend-native"

-FILES_${PN} = "${libdir}/* ${libdir}/xorg/modules/dri/* \
+FILES_${PN}-dev += "${libdir}/pkgconfig"
+FILES_${PN} += "${libdir}/xorg/modules/dri/* \
${libdir}/xorg/modules/drivers/*"

PACKAGES =+ "libglu libglu-dev"
--
1.7.0.4

Join yocto@lists.yoctoproject.org to automatically receive all group messages.