[PATCH 7/7] Add proper deps for nfs-utils, util-linux, and strace


Matthew McClintock
 

These packages need these deps for the RPM generation stage:

error: Failed dependencies:
| /usr/bin/python is needed by nfs-utils-1.2.3-r2.ppce5500
| /usr/bin/perl is needed by util-linux-2.19.1-r4.ppce5500
| /usr/bin/perl is needed by strace-4.5.20-r2.ppce5500

Signed-off-by: Matthew McClintock <msm@...>
---
.../nfs-utils/nfs-utils_1.2.3.bb | 2 +-
meta/recipes-core/util-linux/util-linux.inc | 2 +-
meta/recipes-devtools/strace/strace_4.5.20.bb | 2 ++
3 files changed, 4 insertions(+), 2 deletions(-)

diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb
index 08468fe..e8b0490 100644
--- a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb
+++ b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"

# util-linux for libblkid
DEPENDS = "libcap libnfsidmap libevent util-linux tcp-wrappers"
-RDEPENDS_${PN} = "portmap"
+RDEPENDS_${PN} = "portmap python"
RRECOMMENDS_${PN} = "kernel-module-nfsd"

PR = "r2"
diff --git a/meta/recipes-core/util-linux/util-linux.inc b/meta/recipes-core/util-linux/util-linux.inc
index 1f242b7..afce673 100644
--- a/meta/recipes-core/util-linux/util-linux.inc
+++ b/meta/recipes-core/util-linux/util-linux.inc
@@ -55,7 +55,7 @@ FILES_util-linux-libuuid-dev = "${libdir}/libuuid.so ${libdir}/libuuid.a ${libdi
FILES_util-linux-lscpu = "${bindir}/lscpu"

RRECOMMENDS_${PN} = "util-linux-fdisk util-linux-cfdisk util-linux-sfdisk util-linux-mount util-linux-readprofile "
-RDEPENDS_${PN} = "util-linux-umount util-linux-swaponoff util-linux-losetup"
+RDEPENDS_${PN} = "util-linux-umount util-linux-swaponoff util-linux-losetup perl"

RRECOMMENDS_${PN}_virtclass-native = ""
RDEPENDS_${PN}_virtclass-native = ""
diff --git a/meta/recipes-devtools/strace/strace_4.5.20.bb b/meta/recipes-devtools/strace/strace_4.5.20.bb
index 391669f..b3d2aa5 100644
--- a/meta/recipes-devtools/strace/strace_4.5.20.bb
+++ b/meta/recipes-devtools/strace/strace_4.5.20.bb
@@ -5,6 +5,8 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=4535377ede62550fdeaf39f595fd550a"
PR = "r2"

+RDEPENDS = "perl"
+
SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
file://sigmask.patch \
"
--
1.7.6.1

Join yocto@lists.yoctoproject.org to automatically receive all group messages.