Fixing build when changing kernel PREFERRED_PROVIDER

Bryan Evenson

I'm on poky/dizzy-1.7.2 and I'm in the process of updating to poky/dizzy-1.7.3. I'm using an Atmel processor, so while I'm at it I'm pulling in changes from meta-atmel (over at, dizzy branch). One of the commits I pulled in was this one: This renamed the kernel package from linux-yocto-custom to linux-at91. After this change when I tried to build the image, I was greeted with a very long list of files and the following error:

The build has stopped as continuing in this scenario WILL break things, if not now, possibly in the future (we've seen builds fail several months later). If the system knew how to recover from this automatically it would however there are several different scenarios which can result in this and we don't know which one this is. It may be you have switched providers of something like virtual/kernel (e.g. from linux-yocto to linux-yocto-dev), in that case you need to execute the clean task for both recipes and it will resolve this error. It may be you changed DISTRO_FEATURES from systemd to udev or vice versa. Cleaning those recipes should again resolve this error however switching DISTRO_FEATURES on an existing build directory is not supported, you should really clean out tmp and rebuild (reusing sstate should be safe). It could be the overlapping files detected are harmless in which case adding them to SSTATE_DUPWHITELIST may be the correct solution. It could also be your build is including two different conflicting versions of things (e.g. bluez 4 and bluez 5 and the correct solution for that would be to resolve the conflict. If in doubt, please ask on the mailing list, sharing the error and filelist above.
ERROR: If the above message is too much, the simpler version is you're advised to wipe out tmp and rebuild (reusing sstate is fine). That will likely fix things in most (but not all) cases.
ERROR: Function failed: sstate_task_postfunc

I issued 'bitbake -c clean linux-at91' and then 'bitbake -c clean linux-yocto-custom'. Linux-at91 cleaned without issue, but when I tried to clean linux-yocto-custom I got an error saying "Nothing PROVIDES 'linux-yocto-custom'". That in itself makes sense as there is no longer any recipe for linux-yocto-custom. However, I'd like to avoid deleting the entire tmp directory. I don't have the speediest machine and I'd like to avoid wasting a day if there was a simpler solution.

Is there a less destructive fix to this problem than deleting the tmp directory, or is that the only safe way to fix this problem?


Join to automatically receive all group messages.