Re: Yocto 1.1 Beta Questions


Jason Kridner
 

Isn't bitbake supposed to be smart enough to discover and use 'screen'
instead now?

On Tue, Sep 6, 2011 at 9:07 PM, Stewart, David C
<david.c.stewart@...> wrote:
Yeah, I ran into the same thing, Brian. Installing xterm is missing from the
quickstart and the beta instructions. Sorry about that.


Sent from my Blackberry

From: Brian Duffy [mailto:brduffy@...]
Sent: Tuesday, September 06, 2011 04:51 PM
To: Osier-mixon, Jeffrey; yocto@... <yocto@...>
Subject: Re: [yocto] Yocto 1.1 Beta Questions

Okay, so it turns out that I had already downloaded what I needed with the
instructions from the latest blog post for the beta release. It specifically
mentions certain command to replace from the quick start guide. So I went
into the "oe-beta" directory and ran . ./oe-init-build-env ~/my-build and
that set up my environment variables. When I ran bitbake core-image-minimal
I got an error stating that xterm was not installed. That might be something
to include in the quick start section of things to install first. Anyway, it
seems to be happily building a minimal linux distro for the emulator to run.
I'll let you know if it works out.
thnx
Brian

On Tue, Sep 6, 2011 at 3:28 PM, Osier-mixon, Jeffrey
<jeffrey.osier-mixon@...> wrote:

One more thing - if you prefer a tarball to git (easier on some corporate
networks) the process is the same, just un-tar the tarball into a working
directory and cd into the poky subdir and go from there. The tarball should
be the latest stable release.

On Tue, Sep 6, 2011 at 12:27 PM, Osier-mixon, Jeffrey
<jeffrey.osier-mixon@...> wrote:

Hi Brian, sorry for the delay.
If you download the poky tarball or use git to grab it and then follow
the instructions on the quick-start, the tools should build automatically.
 In a nutshell, try this:
git clone git://git.yoctoproject.org/poky.git
cd poky
. ./oe-core-build-env
[that should put you into a build directory]
vi conf/local.conf  [set at least MACHINE, instructions in the file]
bitbake core-minimal
I hope this helps!  I'm on IRC as Jefro or available by email, let me
know if I can help at all.

On Sat, Sep 3, 2011 at 5:52 PM, Brian Duffy <brduffy@...> wrote:

Thanks for the input Jeff. I have not downloaded the tools yet. I'll
probably download the tarball since I don't have much experience with git.
I'll set the bbpath in local.conf and uninstall bitbake from the package
manager before I do so. I guess building the tools will take care of bitbake
and pseudo. Any help with how to build the tools would be appreciated, but
no hurry, enjoy the holiday!
thnx
Brian

On Sat, Sep 3, 2011 at 5:50 PM, Osier-mixon, Jeffrey
<jeffrey.osier-mixon@...> wrote:

Hi Brian - both bitbake and pseudo are part of the Yocto toolset. The
standard bitbake from the package manager on your host is not the correct
one. Make sure you have set your environment properly by sourcing the
build-env script, and it should be set correctly.
As Jason says, set BBPATH in your project directory in conf/local.conf
How did you download the tools, tarball or git?  I find it easiest to
do this:
git clone git://git.yoctoproject.org/poky.git
Note that responses may be delayed on a US holiday weekend :)
On Sat, Sep 3, 2011 at 1:48 PM, Jason Kridner
<jkridner@...> wrote:

On Sat, Sep 3, 2011 at 2:43 PM, Brian Duffy <brduffy@...> wrote:
Hi Yocto group. I am new to Yocto. I followed the starters guide and
When
running bitbake I get some errors. first it complains that pseudo is
not
available but required, and then it complains that bbpath is not
set. What
is pseudo?
Google should have helped you with this question:
http://www.yoctoproject.org/projects/pseudo.

I believe the primary purpose is to be able to create files with root
ownership without root access.  This is critical for building your
file system.

I have sudo installed and setup to work for me, but I don't know
what pseudo is. Also, bitbake was not installed on my fresh install
of
Fedora 15 so I installed it through the package manager.
I doubt you want to do that, but I don't see anything in the
instructions provided to tell you where to get it either.

I guess that was
not included in the packages from the getting started guide. Where
do I set
the bbpath?
Did you edit conf/local.conf?

I followed the getting started guide and replaced the
appropriate commands with the ones from Davids blog post for the
latest
release.

thnx
Brian
--
Duff

_______________________________________________
yocto mailing list
yocto@...
https://lists.yoctoproject.org/listinfo/yocto

_______________________________________________
yocto mailing list
yocto@...
https://lists.yoctoproject.org/listinfo/yocto


--
Jeff Osier-Mixon http://jefro.net/blog
Yocto Project Community Manager @Intel http://yoctoproject.org


--
Duff


--
Jeff Osier-Mixon http://jefro.net/blog
Yocto Project Community Manager @Intel http://yoctoproject.org


--
Jeff Osier-Mixon http://jefro.net/blog
Yocto Project Community Manager @Intel http://yoctoproject.org


--
Duff

_______________________________________________
yocto mailing list
yocto@...
https://lists.yoctoproject.org/listinfo/yocto

Join yocto@lists.yoctoproject.org to automatically receive all group messages.