[meta-security][PATCH 2/2] nmap: fix build issue.


Armin Kuster
 

ncat/ncat_lua.c:174: undefined reference to `lua_remove'

ncat/ncat_lua.c:167: undefined reference to `lua_insert'

use internal lua support

Signed-off-by: Armin Kuster <akuster808@...>
---
recipes-security/nmap/nmap_6.47.bb | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)

diff --git a/recipes-security/nmap/nmap_6.47.bb b/recipes-security/nmap/nmap_6.47.bb
index c0b0650..e9ce1c9 100644
--- a/recipes-security/nmap/nmap_6.47.bb
+++ b/recipes-security/nmap/nmap_6.47.bb
@@ -13,7 +13,7 @@ SRC_URI[sha256sum] = "8fa11e9e203ce2d81a207db5ca4f110a525f6c01c1dd0018325a7112a5

inherit autotools-brokensep pkgconfig distro_features_check

-PACKAGECONFIG = "ncat nping ndiff pcap lua"
+PACKAGECONFIG = "ncat nping ndiff pcap"
PACKAGECONFIG += " ${@bb.utils.contains("IMAGE_FEATURES", "x11-base", "zenmap", "", d)}"

PACKAGECONFIG[pcap] = "--with-pcap=linux, --without-pcap, libpcap, libpcap"
@@ -24,14 +24,12 @@ PACKAGECONFIG[nping] = ",--without-nping,"
PACKAGECONFIG[ncat] = ",--without-ncat,"
PACKAGECONFIG[ndiff] = ",--without-ndiff,"

-#use nmap's Included or system's libs
-PACKAGECONFIG[lua] = "--with-liblua=${STAGING_LIBDIR}/.., --without-liblua, lua"
PACKAGECONFIG[pcre] = "--with-libpcre=${STAGING_LIBDIR}/.., --with-libpcre=included, libpre"

#Add gui
PACKAGECONFIG[zenmap] = "--with-zenmap, --without-zenmap, gtk+ python-core python-codecs python-io python-logging python-unittest python-xml python-netclient python-doctest python-subprocess python-pygtk, python-core python-codecs python-io python-logging python-netclient python-xml python-unittest python-doctest python-subprocess python-pygtk gtk+"

-EXTRA_OECONF = "--with-libdnet=included --with-liblinear=included --without-subversion"
+EXTRA_OECONF = "--with-libdnet=included --with-liblinear=included --without-subversion --with-liblua=included"

do_configure() {
autoconf
--
2.3.5

Join yocto@lists.yoctoproject.org to automatically receive all group messages.