Fw: problem with ADT


Ed Vidal
 

I might of sent to wrong mailing list sorry!
 
Edward Vidal Jr. e-mail develone@... 915-595-1613


On Wednesday, August 19, 2015 9:47 AM, Edward Vidal <develone@...> wrote:


Hello all,
I need to cross compile several packages which I do not have bitbake recipes.

I have added several items to core-image-sato.  After creating the image I do the following to create a tool chain:
1. "bitbake core-image-sato -c populate_sdk"
(Then I setup the tool chain)
2. "sudo poky-glibc-x86_64-core-image-sato-cortexa7hf-vfp-vfpv4-neon-toolchain-1.8+snapshot.sh" which was created with the step 1
3. "source /opt/poky/1.8+snapshot/environment-setup-cortexa7hf-vfp-vfpv4-neon-poky-linux-gnueabi"
4. "./configure --disable-lua --enable-opencv=no --disable-libgcrypt --enable-run-as-root ${CONFIGURE_FLAG}
Most of the packages I have tried I get this warning.

configure: WARNING: unrecognized options: --with-libtool-sysroot

From the ADT manual section 5.1.2 I tried the following.
I am have trouble with the lines understanding the lines
aclocal -I ${OECORE_NATIVE_SYSROOT}/usr/share/aclocal \
[-I dir_containing_your_project-specific_m4_macros]

5.)
libtoolize --automake
aclocal -I ${OECORE_NATIVE_SYSROOT}/usr/share/aclocal \
[-I /home/vidal/wkg/adt_tests/vlc-2.1.4/m4]
autoconf
autoheader
automake -a
6.)  (Running the command step 4 the configure warning is gone)
libvlc configuration
--------------------
version               : 2.1.4
system                : linux
architecture          : arm
optimizations         : yes
vlc aliases           : cvlc rvlc qvlc svlc nvlc

To build vlc and its plugins, type `make', or `./compile' if you like nice colors.
When I try to do the make I get the following error.

vidal@ws009:~/wkg/adt_tests/vlc-2.1.4$ make
CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/bash /home/vidal/wkg/adt_tests/vlc-2.1.4/autotools/missing aclocal-1.14 -I m4
/home/vidal/wkg/adt_tests/vlc-2.1.4/autotools/missing: line 81: aclocal-1.14: command not found
WARNING: 'aclocal-1.14' is missing on your system.
         You should only need it if you modified 'acinclude.m4' or
         'configure.ac' or m4 files included by 'configure.ac'.
         The 'aclocal' program is part of the GNU Automake package:
         <http://www.gnu.org/software/automake>
         It also requires GNU Autoconf, GNU m4 and Perl in order to run:
         <http://www.gnu.org/software/autoconf>
         <http://www.gnu.org/software/m4/>
         <http://www.perl.org/>
make: *** [aclocal.m4] Error 127

Thanks in advance.

 
Edward Vidal Jr. e-mail develone@... 915-595-1613


Join yocto@lists.yoctoproject.org to automatically receive all group messages.