Re: e100 driver does not build


Saxena, Rahul <rahul.saxena@...>
 

Yes, I had noticed that it is part of intel-1xxxx feature also.

I tend to think that it is better to separate out CONFIG_E100 option from intel-1xxxx
I think that platforms that want 1G/10G enabled would not need 10/100 driver

It means that config option was never set or got turned off because of
unmet depencies <<

However I am not sure if this works in all cases as I did not see
"# CONFIG_E100 is not set" even when its dependent configurations were not satisfied

Rahul

-----Original Message-----
From: Zanussi, Tom
Sent: Thursday, September 01, 2011 11:22 AM
To: Saxena, Rahul
Cc: yocto@...
Subject: Re: [yocto] e100 driver does not build

On Thu, 2011-09-01 at 11:11 -0700, Saxena, Rahul wrote:
Yes, the problem was due to missing dependent options..
I had incorrectly assumed that dependent options would get pulled in
or perhaps a error would be generated.
It worked after I added following 3 options stated as dependent options
in a Kernel configuration database that I saw:

CONFIG_ISA
CONFIG_EISA
CONFIG_NET_PCI

I am still iterating to check if all three of the above are really needed or
or if just the CONFIG_NET_PCI option is needed.

I had enabled the option using a .cfg file. Also checking again to see if a warning
gets generated when the dependent options are not included.
Note that it's also part of the intel-1xxxx feature, which is basically
there for reusability - they were all together in a bunch of BSPs so I
moved them into a feature. I'm wondering whether we want to break them
up or at least create a separate e100 feature.

BTW what does a message such as following in the .config file mean ?

"CONFIG_xxxxx is not set"
It means that config option was never set or got turned off because of
unmet depencies.

Tom


Thanks
Rahul

-----Original Message-----
From: Bruce Ashfield [mailto:bruce.ashfield@...]
Sent: Wednesday, August 31, 2011 6:27 PM
To: Zanussi, Tom
Cc: Saxena, Rahul; yocto@...
Subject: Re: [yocto] e100 driver does not build

On 11-08-31 7:18 PM, Tom Zanussi wrote:

On Wed, 2011-08-31 at 16:04 -0700, Saxena, Rahul wrote:
I am unable to get the e100 driver to build for my BSP.

I have configured to build it as a module. I do not see the e100.ko
file being generated nor does

CONFIG_E100 appear in the generated .config file in my build area.



However I do see the driver source file e100.c in
tmp/work/bspname-poky-linux/linux-yocto-3.0.3+git1
+xxxx ../linux/drivers/net



I do not have any problems with other drivers (igb, E1000 etc) that I
have configured in exactly similar way.



Any insight on this issue ?
It's probably missing another option it depends on e.g. is
CONFIG_NET_PCI and CONFIG_MII enabled in your .config?
This is most likely what it is.

Out of curiosity, how did you enable the option ? Via a config fragement
(.cfg file) or via menuconfig .. or something else?

If you tried to set something via a fragment and it doesn't make it to
the final .config, you should see a warning during the kernel build
phase.

Cheers,

Bruce


Tom



Thanks

Rahul


_______________________________________________
yocto mailing list
yocto@...
https://lists.yoctoproject.org/listinfo/yocto
_______________________________________________
yocto mailing list
yocto@...
https://lists.yoctoproject.org/listinfo/yocto

Join yocto@lists.yoctoproject.org to automatically receive all group messages.