gtkwave recipe fails in do_configure


Ed Vidal
 

Hello All,

I am trying to add gtkwave with a bitbake recipe
gtkwave_3.6.66.bb found at https://github.com/develone/raspberrypi2_yocto.git in the folder
receipe_gtkwave.
I need to add the following trying to get do_configure working.

EXTRA_OECONF = "--with-tcl=/home/vidal/wkg/yocto/RaspberryPi2/poky/build/tmp/sysroots/raspberrypi2/usr/lib --with-tk=/home/vidal/wkg/yocto/RaspberryPi2/poky/build/tmp/sysroots/raspberrypi2/usr/lib"

I tried replacing /home/vidal/wkg/yocto/RaspberryPi2/poky/build with ${BUILDDIR}.
I still get the error

| checking for Tcl configuration... configure: error: /tmp/sysroots/raspberrypi2/usr/lib directory doesn't contain tclConfig.sh

I get further with the full path as above.
Which leads to a new error.
ERROR: This autoconf log indicates errors, it looked at host include and/or library paths while determining system capabilities.
Rerun configure task after fixing this. The path was '/home/vidal/wkg/yocto/RaspberryPi2/poky/build/tmp/work/cortexa7hf-vfp-vfpv4-neon-poky-linux-gnueabi/gtkwave/3.6.66-r0/build'
ERROR: Function failed: do_qa_configure
ERROR: Logfile of failure stored in: /home/vidal/wkg/yocto/RaspberryPi2/poky/build/tmp/work/cortexa7hf-vfp-vfpv4-neon-poky-linux-gnueabi/gtkwave/3.6.66-r0/temp/log.do_configure.22672
ERROR: Task 5 (/home/vidal/wkg/yocto/RaspberryPi2/poky/meta/recipes-devtools/gtkwave/gtkwave_3.6.66.bb, do_configure) failed with exit code '1'

I tried autotools-brokensep instead of autotools same results.

Thanks in advance.
 
Edward Vidal Jr.
e-mail develone@...
915-595-1613

Join yocto@lists.yoctoproject.org to automatically receive all group messages.