linux-yocto 3.0.1 upgrade broke PREFERRED_VERSION setting in BSPs


Darren Hart <dvhart@...>
 

We have just rolled out PREFERRED_VERSION="3.0+git%", and these now fail
with messages like:

NOTE: preferred version 3.0+git% of linux-yocto not available (for item
virtual/kernel)

I could patch everything really quick to use 3.0.1+git%... but 3.0.2 was
just released and I'd have to do it again tomorrow. For 2.6.37, the
LINUX_VERSION remained the same across point releases. I recommend we do
the same for 3.0. I really don't want to have to go through and update
all the PREFERRED_VERSIONs in addition to all the SRCREVs everytime a
point release comes out.

--
Darren Hart
Intel Open Source Technology Center
Yocto Project - Linux Kernel

Join {yocto@lists.yoctoproject.org to automatically receive all group messages.