Remote Debug Issue

Wy kevinthesun <kevinthesunwy@...>

Hi, I am trying to remote debug on my Atmel SAMA5D3 Xplained board which "Poky (Yocto Project Reference Distro) 1.5.1" is prebuilt. First I tried to use TCP/IP. I connected my board to my laptop and type "ifconfig", I got following information:
eth0      Link encap:Ethernet  HWaddr 2e:da:b6:48:b6:47                       
          inet6 addr: fe80::2cda:b6ff:fe48:b647/64 Scope:Link                  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                   
          RX packets:3 errors:0 dropped:0 overruns:0 frame:0                   
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0                 
          collisions:0 txqueuelen:1000                                         
          RX bytes:138 (138.0 B)  TX bytes:328 (328.0 B)                       
          Interrupt:26 Base address:0x8000                                     
lo        Link encap:Local Loopback                                            
          inet addr:  Mask:                                  
          inet6 addr: ::1/128 Scope:Host                                       
          UP LOOPBACK RUNNING  MTU:65536  Metric:1                             
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0                   
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0                 
          collisions:0 txqueuelen:0                                            
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

It seems there is only ipv6 address for eth0. Then I type "gdbserver localhost:2001 Test3", I got :
Process Test3 created; pid = 937                               
Listening on port 2001

Then on my laptop I started arm-poky-linux-gnueabi-gdb of 1.5.1 toolchain. In the gdb command line I typed "target remote fe80::2cda:b6ff:fe48:b647:2001". I got error information :
fe80: unknown host
fe80::2cda:b6ff:fe48:b647:2001: No such file or directory.

Actually I can use this ipv6 address to establish ssh remote target in eclipse, so I don't know why it doesn't work for remote debug using TCP/IP.

After that I tried to use serial port to establish remote debug. I connect my board to laptop through usb serial port. When I start minicom in terminal, I get "Poky (Yocto Project Reference Distro) 1.5.1 sama5d3_xplained /dev/ttyGS0". So I typed "gdbserver /dev/ttyGS0 Test3". Then in gdb command line I typed "target remote /dev/ttyACM0". "ttyACM0" is the port of the usb serial port. However, in the minicom window it kept printing:

Remote dRemote debugging using /dev
       Remote side has terminated connection.  GDBRemote side has terminated connectiRemote side has terminated coRemote debugging using /dev/ttyGS0
                                                                                                                                                    readchar: Input/output error

Now I can't remote debug on my board.

Thanks for any help!


Join { to automatically receive all group messages.