Re: Cannot run simple binary executable file

Khem Raj

On Tue, Oct 7, 2014 at 4:07 AM, Wy kevinthesun <kevinthesunwy@...> wrote:
Hi, I am new to Yocto Project and learning to develop software on Atmel
SAMA5D3 Xplained board, on which Yocto 1.5.1 is pre-built. I followed the
instructions and got the 1.6.1 toolchain

I can compile the simple HelloWorld program and binary file is made. Then I
copied the binary file

into board and tried to run it. However, when I changed to the file located
directory and type

"./Hello", it returned "sh: ./Hello: No such file or directory". Then I
tried "sh Hello", it gave

me "Hello: Hello: cannot execute binary file ". If I type "file Hello", it
gives "Hello: ELF 32-bit
LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked (uses
shared libs), for GNU/Linux 2.6.16,
BuildID[sha1]=9933a2d2ce212099c5f9902a8e612c1423e136da, not stripped". I
googled and someone

said the problem may be the toolchain. Then I tried 1.3, 1.5.1 toolchain for
arm, but still same

error. Could you please help me about this problem?
whats running on board ? make sure that it has ldso in same directory
and name as encoded
in binary. it seems there is a mismatch. Try

/lib/ ./a.out

does that run ?

Thank you!


yocto mailing list

Join to automatically receive all group messages.