Re: kernel panic - not syncing: No init found

Francis Meyvis <francis.meyvis@...>


When I mounted the root image on loop back device, I actually ran the init program. It executed and complained about missing params. I tried with the 5, like for network connected inittab. Then init complained there was no /dev/initctl. So combining this with the replies I got, I think the latest /sbin/init on yocto master does not support a default run level? I think the architecture of my root image is for x86 cause my pc could exec it.

Any suggestions on how to continue?


On Aug 1, 2011 6:04 AM, "Bruce Ashfield" <bruce.ashfield@...> wrote:
> On 11-07-31 11:30 PM, Tom Zanussi wrote:
>> On Sun, 2011-07-31 at 19:42 -0700, Bruce Ashfield wrote:
>>> On 11-07-31 3:44 PM, Francis Meyvis wrote:
>>>> Hello,
>>>> I probably miss something trivial.
>>>> I cloned the git://
>>>> I build on a 64 bit machine a qemux86-64
>>>> (. ./oe-init-build-env qemux86-64 and changing the conf/local.conf)
>>>> I build the core-image-sato& core-image-minimal.
>>>> Then I try to run with
>>>> runqemu qemux86-64 core-image-sato ext3
>>>> But both sato and minimal give me this message:
>>>> Kernel panic - not syncing: No init found.
>>>> As runqemu showed me the full command line I tried to add the --append
>>>> command line option
>>>> init=/sbin/init and /sbin/init.sysvinit
>>>> But that did not help (there's a message saying Failed to execute
>>>> /sbin/init. Attempting defaults...)
>>>> I verified by mounting these ext3 images on a loop device that there's
>>>> really a /sbin/init present.
>>>> Can somebody tell what I'm doing wrong?
>>> Can you send a full bootlog, or paste it somewhere accessible ? It's hard
>>> to say what's with the information you've given.
>>> Is this the latest yocto master ?
>>> If you are seeing that message it typically means that the the
>>> device that is being used as the root isn't ready (fixed by
>>> rootwait/rootdelay) or isn't supported (i.e. NFS root without
>>> the right ethernet device). Changing what init is, won't change
>>> the result if either one of those is the case.
>> I'm also seeing this on both sugarbay and jasperforest with the latest
>> master. rootwait doesn't help.
>> rtc_cmos 00:07: setting system clock to 2010-01-02 05:35:34 UTC
>> (1262410534)
>> Freeing unused kernel memory: 720k freed
>> Failed to execute /init
>> Kernel panic - not syncing: No init found. Try passing init= option to
>> kernel.
>> See Linux Documentation/init.txt for guidance.
>> Pid: 1, comm: swapper Not tainted 3.0.0-rc7-yocto-standard+ #1
>> Call Trace:
>> [<ffffffff81541b77>] panic+0x9b/0x191
>> [<ffffffff81540862>] init_post+0xc0/0xc0
>> [<ffffffff8188bcef>] kernel_init+0x17b/0x17b
>> [<ffffffff8154b234>] kernel_thread_helper+0x4/0x10
>> [<ffffffff8188bb74>] ? start_kernel+0x377/0x377
>> [<ffffffff8154b230>] ? gs_change+0xb/0xb
>> I thought initially it had something to do with the -live image changes,
>> but reverting the two -live patches didn't help.
>> The problem seems to coincide with the tune file changes, but that may
>> be a red herring.
> Nope. I don't think it's a red herring:
> Both of these:
> Freeing unused kernel memory: 720k freed
> Failed to execute /init
> Indicate that the device came up and init was loaded, the kernel
> passed control to userspace and then things went bad. i.e. you just
> ran init of the wrong arch or something incompatible with the
> kernel support, etc.
> Since I'm having no trouble with old rootfs and new kernels, that's
> another sign. I'm assuming that old userspace's boot for you ?
> Bruce
>> Tom
>>> Cheers,
>>> Bruce
>>>> BTW is there any way to not have to run qemu with root permissions?
>>>> I ran the android emulator and it does not require me to be root.
>>>> Should I configure something on my Ubuntu machine to get qemu to function?
>>>> Thanks,
>>>> francis
>>>> _______________________________________________
>>>> yocto mailing list
>>>> yocto@...
>>> _______________________________________________
>>> yocto mailing list
>>> yocto@...

Join { to automatically receive all group messages.