do_populate_sdk error

mareczek <mareczek6415@...>


I ran into an error during do_populate_sdk

ERROR: Unable to install packages. Command '/yocto-daisy/build/tmp/sysroots/i686-linux/usr/bin/apt-get install --force-yes --allow-unauthenticated nativesdk-packagegroup-sdk-host packagegroup-cross-canadian-imx6riotboard' returned 100:
Reading package lists...
Building dependency tree...
Reading state information...
W: Unable to read /yocto-daisy/build/tmp/work/cortexa9hf-vfp-neon-poky-linux-gnueabi/meta-toolchain/1.0-r7/apt-sdk/preferences.d/ - DirectoryExists (2: No such file or directory)
E: Unable to locate package nativesdk-packagegroup-sdk-host

ERROR: Function failed: do_populate_sdk
ERROR: Logfile of failure stored in: /yocto-daisy/build/tmp/work/cortexa9hf-vfp-neon-poky-linux-gnueabi/meta-toolchain/1.0-r7/temp/log.do_populate_sdk.32319
ERROR: Task 7 (/yocto-daisy/meta/recipes-core/meta/, do_populate_sdk) failed with exit code '1'

I tried to find an answer, but without success. I tried to compile nativesdk-packagegroup-sdk-host and it was already compiled.

I was able to compile u-boot, kernel, kernel modules, dtb, rootfs and everythink works quite well, but now I'm stuck with this and have no clue how to solve this. If anyone knows how to make it working I would be very glad.

Thank you very much


Join { to automatically receive all group messages.