Re: 2.6.39 kernel and poky


Bryan Evenson
 

Maxwell,

 

Atmel has a Yocto meta layer over at http://www.github.com/linux4sam/meta-atmel.  Their layer was originally focused on the SAMA5 chipset, but has been since modified to include the SAM9x5 chipset.  I have a fork over at http://www.github.com/evensonbryan/meta-atmel that I’ve been using for my SAM9G25 board.  There is one kernel recipe that is using Atmel’s 3.6.9 kernel and another that uses Atmel’s 3.9 kernel.  The 3.6.9 kernel in my testing is the most stable and has the highest level of peripheral support, but I’ve been able to get both to run on the SAM9G25 evaluation board and our custom hardware.  Feel free to fork my layer or Atmel’s layer and add support for the 2.6.39 kernel.  Atmel has been accepting pull requests on additional features.

 

-Bryan Evenson

 

From: yocto-bounces@... [mailto:yocto-bounces@...] On Behalf Of Maxwell Bottiger
Sent: Friday, November 01, 2013 11:22 AM
To: yocto@...
Subject: [yocto] 2.6.39 kernel and poky

 

I have a custom kernel and drivers I built for an Atmel AT91SAM9x5ek system on a chip, and I'd like to use them with yocto to build a distribution.

The original documentation, support CD, etc are all based around an open embedded build from 2011, which doesn't seem to work any longer.  Yocto looks like a great alternative, but wants to build the 3.10 kernel, which I don't think supports this SoC any longer.  So, is there a straight forward method of building a standard Poky root filesystem, but with a custom recipe for the 2.6.39 kernel instead of the stock one?

Thanks for your help.

Join yocto@lists.yoctoproject.org to automatically receive all group messages.