Re: telnetd is not running with "core-image-basic"

Gary Thomas

On 2013-10-25 23:17, Amit Kumar wrote:
I tried to run the telnetd with "core-image-basic". I follow up the following step to enable the telnetd support in my layer.
I have build the latest inetutils recipe with my layer, the latest version of inteutils is "intetutils_1.9.1". I have build the packages successful.
But the telnetd is not available in my "core-image-basic". When i run the the image under QEMU, there is no telnetd under "/usr/sbin/" or "/usr/bin".
It's not present at all.

I have also tried to add the "initscript-telnetd" refer from meta-arago. But not succeed.

Please guild me- how can i will get it with my core-image-basic image. Am i missing any step here for that?
Building the package is not enough by itself. You need to get it added to the
image that you are using. This can be done either at build time or at run time.

To add the package at build time, simply add this to your local.conf:
CORE_IMAGE_EXTRA_INSTALL += "inetutils inetutils-telnetd"

Gary Thomas | Consulting for the
MLB Associates | Embedded world

Join { to automatically receive all group messages.