Re: Troubleshooting ERROR: Function 'Fetcher failure for URL: 'cvs://anoncvs:anoncvs@anoncvs.handhelds.org/cvs; module=apps/update-rc.d; tag=r0_7'?


Daryl Spitzer <daryl.spitzer@...>
 

Thanks Richard.

How do I find out where DL_DIR is pointing?

I found this line, commented out in conf/local.conf:

#DL_DIR ?= "${TOPDIR}/downloads"

It's not listed after I run `bitbake -k poky-image-sato`:

OE Build Configuration:
BB_VERSION = "1.11.0"
METADATA_BRANCH = "<unknown>"
METADATA_REVISION = "<unknown>"
TARGET_ARCH = "i586"
TARGET_OS = "linux"
MACHINE = "qemux86"
DISTRO = "poky"
DISTRO_VERSION = "1.0.1"
TARGET_FPU = ""

And there is no DL_DIR environment variable defined (after I run
`source poky-bernard-5.0.1/poky-init-build-env poky-5.0.1-build`).

There is a poky-5.0.1-build/downloads directory. I'll assume that's
it. But I'd like to learn how to find out without guessing.

--
Daryl

P.S. It looks like that was a safe assumption. The build has moved
past that point of failure.


On Thu, Jun 9, 2011 at 2:54 PM, Richard Purdie
<richard.purdie@...> wrote:
On Thu, 2011-06-09 at 11:32 -0700, Daryl Spitzer wrote:
I'm continuing to try to successfully build an image for the first
time, following the instructions in the Yocto Project Quick Start
(http://www.yoctoproject.org/docs/1.1/yocto-project-qs/yocto-project-qs.html).

As suggested in
https://lists.yoctoproject.org/pipermail/yocto/2011-June/001598.html,
I'm now trying http://www.yoctoproject.org/downloads/poky/poky-bernard-5.0.1.tar.bz2.
 And I'm following the instructions in
https://wiki.yoctoproject.org/wiki/Working_Behind_a_Network_Proxy,
including defining CVS_PROXY_HOST & CVS_PROXY_PORT in my local.conf
file.

But I'm getting the following error:

NOTE: fetch http://anoncvs@autobuilder.yoctoproject.org/sources/apps.update-rc.d_anoncvs.handhelds.org_r0_7_.tar.gz
NOTE: Fetch cvs://anoncvs:anoncvs@.../cvs;module=apps/update-rc.d;tag=r0_7
cvs [checkout aborted]: end of file from server (consult above messages if any)
ERROR: Function 'Fetcher failure for URL:
'cvs://anoncvs:anoncvs@.../cvs;module=apps/update-rc.d;tag=r0_7'.
Unable to fetch URL
cvs://anoncvs:anoncvs@.../cvs;module=apps/update-rc.d;tag=r0_7
from any source.' failed

(This is the contents of the logfile created in
poky-5.0.1-build/tmp/work/all-poky-linux/update-rc.d-0.7-r3/temp/log.do_fetch.16236.)

It's not clear to me if this is a proxy problem.

If I try `wget http://anoncvs@autobuilder.yoctoproject.org/sources/apps.update-rc.d_anoncvs.handhelds.org_r0_7_.tar.gz`,
I see the following:

$ wget http://anoncvs@autobuilder.yoctoproject.org/sources/apps.update-rc.d_anoncvs.handhelds.org_r0_7_.tar.gz
--2011-06-09 11:25:37--
http://anoncvs@autobuilder.yoctoproject.org/sources/apps.update-rc.d_anoncvs.handhelds.org_r0_7_.tar.gz
Resolving gateway... 149.199.33.100, 172.22.140.250
Connecting to gateway|149.199.33.100|:8080... connected.
Proxy request sent, awaiting response... 400 Bad Request
2011-06-09 11:25:37 ERROR 400: Bad Request.

But `wget http://autobuilder.yoctoproject.org/sources/apps.update-rc.d_anoncvs.handhelds.org_r0_7_.tar.gz`
(same as above, but s/anoncvs@//) succeeds:

 wget http://autobuilder.yoctoproject.org/sources/apps.update-rc.d_anoncvs.handhelds.org_r0_7_.tar.gz
--2011-06-09 11:29:39--
http://autobuilder.yoctoproject.org/sources/apps.update-rc.d_anoncvs.handhelds.org_r0_7_.tar.gz
Resolving gateway... 149.199.33.100, 172.22.140.250
Connecting to gateway|149.199.33.100|:8080... connected.
Proxy request sent, awaiting response... 200 OK
Length: 2475 (2.4K) [application/x-gzip]
Saving to: `apps.update-rc.d_anoncvs.handhelds.org_r0_7_.tar.gz'

100%[======================================>] 2,475       --.-K/s   in 0s

2011-06-09 11:29:39 (336 MB/s) -
`apps.update-rc.d_anoncvs.handhelds.org_r0_7_.tar.gz' saved
[2475/2475]


How do I troubleshoot or move past this?
To move past it, place the file you've downloaded into wherever DL_DIR
is pointing and also touch
apps.update-rc.d_anoncvs.handhelds.org_r0_7_.tar.gz.done to signify the
download is complete. It should them move you past that point.

As for the root cause, we should be discarding the username information
when trying mirrors. I'll have a look and see if I can work out a patch
for the fetcher to do that...

Cheers,

Richard

Join yocto@lists.yoctoproject.org to automatically receive all group messages.