Re: undefined reference to `pthread_getspecific' in perl-native_5.12.2.bb task do_compile?


Daryl Spitzer <daryl.spitzer@...>
 

Looks like we fixed this issue in our recent point release. Could you
try http://www.yoctoproject.org/downloads/poky/poky-bernard-5.0.1.tar.bz2 ?
I tried it, and am getting what I think is an unrelated error. I'll
start a new thread for that.

Shouldn't documentation references to
"http://www.yoctoproject.org/downloads/poky/poky-bernard-5.0.tar.bz2"
be changed to "http://www.yoctoproject.org/downloads/poky/poky-bernard-5.0.1.tar.bz"
(such as in http://www.yoctoproject.org/docs/1.1/yocto-project-qs/yocto-project-qs.html)?

Thanks Joshua and Gary.

--
Daryl


On Wed, Jun 8, 2011 at 4:57 PM, Joshua Lock <josh@...> wrote:
On Wed, 2011-06-08 at 06:48 -0700, Daryl Spitzer wrote:
Does this look familiar?  Why would I be getting these errors when
following the Yocto Project Quick Start instructions, without changes?
 Did I miss something?
It does not. However this is when trying to build perl-native, i.e. Poky
is trying to build its own version of Perl but linked against your
system libraries etc and is unable to find some pthread functions to
link to.

Can you tell us which distribution/version combination you are using?

Could be that we need to patch perl-native to -lpthread ?
Is your host Ubuntu 11.04 on x86 (not x86_64)?  There was a patch for this
that I'm not sure got back ported into Bernard.
Oops.  I forgot to provide those details...

My host is Ubuntu 11.04 64 bit:

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"
$ uname -m
x86_64

I ran `wget http://www.yoctoproject.org/downloads/poky/poky-bernard-5.0.tar.bz2`
(as directed in the Yocto Project Quick Start).  Does that 5.0
correspond to Yocto Project 1.0.1?
Hi Daryl,

Looks like we fixed this issue in our recent point release. Could you
try
http://www.yoctoproject.org/downloads/poky/poky-bernard-5.0.1.tar.bz2 ?

Cheers,
Joshua
--
Joshua Lock
       Yocto Build System Monkey
       Intel Open Source Technology Centre

Join yocto@lists.yoctoproject.org to automatically receive all group messages.