Re: linux-yocto defaulting to 3.4.52 for new qemuarmhf.conf


Elvis Dowson
 

On Aug 24, 2013, at 10:00 PM, Elvis Dowson <elvis.dowson@...> wrote:

I created a new qemuarmhf.conf, to build using armv7a vfp and neon.

In the linux-yocto_3.8.bb recipe, I explicitly specified SRCREV_machine_qemuarmhf and added qemuarmhf to the list of COMPATIBLE_MACHINES.

For some reason, it still refuses to build using kernel 3.8, and keeps defaulting to 3.4.52.

I know I can over-ride it in my local.conf by setting a PREFERRED_VERSION_virtual/linux ="3.8" , but I'd like to know what I've missed, to get it to work by default, without setting the over-ride in my local.conf.
Weird, even after setting PREFERRED_VERSION_virtual/linux ="3.8", it still picks up linux-yocto_3.4.bb recipe!

What am I failing to set or configure additionally to get it to work, as intended?

Best regards,

Elvis Dowson

Join yocto@lists.yoctoproject.org to automatically receive all group messages.