FW: cannot bitbake/build.compile tcf-agent for use with fsl-image-gui-sdk


Thanassis Silis <djnass_18@...>
 




From: djnass_18@...
To: jessica.zhang@...
Subject: RE: [yocto] cannot bitbake/build.compile tcf-agent for use with fsl-image-gui-sdk
Date: Thu, 20 Jun 2013 17:48:14 +0000

Hi jessica,
I will try with SSH too,
but for now it seems there are some bugs with "packages_deb " being the primary packaging scheme.
so apart from adding
    IMAGE_INSTALL_append = " tcf-agent"

moving "packages_rpm" to be the primary scheme ended up succeeding in making an image that had tcf-agent included.

Thank you for your help.
I will post back when I generate an image with openssh (I have dropbear enabled ATM).


From: jessica.zhang@...
To: djnass_18@...; meta-freescale@...; yocto@...
Subject: RE: [yocto] cannot bitbake/build.compile tcf-agent for use with fsl-image-gui-sdk
Date: Wed, 19 Jun 2013 16:25:03 +0000

Hi Thanassis,

 

I don’t know why tcf-agent  is not included in your sdk image.  But you also can use ssh to create a rse remote connection that allows you to do remote interaction.  When you create remote connection, instead of choosing tcf, use ssh.  You’ll need openssh in your target image for this to work.

 

Cheers,

Jessica

 

From: yocto-bounces@... [mailto:yocto-bounces@...] On Behalf Of Thanassis Silis
Sent: Tuesday, June 18, 2013 6:56 AM
To: meta-freescale@...; yocto@...
Subject: [yocto] cannot bitbake/build.compile tcf-agent for use with fsl-image-gui-sdk

 

Hello everyone,
it seems tcf-agent is not provided. Not even in the -sdk image I created. And that is where my problems start:

using this in my local.conf: IMAGE_INSTALL_append = " tcf-agent"
I expected to be able to automate the process of generating the tcf-agent and deploying it in my image with command:

bitbake fsl-image-gui-sdk


this fails with:

| Reading package lists...
| Building dependency tree...
| Reading state information...
| Some packages could not be installed. This may mean that you have
| requested an impossible situation or if you are using the unstable
| distribution that some required packages have not yet been created
| or been moved out of Incoming.
| The following information may help to resolve the situation:
|
| The following packages have unmet dependencies:
|  packagegroup-core-x11-base : Depends: packagegroup-core-x11-utils but it is not going to be installed
| W: Ignoring Provides line with DepCompareOp for package pkgconfig__pkg-config__
| W: You may want to run apt-get update to correct these problems
| E: Unable to correct problems, you have held broken packages.
| ERROR: Function failed: do_rootfs (see /home/nass/yocto/build/tmp/work/imx6qsabrelite-poky-linux-gnueabi/fsl-image-gui-sdk/1.0-r0/temp/log.do_rootfs.26945 for further information)
ERROR: Task 7 (/home/nass/yocto/sources/meta-fsl-demos/recipes-fsl/images/fsl-image-gui-sdk.bb, do_rootfs) failed with exit code '1'
NOTE: Tasks Summary: Attempted 7418 tasks of which 7417 didn't need to be rerun and 1 failed.
No currently running tasks (7417 of 7419)

Summary: 1 task failed:
  /home/nass/yocto/sources/meta-fsl-demos/recipes-fsl/images/fsl-image-gui-sdk.bb, do_rootfs
Summary: There was 1 ERROR message shown, returning a non-zero exit code.



I then went on to try and compile it manually:

bitbake fsl-image-gui-sdk -c compile tcf-agent
bitbake fsl-image-gui-sdk -c deploy


this fails with:

ERROR: Task do_deploy does not exist for target fsl-image-gui-sdk

Then I tried compiling it manually using this info http://www.yoctoproject.org/docs/current/adt-manual/adt-manual.html#getting-the-images , by sourcing my toolchain from /opt/poky/1.4.1/env* file, and then
runnning 'make' in org.eclipse.tcf.agent/agent/ . I explicitly assign the $MACHINE variable to be 'arm' in the beginning of the Makefile.inc.

this fails with

arm-poky-linux-gnueabi-gcc  -march=armv7-a -mthumb-interwork -mfloat-abi=softfp -mfpu=neon --sysroot=/opt/poky/1.4.1/sysroots/armv7a-vfp-neon-poky-linux-gnueabi  -O2 -pipe -g -feliminate-unused-debug-types -g -D_FILE_OFFSET_BITS=64 -Wall -Wmissing-prototypes -I./. -I./system/GNU/Linux -I./machine/arm -o obj/GNU/Linux/arm/Debug/tcf/framework/channel_tcp.o -c tcf/framework/channel_tcp.c
tcf/framework/channel_tcp.c:38:27: fatal error: openssl/ssl.h: No such file or directory
compilation terminated.

 
At this point I have run out of ideas about how to prepare tcf-agent to install on my sabrelite fsl-image-gui-sdk rootfs....
Any help would be most welcome.

for example in the 1st case how could I run apt-get as is suggested in a manner that would be appropriate to update yocto sources?

Thank you.

Join yocto@lists.yoctoproject.org to automatically receive all group messages.