Re: No crosscompiler in Toolchain

DAMARLA Satya Swaroop <satyaswaroop.damarla@...>

This thread is closed as I have identified that the error is becuase of issues concerned with using the same build environment for two build , one that uses sysvinit and the other that uses systemd.... So, I deleted the tmp and rebuild the toolchain and it got solved..

On Fri, Jun 14, 2013 at 7:40 PM, Zhang, Jessica <jessica.zhang@...> wrote:

Hi Satya,


If bitbake meta_toolchain didn’t generate the correct cross compiler, then it’s a bug, would you mind open a bug in for us with detailed info e.g. what release, what are the cross toolchain that you were trying to build, etc?  As to your image particular toolchain, since we’re lacking the data how you customize your image, it’s really hard for us to nail down your issue unfortunately.





From: DAMARLA Satya Swaroop [mailto:satyaswaroop.damarla@...]

Sent: Friday, June 14, 2013 4:21 AM
To: Zhang, Jessica
Cc: Jeff Osier-Mixon; yocto@...

Subject: Re: [yocto] No crosscompiler in Toolchain


Hi Everyone,


I solved the issue, but I don't know if its right or wrong but for the moment I am happy... The following didnot work for me


bitbake core-image-skidata -c populate_sdk


bitbake meta-toolchain


but bitbake meta-toolchain-sdk  worked for me and created a toolchain with the crosscompiler... I have no idea why the others didnot create a toolchain with cross compiler for me. I think this has to be discussed in more detail..


For now have a wonderful weekend


Warm regards from Austria,



On Thu, Jun 13, 2013 at 9:16 AM, DAMARLA Satya Swaroop <satyaswaroop.damarla@...> wrote:



Any updates on this issue why there is no cross compiler in the toolchain we build... I think this is pretty important unfortunately I am not able to find the cause.. Help is deeply appreciated..





On Wed, Jun 12, 2013 at 7:12 AM, DAMARLA Satya Swaroop <satyaswaroop.damarla@...> wrote:

Hi Jessica,


By the sentence "No crosscompiler for my target installed in my toolchain", I mean I don't find the binaries for crosscompiling which are usually present in the directory as shown below


damarla@linuxbuildsrv:~/yocto/myToolchain/sysroots/x86_64-pokysdk-linux/usr/bin$ ls

aclocal        autoreconf        flash2raw.terrier       opkg-key    pseudolog  qemu-mipsel       qemu-system-mipsel  raw2flash.terrier        runqemu-ifup

aclocal-1.12   autoscan          gnu-configize           perl        qemu-arm   qemu-mips.real    qemu-system-ppc     runqemu                  runqemu-internal

autoconf       autoupdate        ifnames                 perl5.14.3  qemu-ga    qemu-nbd          qemu-system-x86_64  runqemu-addptable2image  tunctl

autoheader     dtc               libtoolize              perl.real   qemu-i386  qemu-ppc          qemu-x86_64         runqemu-export-rootfs    update-alternatives

autom4te       flash2raw.akita   m4                      pkg-config  qemu-img   qemu-system-arm   raw2flash.akita     runqemu-extract-sdk      x86_64-pokysdk-linux-libtool

automake       flash2raw.borzoi  oe-find-native-sysroot  pseudo      qemu-io    qemu-system-i386  raw2flash.borzoi    runqemu-gen-tapdevs

automake-1.12  flash2raw.spitz   opkg-cl                 pseudodb    qemu-mips  qemu-system-mips  raw2flash.spitz     runqemu-ifdown



I don't have a directory and the list is empty


damarla@linuxbuildsrv:~/yocto/myToolchain/sysroots/x86_64-pokysdk-linux/usr/bin$ ls -la| egrep '^d'

drwxr-xr-x 2 damarla damarla    4096 Jun 11 14:27 .

drwxr-xr-x 7 damarla damarla    4096 Jun 11 14:15 ..


I want to know what could be the potential issue that my toolchain has no crosscompiler for my target





On Tue, Jun 11, 2013 at 9:05 PM, Zhang, Jessica <jessica.zhang@...> wrote:

Hi Satya,


What is your cross compiler that you said it’s not installed? For example, on my development host e.g. x86, after I install the toolchain, there’s an environment-setup-*** file, inside it specifies what is your cross compiler, e.g. arm-poky-linux-gnueabi-gcc for my case, after I source the environment file, and do which arm-poky-linux-gnueabi-gcc, I can see it’s under path_to_toolchain/sysroots/i686_pokysdk_linux/usr/bin/armv5te-poky-linux-gnueabi/arm-poky-linux-gnueabi-gcc… so you’re seeing things differently?




From: yocto-bounces@... [mailto:yocto-bounces@...] On Behalf Of DAMARLA Satya Swaroop
Sent: Tuesday, June 11, 2013 11:55 AM
To: Jeff Osier-Mixon; yocto@...
Subject: Re: [yocto] No crosscompiler in Toolchain


First I am sorry about the Gentlemen.... Next time it would be Ladies & Gentlemen... ;-)


Let me explain the situation better ... core-image-skidata (arm) is customized image which I build and I want to build a toolchain for this image on my x86_64 with should consist of cross compiler (which I assume a toolchain should contain). The build for the toolchain went successfull but when I installed the toolchain on my system, I didnot find the crosscompiler installed...


Hope you understood my problem..





On Tue, Jun 11, 2013 at 7:48 PM, Jeff Osier-Mixon <jefro@...> wrote:

On Tue, Jun 11, 2013 at 5:59 AM, DAMARLA Satya Swaroop
<swaroop.damarla@...> wrote:
> Gentlemen! We have a problem here...

Not all here are gentlemen :)

> I compiled the toolchain using the command bitbake core-image-skidata -c
> populate_sdk and installed the toolchain but I have to tell you that I dont
> see any cross-compiler installed with the toolchain...
> Any guesses what could be the reason.. The image is customized x11 image...

I'm not sure I understand. It looks like you are using Host A to build
a toolchain and install it into an image (core-image-skidata) on
Target A. Are you then expecting to use Target A as Host B to compile
for Target B?  Is it possible that the skidata image recipe does not
contain the cross-compiler recipes?

Jeff Osier-Mixon
Yocto Project Community Manager @Intel





Join { to automatically receive all group messages.