internal compiler error with qt building poky-image-lsb-sdk


Robert Berger <gmane@...>
 

Hi,

The short version:

With commit f8539239bc473279cc475b07c22e1e96514c6d2f Thu Mar 24 13:03:50
2011 +0000 both beagleboard and routerstationpro fail to build due to an
internal compiler error:

../../include/QtCore/../../src/corelib/tools/qstring.h:187:17: note: the
mangling of 'va_list' has changed in GCC 4.4
graphicsview/qgridlayoutengine.cpp:1553:1: internal compiler error: in
build_abbrev_table, at dwarf2out.c:9806

This seems to be due to the gcc version used and how the code is written
in qt.

The longer version:

http://bugzilla.pokylinux.org/show_bug.cgi?id=932

Regards,

Robert..."C treats you like a consenting adult. Pascal treats you like a
naughty child. Ada treats you like a criminal." -- (Bruce Powel Douglass)

My public pgp key is available at:
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0x90320BF1

Join yocto@lists.yoctoproject.org to automatically receive all group messages.