Re: where is the Sysroot Location?

Lu, Lianhao <>

Hi Simon,


Since you have run “poky-extract-sdk”, I assume you already had the rootfs. The poky-extract-sdk is meant to extract the rootfs from a tarball to a user specified directory, which should be specified  as the sysroot in the plug-in.


To build a rootfs, you may want to run “bitbake poky-image-sdk”(for yocto 0.9) or “bitbake poky-image-sato-sdk” (for current git master), and use the poky-extract-sdk to extract the corresponding rootfs located in ${TMPDIR}/deploy/images.


Best Regards,



From: Li, Simon
Sent: Wednesday, March 23, 2011 5:27 PM
To: Lu, Lianhao; yocto@...
Subject: RE: where is the Sysroot Location?


Hi, Lianhao,

Thanks for your replying.

Actually, I already did “bitbake meta-ide-support”.

And I use poky-extract-sdk to extract the pseudo.

However, when I clicked Run->External Tools->qemu_i586-poky-linux.

After kernel booting up , I got kernel panic because kernel panic – not syncing, init not Found.

According to the status, I think I setup the wrong Sysroot location.

As the screenshot,



Since I did not find any full root file system after finishing the build, could you tell me where I can make the full root file system?

Thanks very much.


Best Regards,



From: Lu, Lianhao
Sent: Tuesday, March 22, 2011 6:36 PM
To: Li, Simon; yocto@...
Subject: RE: where is the Sysroot Location?


Hi Simon,


Before using the poky tree mode, you need to run “bitbake meta-ide-support” within the poky tree in a terminal. The eclipse plug-in needs the output of that to determine several configuration options for cross compilation.


Best Regards,



From: yocto-bounces@... [mailto:yocto-bounces@...] On Behalf Of Li, Simon
Sent: Tuesday, March 22, 2011 11:48 AM
To: yocto@...
Subject: [yocto] where is the Sysroot Location?


To whom may concern,

I tried configure the Yocto SDK.

Firstly, I need to config cross compiler options.

I choose Pocky Tree Mode.

I always get the error message, said, Yockto Configuration Error!

Specification Poky Tree Toolchain Root does not contain any toolchain yet.

Please run “bitbake meta-ide-support” to build the toolchain.”


However, I assigned the toolchain directory which gcc resides, I still get this prompt message.

Could anyone please tell me what I have done wrong.



Simon Li

Intel Software & Service Group

B1 #205 Tun-Hwa North Rd, Taipei, Taiwan








Join { to automatically receive all group messages.