Re: Raspberry Pi do_fetch failure

Andrei Gherzan

On Mon, Jan 7, 2013 at 7:53 PM, Robert P. J. Day <rpjday@...> wrote:
On Mon, 7 Jan 2013, Alex J Lennon wrote:

> > Alex
> >
> > Thanks I was able to download and build core-image-sato
> >
> > Having discussion with github but no real solution yet.
> >
> Hi Ed, I'm glad that was useful in moving you forward. I did some
> googling and this issue with GitHub does seem to pop up
> intermittently. My gut feeling is there's some kind of resource
> issue, perhaps related to compression on the server. Some of the
> comments do seem to suggest that disabling compression helps.
> I do wonder if someone from the Yocto project is able to fork the
> RPi linux repo and mirror either the Git repo itself or an archive
> of that (and indeed if that's a good idea)?

  is there a current diagnosis for this github fetching irritation?  i
thought i'd take a shot at building for rpi and, like others, i failed
to fetch the kernel from github:

WARNING: Failed to fetch URL
attempting MIRRORS if available
ERROR: Fetcher failure: Fetch command failed with exit code 128,
Cloning into bare repository

fatal: The remote end hung up unexpectedly
fatal: early EOF
fatal: index-pack failed

ERROR: Function failed: Fetcher failure for URL:
Unable to fetch URL from any source.
ERROR: Logfile of failure stored in:
ERROR: Task 62
do_fetch) failed with exit code '1'

  thoughts?  i've tried a few times this morning, same result each


I tested it today too and i ended up using a shared download directory. The problem is at github. Will submit a bug (even if somebody already did). More bugs - many changes to get it fixed soon. Keep you posted.


Join { to automatically receive all group messages.