Re: Host authenticity failures

Khem Raj

On 01/04/2013 06:50 PM, Stewart, David C wrote:
Is this still a problem?

From: <Thornburg>, Christopher A <christopher.a.thornburg@...<mailto:christopher.a.thornburg@...>>
Date: Wednesday, January 2, 2013 2:48 PM
To: "yocto@...<mailto:yocto@...>" <yocto@...<mailto:yocto@...>>
Subject: [yocto] Host authenticity failures

I’ve started getting the following error from bitbake when it’s trying to access my git server:

The authenticity of host '[<githost>]:<port>([<IP>]:<port>)' can't be established.
DSA key fingerprint is <blah>

I understand this error means that the server’s key has probably changed, and I understand in general how to deal with this via SSH config. When I manually ssh’d to the server the first time after receiving the error, I got the same message, as expected. I entered “yes” and tried again to verify that the error went away. It did. I think ran bitbake again and got the same error. I changed my ~/.ssh/ssh_config file to disable StrictHostKeyChecking and still get the error.

Is bitbake somehow using different known_hosts and ssh_config files from the ones I use for interactive logins? Other ideas on how to resolve this?
bitbake is not hosted on yp dot org but on oe dot org

Join to automatically receive all group messages.