Re: mail list for Xilinx Zynq platform?

Philip Balister

On 12/05/2012 05:21 AM, Andreas Schweigstill wrote:

I personally have used Philip's meta-zynq layer to build a working u-boot and
linux kernel image using Yocto. It works really well.
I have also tried to build a kernel and root filesystem for Zynq but the kernel
gets stuck when booting, regardless if on the ZC702 board or on Qemu. I tried
Poky denzil and Poky danny.

Also the alternate meta-zynq layer from shows the same

These are the last console messages which I get:
## Booting kernel from Legacy Image at 01000000 ...
Image Name: Linux-3.2.11-yocto-standard
Created: 2012-12-04 20:07:37 UTC
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 2997472 Bytes = 2.9 MiB
Load Address: 00008000
Entry Point: 00008000
Verifying Checksum ... OK
## Flattened Device Tree blob at 01a80000
Booting using the fdt blob at 0x1a80000
Loading Device Tree to 0eff8000, end 0efff185 ... OK
Loading Kernel Image ... OK
Loading Device Tree to 0efed000, end 0eff7185 ... OK

Starting kernel ...

Instead of using Linux kernel version 3.5-xilinx I always get
Linux-3.2.11-yocto-standard which is obviously missing the
Zynq patches.

meta-zynq/recipes-kernel-linux-zynq contains the following lines:

How can I force Yocto to build kernel 3.5-xilinx?
Urg, I'll have to take a look at that.

Also, you'll need an updated fsbl in the BOOT.BIN file to work with the later kernels. We should probably post one somewhere, although I wish the fsbl license was a little less restrictive.


With best regards,
Andreas Schweigstill

Dipl.-Phys. Andreas Schweigstill
Schweigstill IT | Embedded Systems
Schauenburgerstraße 116, D-24118 Kiel, Germany
Phone: (+49) 431 530354-35, Fax: (+49) 431 530354-36
Mobile: (+49) 171 6921973, Web:
yocto mailing list

Join to automatically receive all group messages.