Re: mail list for Xilinx Zynq platform?


Elvis Dowson
 

Hi,

On Dec 5, 2012, at 5:21 PM, Andreas Schweigstill <andreas@...> wrote:

I have also tried to build a kernel and root filesystem for Zynq but the kernel
gets stuck when booting, regardless if on the ZC702 board or on Qemu. I tried
Poky denzil and Poky danny.

Also the alternate meta-zynq layer from git.yoctoproject.org shows the same
behaviour.

These are the last console messages which I get:
## Booting kernel from Legacy Image at 01000000 ...
Image Name: Linux-3.2.11-yocto-standard
Created: 2012-12-04 20:07:37 UTC
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 2997472 Bytes = 2.9 MiB
Load Address: 00008000
Entry Point: 00008000
Verifying Checksum ... OK
## Flattened Device Tree blob at 01a80000
Booting using the fdt blob at 0x1a80000
Loading Device Tree to 0eff8000, end 0efff185 ... OK
Loading Kernel Image ... OK
OK
Loading Device Tree to 0efed000, end 0eff7185 ... OK

Starting kernel ...


Instead of using Linux kernel version 3.5-xilinx I always get
Linux-3.2.11-yocto-standard which is obviously missing the
Zynq patches.

meta-zynq/recipes-kernel-linux-zynq contains the following lines:
LINUX_VERSION ?= "3.5"
LINUX_VERSION_EXTENSION ?= "-xilinx"

How can I force Yocto to build kernel 3.5-xilinx?
From you messages, I infer that you are using the meta-zynq layer
located here:

http://git.yoctoproject.org/cgit/cgit.cgi/meta-zynq/

For my builds, I used Philip Ballister's meta-zynq layer located here
for the simple reason that it uses xilinx git repository:

https://github.com/balister/meta-zynq

Also, try to ensure that you don't put both the meta-layers in your bblayers.conf file
while building, and ensure that you set machine as follows in your local.conf file

MACHINE ?= "zynq-zc702"

Do let me know how it goes!

Best regards,

Elvis Dowson

Join yocto@lists.yoctoproject.org to automatically receive all group messages.