Topics

[ANNOUNCEMENT] meta-intel 10.0 layer for Yocto Project "thud" 2.6 is now available


Tracy Graydon <tracy.graydon@...>
 

We are pleased to announce the meta-intel 10.0 layer for the Yocto Project 2.6 “thud" release is now available for download.

Tracy Graydon
Intel Corporation


----------------------
10.0-thud-2.6 Errata
----------------------

Release Name: meta-intel-10.0-thud-2.6
Branch: thud
Tag: 10.0-thud-2.6
Hash: 7ea89b9ddcdd3de1629bae1465425c8077c5aa06
md5: e60a634b2c335ff2b5dd455ce1303b23
Download Locations:
http://downloads.yoctoproject.org/releases/yocto/yocto-2.6/meta-intel-10.0-thud-2.6.tar.bz2
http://mirrors.kernel.org/yocto/yocto/yocto-2.6/meta-intel-10.0-thud-2.6.tar.bz2

---------------------------
New Features / Enhancements
---------------------------
- Added DPDK supportfor IoT platforms.
- Updated linux-intel/4.19 -> v4.19.8
- Updated linux-intel/4.14 -> v4.14.78
- Uupdated linux-intel-rt/4.14 -> v4.14.78
- Updated microcode from 20180703 -> 20180807
- Removed deprecated components including lms7, lms8, rmc, and va-intel
- Kernel hardening configs for 4.19 and 4.14 (bugs are expected)
- Microcode now includes WIC images for bootloaders as default
- Updates to multimedia components:
* intel-vaapi-driver 2.1.0 -> 2.2.0
* libyami-utils 1.3.0 -> 1.3.1
* libyami 1.3.0 -> 1.3.1
* gstreamer-vaapi 1.8.2

--------------
Known Issues
--------------
Bug 12936 - xserver upgrade probably broke video rendering using vaapisink
https://bugzilla.yoctoproject.org/show_bug.cgi?id=12936

This bug appears to be a problem with glamor acceleration in the latest xserver/mesa upstream when using dri2 when
both dri2 and dri3 are enabled. Bugs have been opend upstream and this is slated to be fixed in the 2.7 release. Please see the bug for more detail.

There is a patch for this issue at https://git.yoctoproject.org/cgit/cgit.cgi/poky/commit?id=67f5aac7dfe90f3d2c527fe6387ffc3256aa8065


---------------
Security Fixes
---------------
For Intel processor-specific security information please visit https://software.intel.com/en-us/side-channel-security-support

Method information on Intel's Security Center site:
https://security-center.intel.com/advisory.aspx?intelid=INTEL-SA-00088&;languageid=en-fr

Intel Security Center:
https://security-center.intel.com/default.aspx


---------------
Fixes
---------------
linux-intel/4.19: update to v4.19.8
linux-intel/4.19: update to v4.19.5
linux-intel/4.19: add recipe
linux-intel/4.14: update to v4.14.78
linux-intel/4.14: update to 4.14.68
linux-intel/4.14: update meta SRCREV
linux-intel/4.14: update SRCREV to 4.14.66
linux-intel/4.14: harden kernel config
linux-intel/4.14: update SRCREV to 4.14.59
linux-intel/4.14: update SRCREV to 4.14.56
linux-intel/4.14: update SRCREV to 4.14.52
linux-intel/4.14: update SRCREV to 4.14.48
linux-intel-rt/4.14: update to v4.14.78
linux-intel-rt/4.14: update to v4.14.68
linux-intel-rt/4.14: update to 4.14.63
linux-intel-rt/4.14: update SRCREV to 4.14.59
linux-intel-rt/4.14: update SRCREV to 4.14.52
linux-intel/4.9: update to v4.9.134
linux-intel/4.9: update to 4.9.126
linux-intel/4.9: update meta SRCREV
linux-intel/4.9: use new/correct revision for 4.9.116
linux-intel/4.9: update to 4.9.116
linux-intel/4.9: update SRCREV to 4.9.113
linux-intel-rt/4.9: update meta SRCREV
linux-intel: remove obsolete configs
linux-yocto: add bbappends for 4.18 kernel
linux-yocto: drop bbappends for 4.15 kernel
linux-yocto: drop bbappends for 4.12 kernel
backport-iwlwifi: exclude from world builds
conf/machine/intel-core*: add COMPATIBLE_MACHINE for qat17
core-image-rt-sdk: make sure that we append to DEPENDS
core-image-rt: make sure that we append to DEPENDS
core-image-minimal-initramfs: remove duplicate PACKAGE_INSTALL entries
igt-gpu-tools: fix packaging
igt-gpu-tools: update compile time dependencies
igt-gpu-tools: upgrade 1.22 -> 1.23
intel-core*.conf: change wks to be used for grub-efi
intel-microcode: upgrade 20180425 -> 20180703
intel-microcode: update to 20180425
intel-vaapi-driver: 2.1.0 -> 2.2.0
iucode-tool: upgrade 2.1.2 -> 2.3.1
ixgbe: upgrade 5.3.8 -> 5.5.2
ixgbe: 5.3.7 -> 5.3.8
ixgbe: upgrade 5.3.6 -> 5.3.7
ixgbevf: 4.3.5 -> 4.3.6
ixgbevf: upgrade 4.3.4 -> 4.3.5
layer.conf: update layer compatibility sumo->thud
libyami-utils: update to latest SRCREV
libyami-utils: 1.3.0 -> 1.3.1
libyami: 1.3.0 -> 1.3.1
libyami: update to latest SRCREV
lms7: remove
lms8: remove
lttng-modules: fix build error with 4.14 -rt kernel
machine/intel-corei7-64: remove reference to openssl-qatrmc: remove
machine/intel-corei7: remove lms from MACHINE_EXTRA_RRECOMMENDS
maintainers: update all owners to Anuj
microcode: upgrade 20180703 -> 20180807i
README: point to correct branch for thud
README: minor edit
Revert "lttng-modules: fix build error with 4.14 -rt kernel"
thermald: 1.7.2 -> 1.8
thermald: upgrade 1.7.1 -> 1.7.2
va-intel: remove
wic: add wks for enabling grub-efi bootloader