Topics

Current autobuilder status


Richard Purdie
 

I'm not sure what is happening with SWAT but we're in danger of losing
track of issues which is sad after Naveen did a great job and had
everything up to date. I'm aware of the following:

https://autobuilder.yoctoproject.org/typhoon/#/builders/56/builds/1305
https://autobuilder.yoctoproject.org/typhoon/#/builders/56/builds/1306
both failed in initramfs-boot, already open bug, fix in master-next.

https://autobuilder.yoctoproject.org/typhoon/#/builders/76/builds/2876/steps/14/logs/stdio
https://autobuilder.yoctoproject.org/typhoon/#/builders/76/builds/2890/steps/14/logs/stdio
failure running apt-get update. Second time we've seen it, was on
debian10-ty-1 here, denian10-ty-3 last time. pseudo.log says:
path mismatch [1 link]: ino 143525936 db '/home/pokybuild/yocto-worker/pkgman-non-rpm/build/build/tmp/work/qemux86-poky-linux/core-image-sato/1.0-r0/apt/lists/partial/_home_pokybuild_yocto-worker_pkgman-non-rpm_build_build_tmp_work_qemux86-poky-linux_core-image-sato_1.0-r0_oe-rootfs-repo_qemux86_._Release.CBFzPd' req '/home/pokybuild/yocto-worker/pkgman-non-rpm/build/build/tmp/work/qemux86-poky-linux/core-image-sato/1.0-r0/apt/lists/partial/_home_pokybuild_yocto-worker_pkgman-non-rpm_build_build_tmp_work_qemux86-poky-linux_core-image-sato_1.0-r0_oe-rootfs-repo_qemux86_._Release'.
similar to the last time.
path mismatch [1 link]: ino 27666766 db '/home/pokybuild/yocto-worker/pkgman-non-rpm/build/build/tmp/work/qemux86-poky-linux/core-image-sato/1.0-r0/apt/lists/partial/_home_pokybuild_yocto-worker_pkgman-non-rpm_build_build_tmp_work_qemux86-poky-linux_core-image-sato_1.0-r0_oe-rootfs-repo_all_._Release.RpRzHw' req '/home/pokybuild/yocto-worker/pkgman-non-rpm/build/build/tmp/work/qemux86-poky-linux/core-image-sato/1.0-r0/apt/lists/partial/_home_pokybuild_yocto-worker_pkgman-non-rpm_build_build_tmp_work_qemux86-poky-linux_core-image-sato_1.0-r0_oe-rootfs-repo_all_._Release'

https://autobuilder.yoctoproject.org/typhoon/#/builders/87/builds/1720/steps/15/logs/stdio
new issue where dnf is complaining checksums are incorrect

https://autobuilder.yoctoproject.org/typhoon/#/builders/87/builds/1716/steps/15/logs/stdio
ppp intermittent reproducibility issue

https://autobuilder.yoctoproject.org/typhoon/#/builders/80/builds/1688/steps/14/logs/stdio
bash reproducibility issue

arm ptest warnings which will need to be added to bugs or bugs opened:
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1403
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1401
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1400
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1399

x86 ptest warnings which will need to be added to bugs or bugs opened:
https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/1680
https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/1676

perl install failure in man pages, think open bug needs updating?
https://autobuilder.yoctoproject.org/typhoon/#/builders/47/builds/2909

The issue with new qemu needing python 3.6+ is fixed by changes in
autobuilder-helper for debian9. I also resolved the gio postinst
execution issue with new qemu. The mingw failure with new qemu is known
Joshua is looking into that.

Cheers,

Richard


Armin Kuster
 

On 1/7/21 3:07 AM, Richard Purdie wrote:
I'm not sure what is happening with SWAT but we're in danger of losing
track of issues which is sad after Naveen did a great job and had
everything up to date. I'm aware of the following:
My work schedule is such that I have no time to put into this activity.

-armin

https://autobuilder.yoctoproject.org/typhoon/#/builders/56/builds/1305
https://autobuilder.yoctoproject.org/typhoon/#/builders/56/builds/1306
both failed in initramfs-boot, already open bug, fix in master-next.

https://autobuilder.yoctoproject.org/typhoon/#/builders/76/builds/2876/steps/14/logs/stdio
https://autobuilder.yoctoproject.org/typhoon/#/builders/76/builds/2890/steps/14/logs/stdio
failure running apt-get update. Second time we've seen it, was on
debian10-ty-1 here, denian10-ty-3 last time. pseudo.log says:
path mismatch [1 link]: ino 143525936 db '/home/pokybuild/yocto-worker/pkgman-non-rpm/build/build/tmp/work/qemux86-poky-linux/core-image-sato/1.0-r0/apt/lists/partial/_home_pokybuild_yocto-worker_pkgman-non-rpm_build_build_tmp_work_qemux86-poky-linux_core-image-sato_1.0-r0_oe-rootfs-repo_qemux86_._Release.CBFzPd' req '/home/pokybuild/yocto-worker/pkgman-non-rpm/build/build/tmp/work/qemux86-poky-linux/core-image-sato/1.0-r0/apt/lists/partial/_home_pokybuild_yocto-worker_pkgman-non-rpm_build_build_tmp_work_qemux86-poky-linux_core-image-sato_1.0-r0_oe-rootfs-repo_qemux86_._Release'.
similar to the last time.
path mismatch [1 link]: ino 27666766 db '/home/pokybuild/yocto-worker/pkgman-non-rpm/build/build/tmp/work/qemux86-poky-linux/core-image-sato/1.0-r0/apt/lists/partial/_home_pokybuild_yocto-worker_pkgman-non-rpm_build_build_tmp_work_qemux86-poky-linux_core-image-sato_1.0-r0_oe-rootfs-repo_all_._Release.RpRzHw' req '/home/pokybuild/yocto-worker/pkgman-non-rpm/build/build/tmp/work/qemux86-poky-linux/core-image-sato/1.0-r0/apt/lists/partial/_home_pokybuild_yocto-worker_pkgman-non-rpm_build_build_tmp_work_qemux86-poky-linux_core-image-sato_1.0-r0_oe-rootfs-repo_all_._Release'

https://autobuilder.yoctoproject.org/typhoon/#/builders/87/builds/1720/steps/15/logs/stdio
new issue where dnf is complaining checksums are incorrect

https://autobuilder.yoctoproject.org/typhoon/#/builders/87/builds/1716/steps/15/logs/stdio
ppp intermittent reproducibility issue

https://autobuilder.yoctoproject.org/typhoon/#/builders/80/builds/1688/steps/14/logs/stdio
bash reproducibility issue

arm ptest warnings which will need to be added to bugs or bugs opened:
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1403
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1401
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1400
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1399

x86 ptest warnings which will need to be added to bugs or bugs opened:
https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/1680
https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/1676

perl install failure in man pages, think open bug needs updating?
https://autobuilder.yoctoproject.org/typhoon/#/builders/47/builds/2909

The issue with new qemu needing python 3.6+ is fixed by changes in
autobuilder-helper for debian9. I also resolved the gio postinst
execution issue with new qemu. The mingw failure with new qemu is known
Joshua is looking into that.

Cheers,

Richard








Richard Purdie
 

To try and ensure we don't lose track of issues:

On Thu, 2021-01-07 at 11:07 +0000, Richard Purdie via lists.yoctoproject.org wrote:
I'm not sure what is happening with SWAT but we're in danger of losing
track of issues which is sad after Naveen did a great job and had
everything up to date. I'm aware of the following:

https://autobuilder.yoctoproject.org/typhoon/#/builders/56/builds/1305
https://autobuilder.yoctoproject.org/typhoon/#/builders/56/builds/1306
both failed in initramfs-boot, already open bug, fix in master-next.
Fix merged, bug closed so resolved.

https://autobuilder.yoctoproject.org/typhoon/#/builders/76/builds/2876/steps/14/logs/stdio
https://autobuilder.yoctoproject.org/typhoon/#/builders/76/builds/2890/steps/14/logs/stdio
failure running apt-get update. Second time we've seen it, was on
debian10-ty-1 here, denian10-ty-3 last time. pseudo.log says:
path mismatch [1 link]: ino 143525936 db '/home/pokybuild/yocto-worker/pkgman-non-rpm/build/build/tmp/work/qemux86-poky-linux/core-image-sato/1.0-r0/apt/lists/partial/_home_pokybuild_yocto-worker_pkgman-non-rpm_build_build_tmp_work_qemux86-poky-linux_core-image-sato_1.0-r0_oe-rootfs-repo_qemux86_._Release.CBFzPd' req '/home/pokybuild/yocto-worker/pkgman-non-rpm/build/build/tmp/work/qemux86-poky-linux/core-image-sato/1.0-r0/apt/lists/partial/_home_pokybuild_yocto-worker_pkgman-non-rpm_build_build_tmp_work_qemux86-poky-linux_core-image-sato_1.0-r0_oe-rootfs-repo_qemux86_._Release'.
similar to the last time.
path mismatch [1 link]: ino 27666766 db '/home/pokybuild/yocto-worker/pkgman-non-rpm/build/build/tmp/work/qemux86-poky-linux/core-image-sato/1.0-r0/apt/lists/partial/_home_pokybuild_yocto-worker_pkgman-non-rpm_build_build_tmp_work_qemux86-poky-linux_core-image-sato_1.0-r0_oe-rootfs-repo_all_._Release.RpRzHw' req '/home/pokybuild/yocto-worker/pkgman-non-rpm/build/build/tmp/work/qemux86-poky-linux/core-image-sato/1.0-r0/apt/lists/partial/_home_pokybuild_yocto-worker_pkgman-non-rpm_build_build_tmp_work_qemux86-poky-linux_core-image-sato_1.0-r0_oe-rootfs-repo_all_._Release'
Still needs filing.

https://autobuilder.yoctoproject.org/typhoon/#/builders/87/builds/1720/steps/15/logs/stdio
new issue where dnf is complaining checksums are incorrect
Still needs filing.

https://autobuilder.yoctoproject.org/typhoon/#/builders/87/builds/1716/steps/15/logs/stdio
ppp intermittent reproducibility issue
Issue resolved, patch sent upstream.

https://autobuilder.yoctoproject.org/typhoon/#/builders/80/builds/1688/steps/14/logs/stdio
bash reproducibility issue
Issue resolved, patch queued in master-next with the bash upgrade.

arm ptest warnings which will need to be added to bugs or bugs opened:
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1403
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1401
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1400
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1399
Still needs filing.

x86 ptest warnings which will need to be added to bugs or bugs opened:
https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/1680
https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/1676
Still needs filing.

perl install failure in man pages, think open bug needs updating?
https://autobuilder.yoctoproject.org/typhoon/#/builders/47/builds/2909
Added to https://bugzilla.yoctoproject.org/show_bug.cgi?id=14096 so
done.

The issue with new qemu needing python 3.6+ is fixed by changes in
autobuilder-helper for debian9. I also resolved the gio postinst
execution issue with new qemu. The mingw failure with new qemu is known
Joshua is looking into that.
qemu upgrade merged, issues resolved. Still need to upstream the mingw
issue.

New issues:

vulkan-samples-staticdev reproducibility issue:
https://autobuilder.yocto.io/pub/repro-fail/oe-reproducible-20210109-uud35nir/packages/reproducibleA/tmp/deploy/deb/core2-64/
https://autobuilder.yoctoproject.org/typhoon/#/builders/79/builds/1712

Intermittent ssh failure:
https://autobuilder.yoctoproject.org/typhoon/#/builders/72/builds/2936

qemuarm rcu backtrace and QA failure:
https://autobuilder.yoctoproject.org/typhoon/#/builders/53/builds/2921

bitbake pickling failure:
https://autobuilder.yoctoproject.org/typhoon/#/builders/101/builds/1800
[have seen this very occasionally before, evidently previous fixes
haven't solved everything, bugs were closed for it I think :(]

Doing my best to try and keep on top of some of the issues!

Cheers,

Richard


Ross Burton
 

https://autobuilder.yoctoproject.org/typhoon/#/builders/76/builds/2876/steps/14/logs/stdio
https://autobuilder.yoctoproject.org/typhoon/#/builders/76/builds/2890/steps/14/logs/stdio
failure running apt-get update. Second time we've seen it, was on
debian10-ty-1 here, denian10-ty-3 last time. pseudo.log says:
path mismatch [1 link]: ino 143525936 db '/home/pokybuild/yocto-worker/pkgman-non-rpm/build/build/tmp/work/qemux86-poky-linux/core-image-sato/1.0-r0/apt/lists/partial/_home_pokybuild_yocto-worker_pkgman-non-rpm_build_build_tmp_work_qemux86-poky-linux_core-image-sato_1.0-r0_oe-rootfs-repo_qemux86_._Release.CBFzPd' req '/home/pokybuild/yocto-worker/pkgman-non-rpm/build/build/tmp/work/qemux86-poky-linux/core-image-sato/1.0-r0/apt/lists/partial/_home_pokybuild_yocto-worker_pkgman-non-rpm_build_build_tmp_work_qemux86-poky-linux_core-image-sato_1.0-r0_oe-rootfs-repo_qemux86_._Release'.
similar to the last time.
path mismatch [1 link]: ino 27666766 db '/home/pokybuild/yocto-worker/pkgman-non-rpm/build/build/tmp/work/qemux86-poky-linux/core-image-sato/1.0-r0/apt/lists/partial/_home_pokybuild_yocto-worker_pkgman-non-rpm_build_build_tmp_work_qemux86-poky-linux_core-image-sato_1.0-r0_oe-rootfs-repo_all_._Release.RpRzHw' req '/home/pokybuild/yocto-worker/pkgman-non-rpm/build/build/tmp/work/qemux86-poky-linux/core-image-sato/1.0-r0/apt/lists/partial/_home_pokybuild_yocto-worker_pkgman-non-rpm_build_build_tmp_work_qemux86-poky-linux_core-image-sato_1.0-r0_oe-rootfs-repo_all_._Release'
Still needs filing.
https://bugzilla.yoctoproject.org/show_bug.cgi?id=14183

https://autobuilder.yoctoproject.org/typhoon/#/builders/87/builds/1720/steps/15/logs/stdio
new issue where dnf is complaining checksums are incorrect
Still needs filing.
https://bugzilla.yoctoproject.org/show_bug.cgi?id=14180

arm ptest warnings which will need to be added to bugs or bugs opened:
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1403
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1401
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1400
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1399
Still needs filing.
These have all been filed already.

x86 ptest warnings which will need to be added to bugs or bugs opened:
https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/1680
https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/1676
Still needs filing.
All filed already.

vulkan-samples-staticdev reproducibility issue:
https://autobuilder.yocto.io/pub/repro-fail/oe-reproducible-20210109-uud35nir/packages/reproducibleA/tmp/deploy/deb/core2-64/
https://autobuilder.yoctoproject.org/typhoon/#/builders/79/builds/1712
https://bugzilla.yoctoproject.org/show_bug.cgi?id=14182

Intermittent ssh failure:
https://autobuilder.yoctoproject.org/typhoon/#/builders/72/builds/2936
Nothing useful in the log beyond "cannot connect to host".

qemuarm rcu backtrace and QA failure:
https://autobuilder.yoctoproject.org/typhoon/#/builders/53/builds/2921
https://bugzilla.yoctoproject.org/show_bug.cgi?id=14184

bitbake pickling failure:
https://autobuilder.yoctoproject.org/typhoon/#/builders/101/builds/1800
[have seen this very occasionally before, evidently previous fixes
haven't solved everything, bugs were closed for it I think :(]
https://bugzilla.yoctoproject.org/show_bug.cgi?id=14181

Ross