Autobuilder pending failures


Naveen Saini
 

Hi Richard,

-----Original Message-----
From: swat@lists.yoctoproject.org <swat@lists.yoctoproject.org> On Behalf
Of Richard Purdie
Sent: Wednesday, December 23, 2020 8:44 PM
To: swat@lists.yoctoproject.org
Subject: [swat] Autobuilder pending failures

The autobuilder doesn't stop running over the holidays so I'm going to list the
failures I haven't been able to log/handle (and I'll probably reply to this to
add new ones if I spot them):

initramfs-boot reproducibility failure:
https://autobuilder.yoctoproject.org/typhoon/#/builders/56/builds/1291/st
eps/14/logs/stdio

[Naveen] Cause of failure: device node permission bits are not set (/dev/console).
From the recipe do_install():
mknod -m 622 ${D}/dev/console c 5 1

From diff-html:

reproducibleA/tmp/deploy/deb/all/initramfs-boot_1.0-r2_all.deb vs
reproducibleB/tmp/deploy/deb/all/initramfs-boot_1.0-r2_all.deb

3 crw--w--w-···0·root·········(0)·root·········(0)····5,··1·1970-01-01·00:00:00.000000·./dev/console
3 crw-------···0·root·········(0)·root·········(0)····5,··1·1970-01-01·00:00:00.000000·./dev/console

Raised Bug#14162 [https://bugzilla.yoctoproject.org/show_bug.cgi?id=14162]



qemuppc-alt ping timeout:
https://autobuilder.yoctoproject.org/typhoon/#/builders/107/builds/1207
[Naveen] Ping test is failing only with core-image-sato, but passing with core-image-sato-sdk and core-image-full-cmdline. Not sure why it is happening. This issue is observed with master-next. Should I raise bug ?


intermittent arm ptest failures:
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1364
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1359
(the exact ones change a bit each run but we really need open bugs for each
one so that someone can ultimately investigate and fix them)
[Naveen] Bug raised.
libevent: https://bugzilla.yoctoproject.org/show_bug.cgi?id=14163
libinput: https://bugzilla.yoctoproject.org/show_bug.cgi?id=14164
strace: https://bugzilla.yoctoproject.org/show_bug.cgi?id=14165


qemumips64 shutdown backtrace:
https://autobuilder.yoctoproject.org/typhoon/#/builders/74/builds/2836
[Naveen] Bug raised #14166 [ https://bugzilla.yoctoproject.org/show_bug.cgi?id=14166]


If anyone does have some time to file/update bugs or investigate any of the
above please feel free and reply to the email. If not, we'll get to things in
January unless I get bored!

master-next also have something toxic to oe-selftest in it which I've yet to
track down. I plan to keep -next running at a slower pace just to keep on top
of incoming patches as not everywhere is on holiday right now.

Cheers,

Richard








Richard Purdie
 

The autobuilder doesn't stop running over the holidays so I'm going to
list the failures I haven't been able to log/handle (and I'll probably
reply to this to add new ones if I spot them):

initramfs-boot reproducibility failure:
https://autobuilder.yoctoproject.org/typhoon/#/builders/56/builds/1291/steps/14/logs/stdio

qemuppc-alt ping timeout:
https://autobuilder.yoctoproject.org/typhoon/#/builders/107/builds/1207

intermittent arm ptest failures:
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1364
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/1359
(the exact ones change a bit each run but we really need open bugs for
each one so that someone can ultimately investigate and fix them)

qemumips64 shutdown backtrace:
https://autobuilder.yoctoproject.org/typhoon/#/builders/74/builds/2836

If anyone does have some time to file/update bugs or investigate any of
the above please feel free and reply to the email. If not, we'll get to
things in January unless I get bored!

master-next also have something toxic to oe-selftest in it which I've
yet to track down. I plan to keep -next running at a slower pace just
to keep on top of incoming patches as not everywhere is on holiday
right now.

Cheers,

Richard