Re: SWAT Rotation


Naveen Saini
 

New bug:
Tcl ptest failure: https://bugzilla.yoctoproject.org/show_bug.cgi?id=14177

Updated existing bug:
Ltp test failure: https://bugzilla.yoctoproject.org/show_bug.cgi?id=13802
Strace qemux86-64 ptest failure (same as arm): https://bugzilla.yoctoproject.org/show_bug.cgi?id=14165

Regards,
Naveen

-----Original Message-----
From: swat@lists.yoctoproject.org <swat@lists.yoctoproject.org> On Behalf
Of Richard Purdie
Sent: Tuesday, January 5, 2021 8:41 PM
To: Saini, Naveen Kumar <naveen.kumar.saini@intel.com>;
swat@lists.yoctoproject.org; akuster@mvista.com
Subject: Re: [swat] SWAT Rotation

Hi Naveen,

Thanks for looking at these!

On Tue, 2021-01-05 at 02:38 +0000, Saini, Naveen Kumar wrote:
Hi Richard,

I have located few more old build failures (master-next):

(1) ptest failure on qemux86-64-ptest (Looks intermittent, I will
raise Bug)

AssertionError: Failed ptests:
{'tcl': ['socket.test']}
https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/1654
Bug for this one sounds good, thanks!

(2) test_ltp_groups test failure (Should I raise bug for this ?)

Reason: Looks like it's due to ssh connection failure

RESULTS - ltp.LtpTest.test_ltp_groups: ERROR (10948.27s)
SUMMARY:
core-image-sato () - Ran 6 tests in 16385.717s core-image-sato - FAIL
- Required tests failed (successes=4, skipped=1, failures=0, errors=1)


https://autobuilder.yoctoproject.org/typhoon/#/builders/95/builds/1476
I think there is an open ltp ssh connection issue so we probably need to
mention this failure on that bug?


(3) Reproducibility testcase failing due to missing pulseaudio
dependency  (debian) (need to analysis, which patch causing this
failure)

pulseaudio was skipped: pulseaudio - pulseaudio-server: system
username pulse does not have a static ID defined. Add pulse to one of
these files: /home/pokybuild/yocto-worker/oe-selftest-
debian/build/build-st-17416/meta-selftest/files/static-passwd
ERROR: Required build target 'meta-world-pkgdata' has no buildable
providers.
Missing or unbuildable dependency chain was: ['meta-world-pkgdata',
'gstreamer1.0-plugins-good', 'mpg123', 'pulseaudio']


https://autobuilder.yoctoproject.org/typhoon/#/builders/80/builds/1660
Centos:
Missing or unbuildable dependency chain was: ['meta-world-pkgdata',
'alsa-plugins', 'pulseaudio']

https://autobuilder.yoctoproject.org/typhoon/#/builders/79/builds/1678
Fedora:

https://autobuilder.yoctoproject.org/typhoon/#/builders/86/builds/1665
Ubuntu:

https://autobuilder.yoctoproject.org/typhoon/#/builders/87/builds/1690
These ones have patches in master which fix this so this one needs no
further action.


(4) ptest failure on qemux86-64 ( Seems intermittent, already
available for arm machine)

AssertionError: Failed ptests:
{'strace': ['qual_fault-syscall.test', 'qual_fault.test']}

https://autobuilder.yoctoproject.org/typhoon/#/builders/83/builds/1698
Is this the same strace test failing as the arm failure? If not it should be a
separate bug.

Cheers,

Richard





Join swat@lists.yoctoproject.org to automatically receive all group messages.