Another qemu hang


Richard Purdie
 

https://autobuilder.yoctoproject.org/typhoon/#/builders/45/builds/3463

which fails during an on-target compile during testimage:

pokybuild@debian8-ty-1:~/yocto-worker/musl-qemux86-64/build/build-renamed/tmp/work/qemux86_64-poky-linux-musl/core-image-sato-sdk/1.0-r0/testimage$ tail qemu_boot_log.20210521005453 -n 30
matchbox: Cant find a keycode for keysym 269025056
matchbox: ignoring key shortcut XF86Calendar=!$contacts

matchbox: Cant find a keycode for keysym 2809
matchbox: ignoring key shortcut telephone=!$dates

matchbox: Cant find a keycode for keysym 269025050
matchbox: ignoring key shortcut XF86Start=!matchbox-remote -desktop

[settings daemon] Forking. run with -n to prevent fork
dbus-daemon[987]: Activating service name='org.a11y.atspi.Registry' requested by ':1.0' (uid=0 pid=978 comm="connman-applet ")
matchbox-wm: X error warning (0xa00003): BadWindow (invalid Window parameter) (opcode: 12)
dbus-daemon[987]: Successfully activated service 'org.a11y.atspi.Registry'
SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry

** (matchbox-desktop:1019): [1;33mWARNING[0m **: [34m00:56:44.266[0m: Error loading icon: Icon 'net-48d24' not present in theme Sato

** (matchbox-desktop:1019): [1;33mWARNING[0m **: [34m00:56:44.267[0m: Error loading icon: Icon 'terminal' not present in theme Sato
[ 114.624630] rcu: INFO: rcu_preempt detected expedited stalls on CPUs/tasks: { 1-... } 21140 jiffies s: 221 root: 0x2/.
[ 119.752630] rcu: INFO: rcu_preempt detected stalls on CPUs/tasks:
[ 119.752636] rcu: 1-...0: (790 ticks this GP) idle=1ba/1/0x4000000000000000 softirq=11006/11008 fqs=5237
[ 119.752639] (detected by 0, t=21002 jiffies, g=24737, q=3)
[ 124.557907] rcu: blocking rcu_node structures:
[ 124.558693] Task dump for CPU 1:
[ 124.562791] task:cc1 state:R running task stack: 0 pid:10807 ppid: 10806 flags:0x00000008
[ 124.565007] Call Trace:
[ 124.565489] ? do_user_addr_fault+0x1dd/0x3d0
[ 124.566257] ? exc_page_fault+0x6a/0x150
[ 124.566983] ? asm_exc_page_fault+0x8/0x30
[ 124.567676] ? asm_exc_page_fault+0x1e/0x30

which is interesting in that it does say task:cc1

Couldn't find any further helpful debug info.

Cheers,

Richard

Join swat@lists.yoctoproject.org to automatically receive all group messages.