Yocto-hardknott build is success with lbpcre2(V10.36) but so files were never copied to /usr/lib/ when the image is flashed #yocto #poky #package #library


RK25
 

Hello All,
We tried to upgrade the Yocto version from Dunfell to Hardknott.  After successful build using hardknott, we flashed the generated image to the device. But we don't see the libpcre2 package installed under /usr/lib/ folder.
 
Below are the missing so files after built and installed/flashed with hardknott :
 
/usr/lib/libpcre2-8.so.0  /usr/lib/libpcre2-posix.so.2  /usr/lib/libpcre2-8.so.0.9.0  /usr/lib/libpcre2-posix.so.2.0.3
 
 
No changes were done in Yocto recipe libpcre2_10.36.bb:
 
https://git.yoctoproject.org/cgit/cgit.cgi/poky/tree/meta/recipes-support/libpcre?h=hardknott
 
 pl share any inputs.


Khem Raj
 

How is it being brought into image ? Do you pull it explicitly by IMAGE_INSTALL or is it being pulled n indirectly via rdepends 

On Sun, Jul 4, 2021 at 6:28 PM RK25 <rakesh1225@...> wrote:
Hello All,
We tried to upgrade the Yocto version from Dunfell to Hardknott.  After successful build using hardknott, we flashed the generated image to the device. But we don't see the libpcre2 package installed under /usr/lib/ folder.
 
Below are the missing so files after built and installed/flashed with hardknott :
 
/usr/lib/libpcre2-8.so.0  /usr/lib/libpcre2-posix.so.2  /usr/lib/libpcre2-8.so.0.9.0  /usr/lib/libpcre2-posix.so.2.0.3
 
 
No changes were done in Yocto recipe libpcre2_10.36.bb:
 
 
 pl share any inputs.




RK25
 

Yes, it is being pulled indirectly via rdepends