building latest docker on dunfell branch


Marek Belisko
 

Hi,

For my project I would need to use the latest docker build which can
be found in the master branch. I backported it to dunfell and I have
an issue with compilation of docker-ce like:

#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
| # GITCOMMIT = d24c6dc5cf-unsupported
| # The version you are building is listed as unsupported because
| # there are some files in the git repository that are in an uncommitted state.
| # Commit these changes, or add to .gitignore to remove the
-unsupported from the version.
| # Here is the current list:
| M hack/make/.binary
| #~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
| Package devmapper was not found in the pkg-config search path.
| Perhaps you should add the directory containing `devmapper.pc'
| to the PKG_CONFIG_PATH environment variable
| No package 'devmapper' found
| Removing bundles/
|
| ---> Making bundle: dynbinary (in bundles/dynbinary)
| Building: bundles/dynbinary-daemon/dockerd-20.10.8-ce
| GOOS="linux" GOARCH="arm" GOARM="7"
| can't load package: package github.com/docker/docker/cmd/dockerd:
cannot find package "github.com/docker/docker/cmd/dockerd" in any of:
| /home/marek/yocto/.build/tmp/work/cortexa7t2hf-neon-fslc-linux-gnueabi/docker-ce/20.10.8-ce+gitd24c6dc5cf5e68dfb30027b2db454099566a9b9e-r0/recipe-sysroot-native/usr/lib/arm-fslc-linux-gnueabi/go/src/github.com/docker/docker/cmd/dockerd
(from $GOROOT)
| /home/marek/yocto/.build/tmp/work/cortexa7t2hf-neon-fslc-linux-gnueabi/docker-ce/20.10.8-ce+gitd24c6dc5cf5e68dfb30027b2db454099566a9b9e-r0/git/src/import/.gopath_/home/marek/yocto/.build/tmp/work/cortexa7t2hf-neon-fslc-linux-gnueabi/docker-ce/20.10.8-ce+gitd24c6dc5cf5e68dfb30027b2db454099566a9b9e-r0/git/src/import/vendor_/home/marek/yocto/.build/tmp/work/cortexa7t2hf-neon-fslc-linux-gnueabi/docker-ce/20.10.8-ce+gitd24c6dc5cf5e68dfb30027b2db454099566a9b9e-r0/recipe-sysroot/usr/local/go/src/github.com/docker/docker/cmd/dockerd
(from $GOPATH)
| WARNING: exit code 1 from a shell command.
| ERROR: Execution of
'/home/marek/yocto/.build/tmp/work/cortexa7t2hf-neon-fslc-linux-gnueabi/docker-ce/20.10.8-ce+gitd24c6dc5cf5e68dfb30027b2db454099566a9b9e-r0/temp/run.do_compile.3085'
failed with exit code 1:

There seems to be some issue with dependencies. Any idea how to
properly backport it or make it working? Thanks.

BR,

marek

--
as simple and primitive as possible
-------------------------------------------------
Marek Belisko - OPEN-NANDRA
Freelance Developer

Ruska Nova Ves 219 | Presov, 08005 Slovak Republic
Tel: +421 915 052 184
skype: marekwhite
twitter: #opennandra
web: http://open-nandra.com