Date   

[meta-cloud-services][PATCH 2/3] openstack-image-controller: fix warning of operator append combined with +=

Yi Zhao
 

Fixes:
WARNING: openstack-image-controller.bb: IMAGE_ROOTFS_EXTRA_SPACE:append
+= is not a recommended operator combination, please replace it.

Signed-off-by: Yi Zhao <yi.zhao@...>
---
.../recipes-extended/images/openstack-image-controller.bb | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta-openstack/recipes-extended/images/openstack-image-controller.bb b/meta-openstack/recipes-extended/images/openstack-image-controller.bb
index 7f41a08..96dc80c 100644
--- a/meta-openstack/recipes-extended/images/openstack-image-controller.bb
+++ b/meta-openstack/recipes-extended/images/openstack-image-controller.bb
@@ -24,5 +24,5 @@ inherit monitor

# Ensure extra space for guest images, and rabbit MQ has a hard coded
# check for 2G of free space, so we use 5G as a starting point.
-IMAGE_ROOTFS_EXTRA_SPACE:append += "+ 5000000"
+IMAGE_ROOTFS_EXTRA_SPACE:append = " + 5000000"

--
2.25.1


Re: [m-c-s][PATCH] concurrent-ruby: add explicit branch

Bruce Ashfield
 

On Fri, Nov 19, 2021 at 8:43 AM kai <kai.kang@...> wrote:

On 11/11/21 7:05 PM, Peter Kjellerstedt wrote:
-----Original Message-----
From: meta-virtualization@... <meta-
virtualization@...> On Behalf Of kai
Sent: den 11 november 2021 11:07
To: meta-virtualization@...
Subject: [meta-virtualization][m-c-s][PATCH] concurrent-ruby: add explicit
branch

From: Kai Kang <kai.kang@...>

Add explicit branch master for concurrent-ruby as the same for other
recipes.

Signed-off-by: Kai Kang <kai.kang@...>
---
meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb
b/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb
index a328203e..61a2c598 100644
--- a/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb
+++ b/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://www.concurrent-ruby.com"
LICENSE = "MIT"
LIC_FILES_CHKSUM =
"file://LICENSE.md;md5=fde65ae93d18826f70c6fe125aa04297"

-SRC_URI = "git://github.com/ruby-concurrency/concurrent-ruby.git;protocol=https;tag=v1.1.6\
+SRC_URI = "git://github.com/ruby-concurrency/concurrent-ruby.git;protocol=https;tag=v1.1.6;branch=master \
While at it, why not remove the tag= and replace it with a proper
SRCREV = "<sha1>"?
Sorry for late reply.

I am not sure which is better because there is a tag with branch in
SRC_URI in meta-oe. If you insist remove tag is better, I'll send it
with v2.
The default is to use SRCREVs instead of tags, since tags can change
(although they shouldn't), and it used to be that tags did trigger
some network access with some configurations.

So if it isn't too much trouble, I do think switching to a SRCREV is better.

Bruce


Thanks,

Kai


file://0001-Removed-check-for-concurrent_ruby.jar.patch"

S = "${WORKDIR}/git"
--
2.17.1
//Peter
--
Kai Kang
Wind River Linux




--
- Thou shalt not follow the NULL pointer, for chaos and madness await
thee at its end
- "Use the force Harry" - Gandalf, Star Trek II


Re: [m-c-s][PATCH] concurrent-ruby: add explicit branch

kai
 

On 11/11/21 7:05 PM, Peter Kjellerstedt wrote:
-----Original Message-----
From: meta-virtualization@... <meta-
virtualization@...> On Behalf Of kai
Sent: den 11 november 2021 11:07
To: meta-virtualization@...
Subject: [meta-virtualization][m-c-s][PATCH] concurrent-ruby: add explicit
branch

From: Kai Kang <kai.kang@...>

Add explicit branch master for concurrent-ruby as the same for other
recipes.

Signed-off-by: Kai Kang <kai.kang@...>
---
meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb
b/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb
index a328203e..61a2c598 100644
--- a/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb
+++ b/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://www.concurrent-ruby.com"
LICENSE = "MIT"
LIC_FILES_CHKSUM =
"file://LICENSE.md;md5=fde65ae93d18826f70c6fe125aa04297"

-SRC_URI = "git://github.com/ruby-concurrency/concurrent-ruby.git;protocol=https;tag=v1.1.6\
+SRC_URI = "git://github.com/ruby-concurrency/concurrent-ruby.git;protocol=https;tag=v1.1.6;branch=master \
While at it, why not remove the tag= and replace it with a proper
SRCREV = "<sha1>"?
Sorry for late reply.

I am not sure which is better because there is a tag with branch in SRC_URI in meta-oe. If you insist remove tag is better, I'll send it with v2.

Thanks,

Kai


file://0001-Removed-check-for-concurrent_ruby.jar.patch"

S = "${WORKDIR}/git"
--
2.17.1
//Peter
--
Kai Kang
Wind River Linux


Re: [PATCH] openvswitch: fix configure error with dpdk enabled

Bruce Ashfield
 

merged.

Bruce

On Tue, Nov 16, 2021 at 1:13 AM Chen Qi <Qi.Chen@...> wrote:

When enabling 'dpdk' PACKAGECONFIG, the following error appears.

| configure: error: Could not find DPDK library in default search path

Fix the error by tweaking the configure option regarding dpdk.
Add pkgconfig to 'inherit' because pkgconfig is required at do_configure
when dpdk is enabled.

Signed-off-by: Chen Qi <Qi.Chen@...>
---
recipes-networking/openvswitch/openvswitch.inc | 2 +-
recipes-networking/openvswitch/openvswitch_git.bb | 4 +---
2 files changed, 2 insertions(+), 4 deletions(-)

diff --git a/recipes-networking/openvswitch/openvswitch.inc b/recipes-networking/openvswitch/openvswitch.inc
index b354a84..831e0b3 100644
--- a/recipes-networking/openvswitch/openvswitch.inc
+++ b/recipes-networking/openvswitch/openvswitch.inc
@@ -72,7 +72,7 @@ FILES:${PN} += "${datadir}/ovsdbmonitor"
FILES:${PN} += "/run"

FILES:${PN} += "${libdir}/python${PYTHON_BASEVERSION}/"
-inherit autotools update-rc.d systemd python3native
+inherit pkgconfig autotools update-rc.d systemd python3native

SYSTEMD_PACKAGES = "${PN}-switch"
SYSTEMD_SERVICE:${PN}-switch = " \
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb
index f1a5c4c..0fb7c13 100644
--- a/recipes-networking/openvswitch/openvswitch_git.bb
+++ b/recipes-networking/openvswitch/openvswitch_git.bb
@@ -32,10 +32,8 @@ SRC_URI += "git://github.com/openvswitch/ovs.git;protocol=https;branch=branch-2.

LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab"

-DPDK_INSTALL_DIR ?= "/opt/dpdk"
-
PACKAGECONFIG ?= "libcap-ng"
-PACKAGECONFIG[dpdk] = "--with-dpdk=${STAGING_DIR_TARGET}${DPDK_INSTALL_DIR}/share/${TARGET_ARCH}-native-linuxapp-gcc,,dpdk,dpdk"
+PACKAGECONFIG[dpdk] = "--with-dpdk=shared,,dpdk,dpdk"
PACKAGECONFIG[libcap-ng] = "--enable-libcapng,--disable-libcapng,libcap-ng,"
PACKAGECONFIG[ssl] = ",--disable-ssl,openssl,"

--
2.33.0



--
- Thou shalt not follow the NULL pointer, for chaos and madness await
thee at its end
- "Use the force Harry" - Gandalf, Star Trek II


Re: [m-c-s][PATCH] openstack-image-aio: fix warning of operator remove combined with +=

Bruce Ashfield
 

merged.

Bruce

On Fri, Nov 19, 2021 at 2:29 AM kai <kai.kang@...> wrote:

From: Kai Kang <kai.kang@...>

Fix warning of openstack-image-aio:

| WARNING: /path/to/meta-openstack/recipes-extended/images/openstack-image-aio.bb:
| IMAGE_ROOTFS_EXTRA_SPACE:append += is not a recommended operator combination,
| please replace it.

Signed-off-by: Kai Kang <kai.kang@...>
---
meta-openstack/recipes-extended/images/openstack-image-aio.bb | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta-openstack/recipes-extended/images/openstack-image-aio.bb b/meta-openstack/recipes-extended/images/openstack-image-aio.bb
index 858c8e99..f01d0ed5 100644
--- a/meta-openstack/recipes-extended/images/openstack-image-aio.bb
+++ b/meta-openstack/recipes-extended/images/openstack-image-aio.bb
@@ -27,7 +27,7 @@ inherit identity
inherit monitor

# check for 5G of free space, so we use 5G as a starting point.
-IMAGE_ROOTFS_EXTRA_SPACE:append += "+ 5000000"
+IMAGE_ROOTFS_EXTRA_SPACE += "+ 5000000"

POST_KEYSTONE_SETUP_COMMAND = "/etc/keystone/hybrid-backend-setup"

--
2.17.1



--
- Thou shalt not follow the NULL pointer, for chaos and madness await
thee at its end
- "Use the force Harry" - Gandalf, Star Trek II


Re: [m-c-s][PATCH] open-iscsi-user: remove typo spaces in SRC_URI

Bruce Ashfield
 

On Fri, Nov 19, 2021 at 2:10 AM kai <kai.kang@...> wrote:

On 11/11/21 11:53 AM, kai wrote:

From: Kai Kang <kai.kang@...>

There are typo spaces in SRC_URI which are introduced when add
';branch=master'. Remove them.

Signed-off-by: Kai Kang <kai.kang@...>
---
.../recipes-connectivity/open-iscsi/open-iscsi-user_2.1.4.bb | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-user_2.1.4.bb b/meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-user_2.1.4.bb
index d4c489cf..fe802b72 100644
--- a/meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-user_2.1.4.bb
+++ b/meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-user_2.1.4.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "kmod openssl util-linux open-isns"
DEPENDS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"

-SRC_URI = "git://github.com/open-iscsi/open-iscsi.git;protocol=https ;branch=master \
+SRC_URI = "git://github.com/open-iscsi/open-iscsi.git;protocol=https;branch=master \
file://0001-fix-build-error-of-cross-build.patch \
"


Ping.
I was waiting for you to reply about the comment on your other patch
in the same send (the ruby branch one), since if they are sent on the
same day by the same person, and there are comments .. I tend to treat
them as a unit.

But I have gone ahead and merged this now.

Bruce






--
Kai Kang
Wind River Linux




--
- Thou shalt not follow the NULL pointer, for chaos and madness await
thee at its end
- "Use the force Harry" - Gandalf, Star Trek II


[m-c-s][PATCH] openstack-image-aio: fix warning of operator remove combined with +=

kai
 

From: Kai Kang <kai.kang@...>

Fix warning of openstack-image-aio:

| WARNING: /path/to/meta-openstack/recipes-extended/images/openstack-image-aio.bb:
| IMAGE_ROOTFS_EXTRA_SPACE:append += is not a recommended operator combination,
| please replace it.

Signed-off-by: Kai Kang <kai.kang@...>
---
meta-openstack/recipes-extended/images/openstack-image-aio.bb | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta-openstack/recipes-extended/images/openstack-image-aio.bb b/meta-openstack/recipes-extended/images/openstack-image-aio.bb
index 858c8e99..f01d0ed5 100644
--- a/meta-openstack/recipes-extended/images/openstack-image-aio.bb
+++ b/meta-openstack/recipes-extended/images/openstack-image-aio.bb
@@ -27,7 +27,7 @@ inherit identity
inherit monitor

# check for 5G of free space, so we use 5G as a starting point.
-IMAGE_ROOTFS_EXTRA_SPACE:append += "+ 5000000"
+IMAGE_ROOTFS_EXTRA_SPACE += "+ 5000000"

POST_KEYSTONE_SETUP_COMMAND = "/etc/keystone/hybrid-backend-setup"

--
2.17.1


Re: [m-c-s][PATCH] open-iscsi-user: remove typo spaces in SRC_URI

kai
 

On 11/11/21 11:53 AM, kai wrote:
From: Kai Kang <kai.kang@...>

There are typo spaces in SRC_URI which are introduced when add
';branch=master'. Remove them.

Signed-off-by: Kai Kang <kai.kang@...>
---
 .../recipes-connectivity/open-iscsi/open-iscsi-user_2.1.4.bb    | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-user_2.1.4.bb b/meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-user_2.1.4.bb
index d4c489cf..fe802b72 100644
--- a/meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-user_2.1.4.bb
+++ b/meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-user_2.1.4.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
 DEPENDS = "kmod openssl util-linux open-isns"
 DEPENDS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
 
-SRC_URI = "git://github.com/open-iscsi/open-iscsi.git;protocol=https  ;branch=master \
+SRC_URI = "git://github.com/open-iscsi/open-iscsi.git;protocol=https;branch=master \
            file://0001-fix-build-error-of-cross-build.patch \
            "
 

Ping.



      



-- 
Kai Kang
Wind River Linux


[PATCH] openvswitch: fix configure error with dpdk enabled

Chen Qi
 

When enabling 'dpdk' PACKAGECONFIG, the following error appears.

| configure: error: Could not find DPDK library in default search path

Fix the error by tweaking the configure option regarding dpdk.
Add pkgconfig to 'inherit' because pkgconfig is required at do_configure
when dpdk is enabled.

Signed-off-by: Chen Qi <Qi.Chen@...>
---
recipes-networking/openvswitch/openvswitch.inc | 2 +-
recipes-networking/openvswitch/openvswitch_git.bb | 4 +---
2 files changed, 2 insertions(+), 4 deletions(-)

diff --git a/recipes-networking/openvswitch/openvswitch.inc b/recipes-networking/openvswitch/openvswitch.inc
index b354a84..831e0b3 100644
--- a/recipes-networking/openvswitch/openvswitch.inc
+++ b/recipes-networking/openvswitch/openvswitch.inc
@@ -72,7 +72,7 @@ FILES:${PN} += "${datadir}/ovsdbmonitor"
FILES:${PN} += "/run"

FILES:${PN} += "${libdir}/python${PYTHON_BASEVERSION}/"
-inherit autotools update-rc.d systemd python3native
+inherit pkgconfig autotools update-rc.d systemd python3native

SYSTEMD_PACKAGES = "${PN}-switch"
SYSTEMD_SERVICE:${PN}-switch = " \
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb
index f1a5c4c..0fb7c13 100644
--- a/recipes-networking/openvswitch/openvswitch_git.bb
+++ b/recipes-networking/openvswitch/openvswitch_git.bb
@@ -32,10 +32,8 @@ SRC_URI += "git://github.com/openvswitch/ovs.git;protocol=https;branch=branch-2.

LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab"

-DPDK_INSTALL_DIR ?= "/opt/dpdk"
-
PACKAGECONFIG ?= "libcap-ng"
-PACKAGECONFIG[dpdk] = "--with-dpdk=${STAGING_DIR_TARGET}${DPDK_INSTALL_DIR}/share/${TARGET_ARCH}-native-linuxapp-gcc,,dpdk,dpdk"
+PACKAGECONFIG[dpdk] = "--with-dpdk=shared,,dpdk,dpdk"
PACKAGECONFIG[libcap-ng] = "--enable-libcapng,--disable-libcapng,libcap-ng,"
PACKAGECONFIG[ssl] = ",--disable-ssl,openssl,"

--
2.33.0


Re: Building xen-image-minimal for RPi4 Compute Module

Patrick Godwin
 

No worries, now it's my turn to apologize :) Got pulled away from this over the last week and haven't had a chance to fully dive back on in, but I really appreciate you taking the time to reply here! Now that I've had more time with Yocto and the meta-virt layer I think I'm closing the knowledge gaps that are blocking me, I just have a few more edges to sort out. I think that you're right that a patch shouldn't be needed, I think it's just been a lot of user error on my part.

I'll be sure to update this thread once I have the device up and running; I think I'm close. Thanks again!

-----Original Message-----
From: Bruce Ashfield <bruce.ashfield@...>
Sent: Thursday, November 11, 2021 6:53 AM
To: Patrick Godwin <pbg.dev@...>
Cc: meta-virtualization@...
Subject: Re: [meta-virtualization] Building xen-image-minimal for RPi4 Compute Module

Sorry for the slow reply,

On Fri, Nov 5, 2021 at 11:45 PM Patrick Godwin <pbg.dev@...> wrote:

I'm in the process of building xen-image-minimal for my Raspberry Pi 4 Compute Module and am hitting some issues when running the image on physical hardware. Upon inspecting the boot partition of the sd-card, I noticed that the image only contained the dtb for the Raspberry Pi 4B; this makes sense when I look at xen-raspberrypi4-64.inc:
Not sure if you've sorted this out yet.

We do have reference images that booted on the RPI, but I can't say that I've been testing them myself. I'm hoping that my reply will catch the attention of those that do have the h/w and they can comment in more detail.

# Override the meta-raspberrypi default kernel preference
PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
KERNEL_DEVICETREE ?= "broadcom/bcm2711-rpi-4-b.dtb"

Compared with the device tree blobs declared in meta-raspberrypi's raspberrypi4-64.conf:

RPI_KERNEL_DEVICETREE = " \
broadcom/bcm2711-rpi-4-b.dtb \
broadcom/bcm2711-rpi-400.dtb \
broadcom/bcm2711-rpi-cm4.dtb \
"

Looking into it further, it seems that the device tree listing in the kernel used in the xen-image-minimal build doesn't contain the newer firmware blobs contained in meta-raspberrypi, which causes devices like ethernet to fail to start up when the image finally boots.
There's a different level of support on the h/w between linux-yocto and the 'vendor' rpi tree. We use linux-yocto for the core enablement because the branches are stable/not rebased and have a cadence we can predict (all mentioned things are breakages we've hit before!).

That being said, you can change the kernel provider to the linux-rpi, and the rest of the meta-virt settings, etc, are still applicable and should work.

I've tried adding the bcm2711-rpi-cm4 firmware blob to the SD card manually, but that causes u-boot to fail with the error "Bad Linux ARM64 Image Magic!" after the Boot Xen step in output. I also tried manually replacing the bootfiles written by the xen sd card image with the latest blobs from meta-raspberrypi's packages, but once the OS boots I find that xen is no longer running, making me suspect I screwed up the configuration somewhere.
It could be a kernel configuration issue between the two images, if the Xen packages are on the image, but nothing is running. Can you interact with the Xen support via the xen cli at all ? Just to get a better error message ?

Is this something I can trivially fix? Is there a way for me to override the device tree selection used by the minimal xen image in my local.conf? Or do I need to investigate patching one of the meta-virtualization recipes?
Anything that needs changing, should be overridable via variable or through bbappends, so hopefully no patching is required.

Bruce


(Apologies if I've used any of the wrong lingo/terms here; still new
to RasPi/Yocto/Xen :D)




--
- Thou shalt not follow the NULL pointer, for chaos and madness await thee at its end
- "Use the force Harry" - Gandalf, Star Trek II


Re: [PATCH] libvirt: do not install /var/log for target

Bruce Ashfield
 

On Thu, Nov 11, 2021 at 11:49 PM Kai <kai.kang@...> wrote:

On 11/12/21 12:03 PM, Bruce Ashfield wrote:
On Thu, Nov 11, 2021 at 10:23 PM kai <kai.kang@...> wrote:
From: Kai Kang <kai.kang@...>

/var/log is normally a link to /var/volatile/log and /var/volatile is a tmpfs
mount. So anything created in /var/log will not be available when the tmpfs is
mounted.

Not install /var/log to avoid 'empty-dirs' qa issue:

| ERROR: libvirt-7.2.0-r0 do_package_qa: QA Issue: libvirt installs files in
/var/volatile, but it is expected to be empty [empty-dirs]

Signed-off-by: Kai Kang <kai.kang@...>
---
recipes-extended/libvirt/libvirt_7.2.0.bb | 4 ++++
1 file changed, 4 insertions(+)

diff --git a/recipes-extended/libvirt/libvirt_7.2.0.bb b/recipes-extended/libvirt/libvirt_7.2.0.bb
index b7f8383a..b49bd11a 100644
--- a/recipes-extended/libvirt/libvirt_7.2.0.bb
+++ b/recipes-extended/libvirt/libvirt_7.2.0.bb
@@ -232,6 +232,10 @@ do_install:append() {
echo "d root root 0755 /run/libvirt/qemu none" \
>> ${D}${sysconfdir}/default/volatiles/99_libvirt

+ # /var/log is normally a link to /var/volatile/log
+ # and /var/volatile is a tmpfs mount which should be clean.
+ rm -rf ${D}${localstatedir}/log
We should be preventing the install from happening at all, not
deleting it after the fact.

If libvirt thinks something needs to be in the directory, then we
should be looking into why it does exactly that.
OK.I'll figure out.
I poked around at this myself, and then asked Ross to help me out .. I
assumed it was meson doing this, and he pointed out the right
meson.build files to me.

I'm trying to figure out how to balance some non volatile use cases,
with this new QA check. If we universally delete those files, then
those cases are broken.

I'm leaning towards leaving the directories in place, and just
inhibiting the QA check.

Bruce


Regards,
Kai


Bruce

+
# Manually set permissions and ownership to match polkit recipe
if ${@bb.utils.contains('PACKAGECONFIG', 'polkit', 'true', 'false', d)}; then
install -d -m 0700 ${D}/${datadir}/polkit-1/rules.d
--
2.33.0



--
Kai Kang
Wind River Linux

--
- Thou shalt not follow the NULL pointer, for chaos and madness await
thee at its end
- "Use the force Harry" - Gandalf, Star Trek II


Re: [PATCH] libvirt: do not install /var/log for target

kai
 

On 11/12/21 12:03 PM, Bruce Ashfield wrote:
On Thu, Nov 11, 2021 at 10:23 PM kai <kai.kang@...> wrote:
From: Kai Kang <kai.kang@...>

/var/log is normally a link to /var/volatile/log and /var/volatile is a tmpfs
mount. So anything created in /var/log will not be available when the tmpfs is
mounted.

Not install /var/log to avoid 'empty-dirs' qa issue:

| ERROR: libvirt-7.2.0-r0 do_package_qa: QA Issue: libvirt installs files in
/var/volatile, but it is expected to be empty [empty-dirs]

Signed-off-by: Kai Kang <kai.kang@...>
---
recipes-extended/libvirt/libvirt_7.2.0.bb | 4 ++++
1 file changed, 4 insertions(+)

diff --git a/recipes-extended/libvirt/libvirt_7.2.0.bb b/recipes-extended/libvirt/libvirt_7.2.0.bb
index b7f8383a..b49bd11a 100644
--- a/recipes-extended/libvirt/libvirt_7.2.0.bb
+++ b/recipes-extended/libvirt/libvirt_7.2.0.bb
@@ -232,6 +232,10 @@ do_install:append() {
echo "d root root 0755 /run/libvirt/qemu none" \
>> ${D}${sysconfdir}/default/volatiles/99_libvirt

+ # /var/log is normally a link to /var/volatile/log
+ # and /var/volatile is a tmpfs mount which should be clean.
+ rm -rf ${D}${localstatedir}/log
We should be preventing the install from happening at all, not
deleting it after the fact.

If libvirt thinks something needs to be in the directory, then we
should be looking into why it does exactly that.
OK.I'll figure out.

Regards,
Kai


Bruce

+
# Manually set permissions and ownership to match polkit recipe
if ${@bb.utils.contains('PACKAGECONFIG', 'polkit', 'true', 'false', d)}; then
install -d -m 0700 ${D}/${datadir}/polkit-1/rules.d
--
2.33.0


--
Kai Kang
Wind River Linux


Re: [PATCH] libvirt: do not install /var/log for target

Bruce Ashfield
 

On Thu, Nov 11, 2021 at 10:23 PM kai <kai.kang@...> wrote:

From: Kai Kang <kai.kang@...>

/var/log is normally a link to /var/volatile/log and /var/volatile is a tmpfs
mount. So anything created in /var/log will not be available when the tmpfs is
mounted.

Not install /var/log to avoid 'empty-dirs' qa issue:

| ERROR: libvirt-7.2.0-r0 do_package_qa: QA Issue: libvirt installs files in
/var/volatile, but it is expected to be empty [empty-dirs]

Signed-off-by: Kai Kang <kai.kang@...>
---
recipes-extended/libvirt/libvirt_7.2.0.bb | 4 ++++
1 file changed, 4 insertions(+)

diff --git a/recipes-extended/libvirt/libvirt_7.2.0.bb b/recipes-extended/libvirt/libvirt_7.2.0.bb
index b7f8383a..b49bd11a 100644
--- a/recipes-extended/libvirt/libvirt_7.2.0.bb
+++ b/recipes-extended/libvirt/libvirt_7.2.0.bb
@@ -232,6 +232,10 @@ do_install:append() {
echo "d root root 0755 /run/libvirt/qemu none" \
>> ${D}${sysconfdir}/default/volatiles/99_libvirt

+ # /var/log is normally a link to /var/volatile/log
+ # and /var/volatile is a tmpfs mount which should be clean.
+ rm -rf ${D}${localstatedir}/log
We should be preventing the install from happening at all, not
deleting it after the fact.

If libvirt thinks something needs to be in the directory, then we
should be looking into why it does exactly that.

Bruce

+
# Manually set permissions and ownership to match polkit recipe
if ${@bb.utils.contains('PACKAGECONFIG', 'polkit', 'true', 'false', d)}; then
install -d -m 0700 ${D}/${datadir}/polkit-1/rules.d
--
2.33.0




--
- Thou shalt not follow the NULL pointer, for chaos and madness await
thee at its end
- "Use the force Harry" - Gandalf, Star Trek II


[PATCH] libvirt: do not install /var/log for target

kai
 

From: Kai Kang <kai.kang@...>

/var/log is normally a link to /var/volatile/log and /var/volatile is a tmpfs
mount. So anything created in /var/log will not be available when the tmpfs is
mounted.

Not install /var/log to avoid 'empty-dirs' qa issue:

| ERROR: libvirt-7.2.0-r0 do_package_qa: QA Issue: libvirt installs files in
/var/volatile, but it is expected to be empty [empty-dirs]

Signed-off-by: Kai Kang <kai.kang@...>
---
recipes-extended/libvirt/libvirt_7.2.0.bb | 4 ++++
1 file changed, 4 insertions(+)

diff --git a/recipes-extended/libvirt/libvirt_7.2.0.bb b/recipes-extended/libvirt/libvirt_7.2.0.bb
index b7f8383a..b49bd11a 100644
--- a/recipes-extended/libvirt/libvirt_7.2.0.bb
+++ b/recipes-extended/libvirt/libvirt_7.2.0.bb
@@ -232,6 +232,10 @@ do_install:append() {
echo "d root root 0755 /run/libvirt/qemu none" \
>> ${D}${sysconfdir}/default/volatiles/99_libvirt

+ # /var/log is normally a link to /var/volatile/log
+ # and /var/volatile is a tmpfs mount which should be clean.
+ rm -rf ${D}${localstatedir}/log
+
# Manually set permissions and ownership to match polkit recipe
if ${@bb.utils.contains('PACKAGECONFIG', 'polkit', 'true', 'false', d)}; then
install -d -m 0700 ${D}/${datadir}/polkit-1/rules.d
--
2.33.0


Re: Building xen-image-minimal for RPi4 Compute Module

Bruce Ashfield
 

Sorry for the slow reply,

On Fri, Nov 5, 2021 at 11:45 PM Patrick Godwin <pbg.dev@...> wrote:

I'm in the process of building xen-image-minimal for my Raspberry Pi 4 Compute Module and am hitting some issues when running the image on physical hardware. Upon inspecting the boot partition of the sd-card, I noticed that the image only contained the dtb for the Raspberry Pi 4B; this makes sense when I look at xen-raspberrypi4-64.inc:
Not sure if you've sorted this out yet.

We do have reference images that booted on the RPI, but I can't say that I've
been testing them myself. I'm hoping that my reply will catch the attention of
those that do have the h/w and they can comment in more detail.

# Override the meta-raspberrypi default kernel preference
PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
KERNEL_DEVICETREE ?= "broadcom/bcm2711-rpi-4-b.dtb"

Compared with the device tree blobs declared in meta-raspberrypi's raspberrypi4-64.conf:

RPI_KERNEL_DEVICETREE = " \
broadcom/bcm2711-rpi-4-b.dtb \
broadcom/bcm2711-rpi-400.dtb \
broadcom/bcm2711-rpi-cm4.dtb \
"

Looking into it further, it seems that the device tree listing in the kernel used in the xen-image-minimal build doesn't contain the newer firmware blobs contained in meta-raspberrypi, which causes devices like ethernet to fail to start up when the image finally boots.
There's a different level of support on the h/w between linux-yocto and the
'vendor' rpi tree. We use linux-yocto for the core enablement because the
branches are stable/not rebased and have a cadence we can predict (all
mentioned things are breakages we've hit before!).

That being said, you can change the kernel provider to the linux-rpi, and
the rest of the meta-virt settings, etc, are still applicable and should work.

I've tried adding the bcm2711-rpi-cm4 firmware blob to the SD card manually, but that causes u-boot to fail with the error "Bad Linux ARM64 Image Magic!" after the Boot Xen step in output. I also tried manually replacing the bootfiles written by the xen sd card image with the latest blobs from meta-raspberrypi's packages, but once the OS boots I find that xen is no longer running, making me suspect I screwed up the configuration somewhere.
It could be a kernel configuration issue between the two images, if
the Xen packages are on the image, but nothing is running. Can you
interact with the Xen support via the xen cli at all ? Just to get a
better error message ?

Is this something I can trivially fix? Is there a way for me to override the device tree selection used by the minimal xen image in my local.conf? Or do I need to investigate patching one of the meta-virtualization recipes?
Anything that needs changing, should be overridable via variable or
through bbappends, so hopefully no patching is required.

Bruce


(Apologies if I've used any of the wrong lingo/terms here; still new to RasPi/Yocto/Xen :D)




--
- Thou shalt not follow the NULL pointer, for chaos and madness await
thee at its end
- "Use the force Harry" - Gandalf, Star Trek II


Re: [PATCH] python3-dtc: port to Python 3.10

Bruce Ashfield
 

My xen-image-minimal build worked with this change, so I've grabbed it and
pushed it to master.

Bruce

On Thu, Nov 11, 2021 at 8:57 AM Ross Burton <ross@...> wrote:

Signed-off-by: Ross Burton <ross.burton@...>
---
recipes-kernel/dtc/files/ssize.patch | 35 +++++++++++++++++++++++++
recipes-kernel/dtc/python3-dtc_1.6.1.bb | 3 ++-
2 files changed, 37 insertions(+), 1 deletion(-)
create mode 100644 recipes-kernel/dtc/files/ssize.patch

diff --git a/recipes-kernel/dtc/files/ssize.patch b/recipes-kernel/dtc/files/ssize.patch
new file mode 100644
index 0000000..3156896
--- /dev/null
+++ b/recipes-kernel/dtc/files/ssize.patch
@@ -0,0 +1,35 @@
+Python 3.10 has made it mandatory that the 'string+length` formats use ssize_t
+instead of int, so define the magic symbol and upcast the ints from the libfdt
+API to ssize_t.
+
+Upstream-Status: Pending
+Signed-off-by: Ross Burton <ross.burton@...>
+
+diff --git a/pylibfdt/libfdt.i b/pylibfdt/libfdt.i
+index 51ee801..075ef70 100644
+--- a/pylibfdt/libfdt.i
++++ b/pylibfdt/libfdt.i
+@@ -1044,9 +1044,9 @@ typedef uint32_t fdt32_t;
+ $result = Py_None;
+ else
+ %#if PY_VERSION_HEX >= 0x03000000
+- $result = Py_BuildValue("y#", $1, *arg4);
++ $result = Py_BuildValue("y#", $1, (Py_ssize_t)*arg4);
+ %#else
+- $result = Py_BuildValue("s#", $1, *arg4);
++ $result = Py_BuildValue("s#", $1, (Py_ssize_t)*arg4);
+ %#endif
+ }
+
+diff --git a/pylibfdt/setup.py b/pylibfdt/setup.py
+index ef40f15..88ff7d1 100755
+--- a/pylibfdt/setup.py
++++ b/pylibfdt/setup.py
+@@ -42,6 +42,7 @@ def get_version():
+ libfdt_module = Extension(
+ '_libfdt',
+ sources=[os.path.join(srcdir, 'libfdt.i')],
++ define_macros=[('PY_SSIZE_T_CLEAN', None)],
+ include_dirs=[os.path.join(srcdir, '../libfdt')],
+ libraries=['fdt'],
+ library_dirs=[os.path.join(top_builddir, 'libfdt')],
diff --git a/recipes-kernel/dtc/python3-dtc_1.6.1.bb b/recipes-kernel/dtc/python3-dtc_1.6.1.bb
index 293c8d3..d7d45a4 100644
--- a/recipes-kernel/dtc/python3-dtc_1.6.1.bb
+++ b/recipes-kernel/dtc/python3-dtc_1.6.1.bb
@@ -6,7 +6,8 @@ LICENSE = "GPLv2 | BSD-2-Clause"

DEPENDS = "flex-native bison-native swig-native libyaml dtc"

-SRC_URI = "git://git.kernel.org/pub/scm/utils/dtc/dtc.git;branch=master"
+SRC_URI = "git://git.kernel.org/pub/scm/utils/dtc/dtc.git;branch=master \
+ file://ssize.patch"

UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"

--
2.25.1



--
- Thou shalt not follow the NULL pointer, for chaos and madness await
thee at its end
- "Use the force Harry" - Gandalf, Star Trek II


[PATCH] python3-dtc: port to Python 3.10

Ross Burton <ross@...>
 

Signed-off-by: Ross Burton <ross.burton@...>
---
recipes-kernel/dtc/files/ssize.patch | 35 +++++++++++++++++++++++++
recipes-kernel/dtc/python3-dtc_1.6.1.bb | 3 ++-
2 files changed, 37 insertions(+), 1 deletion(-)
create mode 100644 recipes-kernel/dtc/files/ssize.patch

diff --git a/recipes-kernel/dtc/files/ssize.patch b/recipes-kernel/dtc/fi=
les/ssize.patch
new file mode 100644
index 0000000..3156896
--- /dev/null
+++ b/recipes-kernel/dtc/files/ssize.patch
@@ -0,0 +1,35 @@
+Python 3.10 has made it mandatory that the 'string+length` formats use s=
size_t
+instead of int, so define the magic symbol and upcast the ints from the =
libfdt
+API to ssize_t.
+
+Upstream-Status: Pending
+Signed-off-by: Ross Burton <ross.burton@...>
+
+diff --git a/pylibfdt/libfdt.i b/pylibfdt/libfdt.i
+index 51ee801..075ef70 100644
+--- a/pylibfdt/libfdt.i
++++ b/pylibfdt/libfdt.i
+@@ -1044,9 +1044,9 @@ typedef uint32_t fdt32_t;
+ $result =3D Py_None;
+ else
+ %#if PY_VERSION_HEX >=3D 0x03000000
+- $result =3D Py_BuildValue("y#", $1, *arg4);
++ $result =3D Py_BuildValue("y#", $1, (Py_ssize_t)*arg4);
+ %#else
+- $result =3D Py_BuildValue("s#", $1, *arg4);
++ $result =3D Py_BuildValue("s#", $1, (Py_ssize_t)*arg4);
+ %#endif
+ }
+=20
+diff --git a/pylibfdt/setup.py b/pylibfdt/setup.py
+index ef40f15..88ff7d1 100755
+--- a/pylibfdt/setup.py
++++ b/pylibfdt/setup.py
+@@ -42,6 +42,7 @@ def get_version():
+ libfdt_module =3D Extension(
+ '_libfdt',
+ sources=3D[os.path.join(srcdir, 'libfdt.i')],
++ define_macros=3D[('PY_SSIZE_T_CLEAN', None)],
+ include_dirs=3D[os.path.join(srcdir, '../libfdt')],
+ libraries=3D['fdt'],
+ library_dirs=3D[os.path.join(top_builddir, 'libfdt')],
diff --git a/recipes-kernel/dtc/python3-dtc_1.6.1.bb b/recipes-kernel/dtc=
/python3-dtc_1.6.1.bb
index 293c8d3..d7d45a4 100644
--- a/recipes-kernel/dtc/python3-dtc_1.6.1.bb
+++ b/recipes-kernel/dtc/python3-dtc_1.6.1.bb
@@ -6,7 +6,8 @@ LICENSE =3D "GPLv2 | BSD-2-Clause"
=20
DEPENDS =3D "flex-native bison-native swig-native libyaml dtc"
=20
-SRC_URI =3D "git://git.kernel.org/pub/scm/utils/dtc/dtc.git;branch=3Dmas=
ter"
+SRC_URI =3D "git://git.kernel.org/pub/scm/utils/dtc/dtc.git;branch=3Dmas=
ter \
+ file://ssize.patch"
=20
UPSTREAM_CHECK_GITTAGREGEX =3D "v(?P<pver>\d+(\.\d+)+)"
=20
--=20
2.25.1


Re: [m-c-s][PATCH] concurrent-ruby: add explicit branch

Peter Kjellerstedt
 

-----Original Message-----
From: meta-virtualization@... <meta-
virtualization@...> On Behalf Of kai
Sent: den 11 november 2021 11:07
To: meta-virtualization@...
Subject: [meta-virtualization][m-c-s][PATCH] concurrent-ruby: add explicit
branch

From: Kai Kang <kai.kang@...>

Add explicit branch master for concurrent-ruby as the same for other
recipes.

Signed-off-by: Kai Kang <kai.kang@...>
---
meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb
b/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb
index a328203e..61a2c598 100644
--- a/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb
+++ b/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://www.concurrent-ruby.com"
LICENSE = "MIT"
LIC_FILES_CHKSUM =
"file://LICENSE.md;md5=fde65ae93d18826f70c6fe125aa04297"

-SRC_URI = "git://github.com/ruby-concurrency/concurrent-ruby.git;protocol=https;tag=v1.1.6\
+SRC_URI = "git://github.com/ruby-concurrency/concurrent-ruby.git;protocol=https;tag=v1.1.6;branch=master \
While at it, why not remove the tag= and replace it with a proper
SRCREV = "<sha1>"?

file://0001-Removed-check-for-concurrent_ruby.jar.patch"

S = "${WORKDIR}/git"
--
2.17.1
//Peter


[m-c-s][PATCH] concurrent-ruby: add explicit branch

kai
 

From: Kai Kang <kai.kang@...>

Add explicit branch master for concurrent-ruby as the same for other
recipes.

Signed-off-by: Kai Kang <kai.kang@...>
---
meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb b/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb
index a328203e..61a2c598 100644
--- a/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb
+++ b/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://www.concurrent-ruby.com"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.md;md5=fde65ae93d18826f70c6fe125aa04297"

-SRC_URI = "git://github.com/ruby-concurrency/concurrent-ruby.git;protocol=https;tag=v1.1.6\
+SRC_URI = "git://github.com/ruby-concurrency/concurrent-ruby.git;protocol=https;tag=v1.1.6;branch=master \
file://0001-Removed-check-for-concurrent_ruby.jar.patch"

S = "${WORKDIR}/git"
--
2.17.1


[m-c-s][PATCH] open-iscsi-user: remove typo spaces in SRC_URI

kai
 

From: Kai Kang <kai.kang@...>

There are typo spaces in SRC_URI which are introduced when add
';branch=master'. Remove them.

Signed-off-by: Kai Kang <kai.kang@...>
---
.../recipes-connectivity/open-iscsi/open-iscsi-user_2.1.4.bb | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-user_2.1.4.bb b/meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-user_2.1.4.bb
index d4c489cf..fe802b72 100644
--- a/meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-user_2.1.4.bb
+++ b/meta-openstack/recipes-connectivity/open-iscsi/open-iscsi-user_2.1.4.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "kmod openssl util-linux open-isns"
DEPENDS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"

-SRC_URI = "git://github.com/open-iscsi/open-iscsi.git;protocol=https ;branch=master \
+SRC_URI = "git://github.com/open-iscsi/open-iscsi.git;protocol=https;branch=master \
file://0001-fix-build-error-of-cross-build.patch \
"

--
2.17.1

501 - 520 of 7403