Re: [PATCH 1/2] xen, rpi4: Fix syntax in linux-yocto bbappend


Bruce Ashfield
 

FYI: Christopher is having a look at these updates.

I just wanted to let everyone know that they haven't been missed.

Bruce

On Thu, Sep 30, 2021 at 10:54 AM luca fancellu <luca.fancellu@...> wrote:

Syntax conversion for bbappend linux-yocto_5.10
and linux-yocto-dev inside the raspberrypi
dynamic layer.

Signed-off-by: Luca Fancellu <luca.fancellu@...>
---
.../recipes-kernel/linux/linux-yocto-dev.bbappend | 6 +++---
.../recipes-kernel/linux/linux-yocto_5.10.bbappend | 6 +++---
2 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend
index 8381e44..5f43052 100644
--- a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -1,8 +1,8 @@
# For a Xen-enabled distro on the Raspberry Pi, override the contents of cmdline.txt
# with Xen-on-ARM-specific command line options

-KBRANCH_raspberrypi4-64 ?= "standard/bcm-2xxx-rpi"
-KMACHINE_raspberrypi4-64 ?= "bcm-2xxx-rpi4"
-COMPATIBLE_MACHINE_raspberrypi4-64 = "(raspberrypi4-64)"
+KBRANCH:raspberrypi4-64 ?= "standard/bcm-2xxx-rpi"
+KMACHINE:raspberrypi4-64 ?= "bcm-2xxx-rpi4"
+COMPATIBLE_MACHINE:raspberrypi4-64 = "(raspberrypi4-64)"

require linux-yocto_xen-rpi.inc
diff --git a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto_5.10.bbappend b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto_5.10.bbappend
index af92493..f279ef7 100644
--- a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto_5.10.bbappend
+++ b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto_5.10.bbappend
@@ -1,6 +1,6 @@
# Enable use of the linux-yocto 5.10 kernel for the Raspberry Pi 4
-KBRANCH_raspberrypi4-64 ?= "v5.10/standard/bcm-2xxx-rpi"
-KMACHINE_raspberrypi4-64 ?= "bcm-2xxx-rpi4"
-COMPATIBLE_MACHINE_raspberrypi4-64 = "(raspberrypi4-64)"
+KBRANCH:raspberrypi4-64 ?= "v5.10/standard/bcm-2xxx-rpi"
+KMACHINE:raspberrypi4-64 ?= "bcm-2xxx-rpi4"
+COMPATIBLE_MACHINE:raspberrypi4-64 = "(raspberrypi4-64)"

require linux-yocto_xen-rpi.inc
--
2.17.1



--
- Thou shalt not follow the NULL pointer, for chaos and madness await
thee at its end
- "Use the force Harry" - Gandalf, Star Trek II

Join meta-virtualization@lists.yoctoproject.org to automatically receive all group messages.