Re: Starting Xen guest on Raspberry-Pi4. #meta-virtualization #yocto

Siddhartha V

Hi sir,

 I tried to do some work on patch you suggested but sadly I didn't get how to download the  patches from the      I tried a lot and also googled to get some knowledge but that also didn't help me. So I directly downloaded the raspberry-pi4-xen-series branch from and tried to build the image. But I got stuck with below error :
ERROR: linux-raspberrypi-1_5.4.40+gitAUTOINC+aafb8f095e_machine-r0 do_fetch: Fetcher failure for URL: 'git://;branch=rpi-5.4.y'. Unable to fetch URL from any source.
ERROR: Logfile of failure stored in: /home/siddhu/Documents/yocto/zindagi/build/tmp/work/raspberrypi4_64-poky-linux/linux-raspberrypi/1_5.4.40+gitAUTOINC+aafb8f095e_machine-r0/temp/log.do_fetch.3928
ERROR: Task (/home/siddhu/Documents/yocto/zindagi/sources/meta-raspberrypi/recipes-kernel/linux/ failed with exit code '1'
NOTE: Tasks Summary: Attempted 3957 tasks of which 3949 didn't need to be rerun and 1 failed.
The other layers I was using along with the aspberry-pi4-xen-series branch from  are as below:


Even earlier when I started this work, I got this error but later when Christopher sir suggested the commit no's this got resolved.I think now also I am missing some important points.

 Later I read the    there Christopher sir told we should checkout the meta-raspberrypi: 5576a22061864bc451ec4fcacb7d830bf76b7ebd and meta-virtualization: d75bc448866d2b36779251efb1310d0234ece30b, plus this patch series applied on top, or clone the raspberry-pi4-xen-series branch from his repository.

As I didn't know how to download the patches, I cloned the above through below commands:

1. git clone git://
cd meta-raspberrypi
git checkout 5576a22061864bc451ec4fcacb7d830bf76b7ebd

2.git clone  -b  raspberry-pi4-xen-series

And I have below lines in my local.conf:

MACHINE = "raspberrypi4-64"
DISTRO_FEATURES_append = " xen virtualization"
QEMU_TARGETS = "i386 x86_64 aarch64 arm"
PACKAGECONFIG_pn-qemu += " xen fdt"
PACKAGECONFIG_remove_pn-qemu += " sdl"
IMAGE_FSTYPES = "tar.xz tar.bz2 ext3 rpi-sdimg"

Is this ok sir? I have not built yet but before I start building I wanted to know If I am on right path. Why I doubt here is I am didn't get the proper grip on yocto yet.

Can I build the image by " $ bitbake -k xen-image-minimal " ?

Best Regards,
Siddhartha V

Join { to automatically receive all group messages.