Re: [PATCH] cgroup-lite: remove incorrect SYSTEMD_AUTO_ENABLE setting


 

On 06/05/2019 03:00, Hongxu Jia wrote:
Since commit [154abbc329 systemd: create preset files instead of
installing in image] applied in oe-core, it checks SYSTEMD_AUTO_ENABLE
...
|ERROR: cgroup-lite-1.15-r0 do_package: SYSTEMD_AUTO_ENABLE_cgroup-lite
'mask' is not 'enable' or 'disable'
...
Signed-off-by: Hongxu Jia <hongxu.jia@...>
---
recipes-containers/cgroup-lite/cgroup-lite_1.15.bb | 1 -
1 file changed, 1 deletion(-)
diff --git a/recipes-containers/cgroup-lite/cgroup-lite_1.15.bb b/recipes-containers/cgroup-lite/cgroup-lite_1.15.bb
index 7b48c3a..cb16a65 100644
--- a/recipes-containers/cgroup-lite/cgroup-lite_1.15.bb
+++ b/recipes-containers/cgroup-lite/cgroup-lite_1.15.bb
@@ -18,7 +18,6 @@ INITSCRIPT_PARAMS = "start 8 2 3 4 5 . stop 20 0 1 6 ."
# where systemd is in use.
SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE_${PN} = "cgroups-init.service"
-SYSTEMD_AUTO_ENABLE_${PN} = "mask"
Looking at the commit message from when this was added (http://git.yoctoproject.org/cgit/cgit.cgi/meta-virtualization/commit/?id=5b13da8e575ac746b46426f2471bf004b2201e41), the intention is that the service is indeed masked.

Rather than breaking this behaviour I'd like to see if we can support this in oe-core.

Cc-ing Jonas and Alex on this one - is it simple to support `SYSTEMD_AUTO_ENABLE = "mask"` after the recent systemd changes in oe-core?

Thanks,

--
Paul Barker
Managing Director & Principal Engineer
Beta Five Ltd

Join meta-virtualization@lists.yoctoproject.org to automatically receive all group messages.