ROOT LOGIN ISSUE of K2g (Yocto- meta-TI (version : ROCKO))


asif.malek@...
 

Hi,
 

I have used meta-ti layer (Version :Rocko ) to generate core-image-minimal for my 66ak2g12 board from TI. I’m able to boot up my board properly  but after booting up  not able to login.

I’ve tried “root” or blank password but still it’s throwing wrong password.

When I’m using “root” as a user then it throws “can’t set root user”.

 

In local.conf  the variable is as default,

 

EXTRA_IMAGE_FEATURES?= “debug-tweaks”

 

Can you please help me to resolve this issue. Please refer the log also.

 

“k2g-evm login: root

login: can't set

Poky (Yocto Project Reference Distro) 3.3+snapshot-f2728d3ec8c0589e02e9a3ce7cf8aca902cae0a3 k2g-evm /dev/ttyS0 “

 

 

Regards

Asif Malek

Assistant Engineer(Delta Electronics India)


Nishanth Menon
 

On 22:46-20210912, asif.malek@deltaww.com wrote:
Hi,

I have used meta-ti layer (Version :Rocko ) to generate core-image-minimal for my 66ak2g12 board from TI. I’m able to boot up my board properly  but after booting up  not able to login.

I’ve tried “root” or blank password but still it’s throwing wrong password.

When I’m using “root” as a user then it throws “can’t set root user”.

In local.conf  the variable is as default,

EXTRA_IMAGE_FEATURES?= “debug-tweaks”
[1] I'd be guessing, but = instead of ?=


Can you please help me to resolve this issue. Please refer the log also.

“k2g-evm login: root

login: can't set
^^ weird "can't set" message..


Poky (Yocto Project Reference Distro) 3.3+snapshot-f2728d3ec8c0589e02e9a3ce7cf8aca902cae0a3 k2g-evm /dev/ttyS0 “
meta-ti does'nt set the password for poky.

[1] https://www.yoctoproject.org/docs/2.4/ref-manual/ref-manual.html#var-EXTRA_IMAGE_FEATURES

--
Regards,
Nishanth Menon
Key (0xDDB5849D1736249D) / Fingerprint: F8A2 8693 54EB 8232 17A3 1A34 DDB5 849D 1736 249D