Building for TI 8148 EVM


Rainer Koenig <Rainer.Koenig@...>
 

Hi,

I'm currently trying to build an image for the TI 8148 EVM board. For
that I added the meta-ti layer to the standard Yocto/Edison environment.

meta-ti has under conf/machine a dm8148-evm.conf. So I wrote dm8148-evm
as MACHINE in my local.conf.

Build stopped at building u-boot_git.bb and William Mills pointed me to
u-boot_2010.06-psp.bb for the 8148 EVM board. I tried that but then the
build process complained about the SRCREV. Looking at the recipe I see:

require u-boot.inc

FILESPATHPKG =. "u-boot-psp-git:"

COMPATIBLE_MACHINE =
"am387x-evm|am389x-evm|c6a814x-evm|c6a816x-evm|dm814x-evm"

SRC_URI =
"git://arago-project.org/git/projects/u-boot-omap3.git;branch=${BRANCH};protocol=git"

BRANCH_ti814x = "ti81xx-master"
SRCREV_pn-${PN}_ti814x = "5fcf46a405fe8e8a59a04d3cebdafd39ac0c4bd0"
LIC_FILES_CHKSUM_pn-${PN}_ti814x =
"file://COPYING;md5=4c6cde5df68eff615d36789dc18edd3b"

Questions: I can solve my SRCREV problem when I substite the ti814x in
BRANCH... and SRCREV with my actual dm8148-evm. That makes me ask, what
the purpose of the COMPATIBLE_MACHINE variable is?

If this what I (beginner level) found is a bug, then where do I report
it or submit a fix for it?

The recipe built u-boot.bin now, but I don't see an MLO file in my image
directory. What did I do wrong?

After the image compiled I put it on an SD card and tried to boot with
it, but the kernel runs into a panic:

USB Video Class driver (v1.0.0)
OMAP Watchdog Timer Rev 0x00: initial timeout 60 sec
usbcore: registered new interface driver usbhid
usbhid: USB HID core driver
Unable to handle kernel NULL pointer dereference at virtual address 00000002
pgd = c0004000
[00000002] *pgd=00000000
Internal error: Oops: 5 [#1]
last sysfs file:
Modules linked in:
CPU: 0 Not tainted (2.6.37+ #2)
PC is at strcmp+0xc/0x40
LR is at omap_mbox_get+0x3c/0x1d0
pc : [<c01cf034>] lr : [<c00566c4>] psr: a0000013
sp : de83df28 ip : de83df38 fp : de83df34
r10: 00000000 r9 : 00000000 r8 : 00000000
r7 : 00000013 r6 : c0458048 r5 : c0503af8 r4 : c04de2e4
r3 : 00000064 r2 : 00000076 r1 : c0458048 r0 : 00000002
Flags: NzCv IRQs on FIQs on Mode SVC_32 ISA ARM Segment kernel
Control: 10c5387d Table: 80004019 DAC: 00000017
Process swapper (pid: 1, stack limit = 0xde83c2e8)
Stack: (0xde83df28 to 0xde83e000)
df20: de83df5c de83df38 c00566c4 c01cf034 c02cc038
c01cf034
df40: 00000000 c0503a9c c0503a98 00000000 de83df7c de83df60 c02cfb0c
c0056694
df60: 00000000 00000000 c0029c0c c0024034 de83dfa4 de83df80 c0024070
c02cf988
df80: de83c000 c0029c0c c0024034 00000000 00000013 00000000 de83dfdc
de83dfa8
dfa0: c00343b8 c0024040 de83dfc4 00000176 c04ea918 c006154c c0029c0c
c0029cb0
dfc0: c006154c 00000013 00000000 00000000 de83dff4 de83dfe0 c0008cf4
c0034304
dfe0: 00000000 c0008c40 00000000 de83dff8 c006154c c0008c4c 00010960
4a408a08
Backtrace:
[<c01cf028>] (strcmp+0x0/0x40) from [<c00566c4>] (omap_mbox_get+0x3c/0x1d0)
[<c0056688>] (omap_mbox_get+0x0/0x1d0) from [<c02cfb0c>]
(notify_shm_drv_setup+0x190/0x268)
r6:00000000 r5:c0503a98 r4:c0503a9c
[<c02cf97c>] (notify_shm_drv_setup+0x0/0x268) from [<c0024070>]
(notify_init+0x3c/0x2b0)
r5:c0024034 r4:c0029c0c
[<c0024034>] (notify_init+0x0/0x2b0) from [<c00343b8>]
(do_one_initcall+0xc0/0x194)
r8:00000000 r7:00000013 r6:00000000 r5:c0024034 r4:c0029c0c
r3:de83c000
[<c00342f8>] (do_one_initcall+0x0/0x194) from [<c0008cf4>]
(kernel_init+0xb4/0x164)
r9:00000000 r8:00000000 r7:00000013 r6:c006154c r5:c0029cb0
r4:c0029c0c
[<c0008c40>] (kernel_init+0x0/0x164) from [<c006154c>] (do_exit+0x0/0x61c)
r5:c0008c40 r4:00000000
Code: e89da800 e1a0c00d e92dd800 e24cb004 (e4d03001)
---[ end trace e6ffc3d1c2d89a51 ]---
Kernel panic - not syncing: Attempted to kill init!

Now I start wondering if I'm using the right kernel for this board.
meta-ti/recipes-kernel/linux/lists recipes for a lot of kernels, but
according to the conf/machine/include/ti814x.inc I should have used the
right one. So how can I debug this kernel panic?

Regards
Rainer
--
Dipl.-Inf. (FH) Rainer Koenig
Project Manager Linux Clients
Dept. PDG WPS R&D SW OSE

Fujitsu Technology Solutions
Bürgermeister-Ullrich-Str. 100
86199 Augsburg
Germany

Telephone: +49-821-804-3321
Telefax: +49-821-804-2131
Mail: mailto:Rainer.Koenig@...

Internet ts.fujtsu.com
Company Details ts.fujitsu.com/imprint.html

Join meta-ti@lists.yoctoproject.org to automatically receive all group messages.