Re: [dunfell][PATCH] conf: machine: am64xx-hs-evm: Fix naming of u-boot.img


Aparna M
 

On 19:41-20220221, Denys Dmytriyenko wrote:
On Mon, Feb 21, 2022 at 01:43:31PM +0530, Aparna M via lists.yoctoproject.org wrote:
All the HS platforms generate the u-boot binary as u-boot.img_HS
but the bootloader expects the binary to be named as u-boot.img

Due to this mismatch, script cannot find the required image to
be added in the WIC image. Fix this by overwriting the
UBOOT_IMAGE variable via conf file.
Can you please clarify which script cannot find the image? Thanks!
The wic file generation scripts that pick up files for the boot
partition from the IMAGE_BOOT_FILES variable is unable to find
u-boot.img. As a result, the generated wic image does not package the
uboot binary and fails.


Also, how does it work for am65xx HS, j721e HS, j7200 HS? Why only
am64xx HS?
The previous releases for these three platforms did not include wic
images. I believe this issue might be present in these platforms as
well.


Signed-off-by: Nikhil Devshatwar <nikhil.nd@...>

Signed-off-by: Aparna M <a-m1@...>
---
conf/machine/am64xx-hs-evm.conf | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/conf/machine/am64xx-hs-evm.conf b/conf/machine/am64xx-hs-evm.conf
index 44e81463..781b8318 100644
--- a/conf/machine/am64xx-hs-evm.conf
+++ b/conf/machine/am64xx-hs-evm.conf
@@ -17,6 +17,7 @@ UBOOT_DTBO_OFFSET = "0x00010000"
SPL_BINARY = "tispl.bin_HS"
SPL_BINARYNAME = "tispl.bin"
UBOOT_BINARY = "u-boot.img_HS"
-IMAGE_BOOT_FILES = "${UBOOT_BINARY}"
+UBOOT_IMAGE = "u-boot.img"
+IMAGE_BOOT_FILES = "${UBOOT_IMAGE}"

TI_SECURE_DEV_PKG = "${TI_SECURE_DEV_PKG_K3}"
--
2.17.1

Join meta-ti@lists.yoctoproject.org to automatically receive all group messages.