Post Install Intercept Hook Failed


Sebastian Long
 

Hello,

 

I am not sure if this is the right place to ask this, so I would be very grateful if you could point me in the right direction, if not…

 

I have a custom board which uses the TXUL-8013 SoC module from Karo Electronics which is powered by the IMX6ULL.  I am trying to build an minimal image with a few additional features added in.  In particular: systemd, package-management and udev.  My build is failing at do_rootfs() with the following error messages:

 

ERROR: karo-image-minimal-1.0-r0 do_rootfs: The postinstall intercept hook 'update_udev_hwdb' failed, details in /home/seb/karo-bsp/minimal-karo-image-build/tmp/work/txul_8013-poky-linux-gnueabi/karo-image-minimal/1.0-r0/temp/log.do_rootfs

ERROR: Logfile of failure stored in: /home/seb/karo-bsp/minimal-karo-image-build/tmp/work/txul_8013-poky-linux-gnueabi/karo-image-minimal/1.0-r0/temp/log.do_rootfs.16330

ERROR: Task (/home/seb/karo-bsp/layers/meta-karo-distro/recipes-core/images/karo-image-minimal.bb:do_rootfs) failed with exit code '1'

 

Following the message to the log, I read:

 

NOTE: Exit code 127. Output:

/home/seb/karo-bsp/minimal-karo-image-build/tmp/work/txul_8013-poky-linux-gnueabi/karo-image-minimal/1.0-r0/intercept_scripts-4af156835672208005bb416519686e5c1d30c773d50314b14a72dcde35156d36/update_udev_hwdb: 9: /home/seb/karo-bsp/minimal-karo-image-build/tmp/work/txul_8013-poky-linux-gnueabi/karo-image-minimal/1.0-r0/intercept_scripts-4af156835672208005bb416519686e5c1d30c773d50314b14a72dcde35156d36/update_udev_hwdb: qemuwrapper: not found

 

ERROR: The postinstall intercept hook 'update_udev_hwdb' failed, details in /home/seb/karo-bsp/minimal-karo-image-build/tmp/work/txul_8013-poky-linux-gnueabi/karo-image-minimal/1.0-r0/temp/log.do_rootfs

 

In an attempt to fix this, I have added a .bbappend to the image recipe that adds a dependency for qemuwrapper-cross (qemuwrapper on its own didn’t work).  However, it still fails.  Does anybody have an idea where I am going wrong?  Or how I might go about debugging it?

 

Many thanks in advance!

 

Kind regards,

 

 

Sebastian


Mathan
 

Hello Sebastian

Most of the cases it getting failed in post install intercept.
Those errors are suspicious, 
Try to install the patch into poky layer and rebuild the Image.

Thanks & Regards,
Mathanraj