Date   

Support to change the alsa-utils package version

Dhanush Venugopal
 

Hi,

Please can i know how to replace the alsa-utils package with the different version.
since Im using the  Yocto 2.5.3 (sumo) and in local.conf i append the alsa-utils , its of the version 1.1.5.

How to replace alsa-utils package with 1.1.2 version .



Thanks & regards,
Dhanush


Does Yocto / OE build u-boot image for u-boot configs in #define CONFIG_EXTRA_ENV_SETTINGS? #define

JH
 

Hi,

I created recipes-bsp and an appended file u-boot-imx_2018.03.bbappend
to build a customized imx6ullevk image, I added my configures in
#define CONFIG_EXTRA_ENV_SETTINGS in mx6ullevk.h, it built the
u-boot-ram.imx and u-boot-nand.imx, I tried uuu to store
u-boot-ram.imx to the =customized imx6ullevk board, all settings in
CONFIG_EXTRA_ENV_SETTINGS were lost, set nothing in u-boot. It did not
seem that Yocto / OE built the u-boot correctly and properly, what I
could be missing?

Thank you.

Kind regards,

- jh


Use Wayland for a single application fullscreen without window decoration

Christian Lohr <christian.lohr.ext@...>
 

Hello,

 

I have a Variscite Dart i.MX8M (this Model: http://variwiki.com/index.php?title=DART-MX8M) and I want to run a single application (Qt) without window decoration, and it should run in fullscreen mode. I’ve also read that EGLFS with i.MX8 is no more supported (this was my preferred solution), and only Wayland or XWayland is possible. This Wayland/Weston topic is completely new to me. Is there a more detailed description how to get it running? Do I have to use Weston Compositor, or should I use a different compositor?

I’ve read through this : https://wiki.yoctoproject.org/wiki/Wayland , but I didn’t find a solution for my problem. Is there anybody who already did this?

 

Best regards,

 

 

Christian Lohr

Im Auftrag von:

Carl Zeiss Meditec AG
Göschwitzer Strasse 51-52

07745 Jena, Deutschland

christian.lohr.ext@...

Tel: +493641220206

 

 

 


Re: IMAGE_CMD_sdcard strange line

Mauro Ziliani
 

Please ignore this post.

I solved

Il 03/03/20 16:50, Mauro Ziliani ha scritto:

Hi all

Sorry but I need to rework with Krogoth.

I look inside image_types_fsl.bbclass because I cannot produce the .sdcard image.

I see at line 320 this command


dd if=/dev/zero of=${SDCARD} bs=1 count=0 seek=$(expr 1024 \* ${SDCARD_SIZE})


Why the command try to make a 0 size file with a seek of sdcard dimension?

I think this is an error.


Best regards,

  MZ



    


IMAGE_CMD_sdcard strange line

Mauro Ziliani
 

Hi all

Sorry but I need to rework with Krogoth.

I look inside image_types_fsl.bbclass because I cannot produce the .sdcard image.

I see at line 320 this command


dd if=/dev/zero of=${SDCARD} bs=1 count=0 seek=$(expr 1024 \* ${SDCARD_SIZE})


Why the command try to make a 0 size file with a seek of sdcard dimension?

I think this is an error.


Best regards,

  MZ


Issues with make_dtb_boot_files

Patrick Davis
 

I’m running into a rather odd issue when attempting to upgrade a custom target (machine and distro) based off of the iMX6 platform from Thud to Warrior. (The build works just fine in Thud.) The build for warrior fails at do_image_wic because it cannot execute make_dtb_boot_files. More specifically, it expects make_dtb_boot_files to be a file and then fails when it can’t find the file. Here is build output:

| DEBUG: Python function extend_recipe_sysroot finished

| DEBUG: Executing shell function do_image_wic

| INFO: Creating image(s)...

|

| ERROR: _exec_cmd: install -m 0644 -D /home/vagrant/warrior/build/tmp/deploy/images/custom /make_dtb_boot_files /home/vagrant/warrior/build/tmp/work/custom-custom-linux-gnueabi/rootfs/1.0-r0/deploy-rootfs-image-complete/rootfs-custom-20200226170413/tmp.wic.a1r6y7th/boot.2/make_dtb_boot_files returned '1' instead of 0

| output: install: cannot stat '/home/vagrant/warrior/build/tmp/deploy/images/custom/make_dtb_boot_files': No such file or directory

|

| WARNING: exit code 1 from a shell command.

| ERROR: Function failed: do_image_wic (log file is located at /home/vagrant/warrior/build/tmp/work/custom-custom-linux-gnueabi/rootfs/1.0-r0/temp/log.do_image_wic.764)

ERROR: Task (/home/vagrant/warrior/sources/meta-custom-bsp/recipes-aca/images/rootfs.bb:do_image_wic) failed with exit code '1'

 

Note, “rootfs” is the build target in question.

 

As part of my own investigation into this issue, I believe this issue stems from the rootfs.env file incorrectly being compiled. If I open the ‘rootfs.env’ file located within build/tmp/sysroots/custom/imgdata, I find the following:

 

BBLAYERS="/home/vagrant/warrior/sources/poky/meta   /home/vagrant/warrior/sources/poky/meta-poky     /home/vagrant/warrior/sources/meta-openembedded/meta-oe   /home/vagrant/warrior/sources/meta-openembedded/meta-multimedia     /home/vagrant/warrior/sources/meta-freescale   /home/vagrant/warrior/sources/meta-freescale-3rdparty   /home/vagrant/warrior/sources/meta-freescale-distro   /home/vagrant/warrior/sources/meta-fsl-bsp-release/imx/meta-bsp   /home/vagrant/warrior/sources/meta-fsl-bsp-release/imx/meta-sdk   /home/vagrant/warrior/sources/meta-fsl-bsp-release/imx/meta-ml  /home/vagrant/warrior/sources/meta-browser /home/vagrant/warrior/sources/meta-rust /home/vagrant/warrior/sources/meta-openembedded/meta-networking /home/vagrant/warrior/sources/meta-openembedded/meta-python /home/vagrant/warrior/sources/meta-openembedded/meta-filesystems /home/vagrant/warrior/sources/meta-qt5 /home/vagrant/warrior/sources/meta-custom-bsp /home/vagrant/warrior/sources/meta-mender/meta-mender-core"

IMGDEPLOYDIR="/home/vagrant/warrior/build/tmp/work/custom-custom-linux-gnueabi/rootfs/1.0-r0/deploy-rootfs-image-complete"

DEPLOY_DIR_IMAGE="/home/vagrant/warrior/build/tmp/deploy/images/custom"

FAKEROOTCMD="/home/vagrant/warrior/build/tmp/sysroots-components/x86_64/pseudo-native/usr/bin/pseudo"

IMAGE_BASENAME="rootfs"

IMAGE_BOOT_FILES="zImage     ${@make_dtb_boot_files(d)}     ${@bb.utils.contains('COMBINED_FEATURES', 'optee', 'tee.bin uTee-${OPTEE_BIN_EXT}', '', d)}     ${@bb.utils.contains('COMBINED_FEATURES', 'xen', 'xen', '', d)}"

IMAGE_LINK_NAME="rootfs-custom"

IMAGE_ROOTFS="/home/vagrant/warrior/build/tmp/work/custom-custom-linux-gnueabi/rootfs/1.0-r0/rootfs"

INITRAMFS_FSTYPES="cpio.gz"

RECIPE_SYSROOT_NATIVE="/home/vagrant/warrior/build/tmp/work/custom-custom-linux-gnueabi/rootfs/1.0-r0/recipe-sysroot-native"

ROOTFS_SIZE="121498"

STAGING_DATADIR="/home/vagrant/warrior/build/tmp/work/custom-custom-linux-gnueabi/rootfs/1.0-r0/recipe-sysroot/usr/share"

STAGING_DIR="/home/vagrant/warrior/build/tmp/sysroots"

STAGING_LIBDIR="/home/vagrant/warrior/build/tmp/work/custom-custom-linux-gnueabi/rootfs/1.0-r0/recipe-sysroot/usr/lib"

TARGET_SYS="arm-custom-linux-gnueabi"

 

The problem is, I have no idea what my custom layer/build target would have done to interfere with the creation of the rootfs.env file, or how to go about fixing it. Any help or guidance that can be offered would be greatly appreciated.

 

Thank you.

-Patrick

 


Re: gstreamer allocation error on imx6dl-sabresd

Clay Montgomery
 

Hi Mauro,

  I would first determine if this problem could be caused by a problem with gstreamer.

One way to do that would be to run the camera with the mxc_v4l2_capture.out app that is provided by NXP in their unit tests.

It has some basic support for uvcvideo and runs without gstreamer.

Then you will know if it could really be a kernel problem.

Another approach, would be to try gstreamer on a newer kernel.

Regards, Clay


On 2/6/2020 3:50 AM, Mauro Ziliani wrote:

Hi all.

I'm working on a imx6dl-sabresd derived board, gstreamer, uvcvideo webcam, Yocto Freescale i.MX Release Distro 4.1.15-2.0.1 FXMZ /dev/ttymxc0

the pipeline is

gst-launch-1.0 \
        imxv4l2src device=/dev/video1 \
        ! capsfilter caps="video/x-raw, width=640, height=480" \
        ! imxvideoconvert_g2d rotation=4 \
        ! imxv4l2sink overlay-width=800 overlay-height=600 overlay-left=235 overlay-top=65 enable-last-sample=true name=sink


Sometime the webcam freeze. After the first freeze the video stream is black and gstream GST_DEBUG=1 show the following message

WARN    default gstallocatorphymem.c:259:gst_buffer_is_phymem: physical address in memory block is invalid


There is some explanation/patch for this behavior?


gstreamer 1.8.1

gstreamer-plugin-imx 0.12.2


Thanks for your help

MZ



    


u-boot saveenv corrupted other MTD parttions

JH
 

Hi,

I have three MTD partitions, the mtd2 storage installed UBIFS volumes,
first is dtb volume, second is kernel volume, third is rootfs volume.
The saveenv was configured to save environment variables to NAND
ubootenv.

gpmi-nand:1m(boot),1m(ubootenv),-(storage)

There was no issue to run NAND boot, but if I called saveenv in
u-boot, then I run bootcmd again, it could not boot from NAND any
more:

Bad Linux ARM zImage magic!

The saveenv does not take any parameters, how did it work to write to
the NAND 1m(ubootenv)?

=> saveenv
Saving Environment to NAND... Erasing NAND...
Erasing at 0x5e0000 -- 100% complete.
Writing to NAND... OK

It looks like that saveenv overwritten to the storage, is 0x5e0000 RAM
or NAND address?

Where was that address defined?

How do I know it was the NAND 1m(ubootenv) address?

Thank you.

Kind regards,

- jh


enabling lpuart in u-boot on ls1043a for peripheral

zach.ferree@...
 

Hi,

I have a question about enabling lpuarts in u-boot for the purpose of communicating with a peripheral device.
i am using the ls1043ardb sdboot as a jumping off point and all I did was enable the fsl_lpuart in the ls1043ardb sdboot defconfig.
I enbled the fsl_lpuart from within menuconfig and i didnt see any other dependencies i needed to enable so i tried to build it and i got the following error
"u-boot-qoriq/drivers/serial/serial_lpuart.c:417: undefined reference to `devfdt_get_addr'"

do i need to enable something else in the defconfig?

regards,

Zach


Re: [OE-core] [yocto] Support UBI u-boot

Quentin Schulz <quentin.schulz@...>
 

Hi JH,

On Sun, Feb 09, 2020 at 08:01:15PM +1100, JH wrote:
Changed to https://source.codeaurora.org/external/imx/uboot-imx.git
branch imx_v2018.03_4.14.98_2.0.0_ga, it can now support
CONFIG_CMD_MTDPARTS ind defconfg, all MTDPARTS error gone, but then
2018.03-r0/git/cmd/ubi.c missed dependencies of del_mtd_partitions,
add_mtd_partitions, mtd_get_device_size all in mtdpart.c which can
only be enabled by CONFIG_MTD_PARTITIONS:

obj-$(CONFIG_MTD_PARTITIONS) += mtdpart.o

But that CONFIG_MTD_PARTITIONS is not supported in defconfig.

Could anyone advise which branch works for UBI?
FYI, U-boot was still slowly migrating to Kconfig only back then (maybe
still is). There was for a long time a mix between Kconfig options and
options in what I call board header files (include/configs/<board>.h).

Most likely CONFIG_MTD_PARTITIONS had to be defined there.

Biased recommendation: https://www.youtube.com/watch?v=5E0sdYkvq-Q

BR,
Quentin


IMX6UL SUMO: linux-imx_4.14.98.bb:do_compile fail due to arm-poky-linux-gnueabi-gcc: Command not found error

sikumar3@...
 

Hi,

My hardware is based on IMX6ULEVK.

I have pulled yocto SUMO version (imx-linux-sumo -m imx-4.14.98-2.0.0_ga.xml) and added few layers in the sources/base/conf/bblayer.conf file. I have also introduced new machine type imx6uloib which is the clone of imxulevk

project sources/base/

diff --git a/conf/bblayers.conf b/conf/bblayers.conf

index 092d58b..f803796 100644

--- a/conf/bblayers.conf

+++ b/conf/bblayers.conf

@@ -14,4 +14,7 @@ BBLAYERS = " \

   ${BSPDIR}/sources/meta-freescale \

   ${BSPDIR}/sources/meta-freescale-3rdparty \

   ${BSPDIR}/sources/meta-freescale-distro \

+  ${BSPDIR}/sources/meta-inode-eval \

+  ${BSPDIR}/sources/meta-inode-oib \

+  ${BSPDIR}/sources/meta-inode-release \


I am getting build errors when trying to build.

DISTRO=fsl-imx-xwayland MACHINE=imx6uloib source fsl-setup-release.sh -b build-ul
bitbake core-image-base

ERROR: linux-imx-4.14.98-r0 do_compile: oe_runmake failed
ERROR: linux-imx-4.14.98-r0 do_compile: Function failed: do_compile (log file is located at /nobackup/sikumar3/inode_sumo/build-ul/tmp/work/imx6uloib-poky-linux-gnueabi/linux-imx/4.14.98-r0/temp/log.do_compile.2640)
ERROR: Logfile of failure stored in: /nobackup/sikumar3/inode_sumo/build-ul/tmp/work/imx6uloib-poky-linux-gnueabi/linux-imx/4.14.98-r0/temp/log.do_compile.2640
Log data follows:
| DEBUG: Executing shell function do_compile
| /nobackup/sikumar3/inode_sumo/build-ul/tmp/work/imx6uloib-poky-linux-gnueabi/linux-imx/4.14.98-r0/temp/run.do_compile.2640: line 185: arm-poky-linux-gnueabi-gcc: command not found
| NOTE: make -j 16 HOSTCC=gcc  -isystem/nobackup/sikumar3/inode_sumo/build-ul/tmp/work/imx6uloib-poky-linux-gnueabi/linux-imx/4.14.98-r0/recipe-sysroot-native/usr/include -O2 -pipe -L/nobackup/sikumar3/inode_sumo/build-ul/tmp/work/imx6uloib-poky-linux-gnueabi/linux-imx/4.14.98-r0/recipe-sysroot-native/usr/lib -L/nobackup/sikumar3/inode_sumo/build-ul/tmp/work/imx6uloib-poky-linux-gnueabi/linux-imx/4.14.98-r0/recipe-sysroot-native/lib -Wl,-rpath-link,/nobackup/sikumar3/inode_sumo/build-ul/tmp/work/imx6uloib-poky-linux-gnueabi/linux-imx/4.14.98-r0/recipe-sysroot-native/usr/lib -Wl,-rpath-link,/nobackup/sikumar3/inode_sumo/build-ul/tmp/work/imx6uloib-poky-linux-gnueabi/linux-imx/4.14.98-r0/recipe-sysroot-native/lib -Wl,-rpath,/nobackup/sikumar3/inode_sumo/build-ul/tmp/work/imx6uloib-poky-linux-gnueabi/linux-imx/4.14.98-r0/recipe-sysroot-native/usr/lib -Wl,-rpath,/nobackup/sikumar3/inode_sumo/build-ul/tmp/work/imx6uloib-poky-linux-gnueabi/linux-imx/4.14.98-r0/recipe-sysroot-native/lib -Wl,-O1 HOSTCPP=gcc  -E ARCH=arm ARCH=arm zImage CC=arm-poky-linux-gnueabi-gcc   -fuse-ld=bfd -fdebug-prefix-map=/nobackup/sikumar3/inode_sumo/build-ul/tmp/work/imx6uloib-poky-linux-gnueabi/linux-imx/4.14.98-r0=/usr/src/debug/linux-imx/4.14.98-r0 -fdebug-prefix-map=/nobackup/sikumar3/inode_sumo/build-ul/tmp/work/imx6uloib-poky-linux-gnueabi/linux-imx/4.14.98-r0/recipe-sysroot= -fdebug-prefix-map=/nobackup/sikumar3/inode_sumo/build-ul/tmp/work/imx6uloib-poky-linux-gnueabi/linux-imx/4.14.98-r0/recipe-sysroot-native=  -fdebug-prefix-map=/nobackup/sikumar3/inode_sumo/build-ul/tmp/work-shared/imx6uloib/kernel-source=/usr/src/kernel   LD=arm-poky-linux-gnueabi-ld.bfd   LOADADDR=0x10008000
| /nobackup/sikumar3/inode_sumo/build-ul/tmp/work-shared/imx6uloib/kernel-source/scripts/gcc-version.sh: line 26: arm-poky-linux-gnueabi-gcc: command not found
| /nobackup/sikumar3/inode_sumo/build-ul/tmp/work-shared/imx6uloib/kernel-source/scripts/gcc-version.sh: line 27: arm-poky-linux-gnueabi-gcc: command not found
| make[2]: arm-poky-linux-gnueabi-gcc: Command not found
| make[2]: arm-poky-linux-gnueabi-gcc: Command not found
| make[2]: arm-poky-linux-gnueabi-gcc: Command not found

I see that arm-poky-linux-gnueabi-gcc is present in /build/tmp/work/ directory. But, i am not sure why it is not able to pick it up.
 
 


old ARM9 hardware gathering dust

Trevor Woerner
 

Hi,

I know this is a long shot...

I've been doing quite a lot of work recently with some older, ARM926ej-s,
hardware (specifically the lpc32xx) and have become rather interested in other
such systems (aka ARM9, ARMv5, ARM926ej-s, ...).

Is there any chance someone listening on this list might have, perhaps, an
imx23evk or an imx28evk sitting on their shelf gathering dust that they know
they'll never use again? If so I'd be interested in purchasing it (for a
reasonable price) and acting as the maintainer of such devices (should Otavio
be interested in giving up maintainership of these MACHINEs).

Thoughts, offers?

Best regards,
Trevor


Re: [PATCH] u-boot: set B directory for imx5's

Trevor Woerner
 

On Tue 2020-02-11 @ 02:17:03 PM, Otavio Salvador wrote:
On Tue, Feb 11, 2020 at 12:12 PM Trevor Woerner <twoerner@...> wrote:
On Tue 2020-02-11 @ 10:47:46 AM, Otavio Salvador wrote:
On Mon, Feb 10, 2020 at 8:14 PM Trevor Woerner <twoerner@...> wrote:
The imx5* machines need separate S and B directories to build u-boot-fslc
otherwise the build fails with:

| make[1]: *** No rule to make target '/z/build-master/meta-freescale/build/tmp-glibc/work/imx53qsb-oe-linux-gnueabi/u-boot-fslc/v2019.07+gitAUTOINC+ca0ab15271-r0/git/arch//cpu/u-boot.lds', needed by 'u-boot.lds'. Stop.

Build-tested with imx51evk, imx53ard, and imx53qsb.

Signed-off-by: Trevor Woerner <twoerner@...>
Please open an issue on github?
Okay.

IIRC, we are using different build directories for S and B so I am
wondering why it is failing.
This is what I'm getting:

$ bitbake virtual/bootloader -e | grep "^B="
B="/z/build-master/meta-freescale/build/tmp-glibc/work/imx53qsb-oe-linux-gnueabi/u-boot-fslc/v2019.07+gitAUTOINC+ca0ab15271-r0/git"
$ bitbake virtual/bootloader -e | grep "^S="
S="/z/build-master/meta-freescale/build/tmp-glibc/work/imx53qsb-oe-linux-gnueabi/u-boot-fslc/v2019.07+gitAUTOINC+ca0ab15271-r0/git"


Re: [PATCH] u-boot: set B directory for imx5's

Otavio Salvador
 

On Tue, Feb 11, 2020 at 12:12 PM Trevor Woerner <twoerner@...> wrote:
On Tue 2020-02-11 @ 10:47:46 AM, Otavio Salvador wrote:
On Mon, Feb 10, 2020 at 8:14 PM Trevor Woerner <twoerner@...> wrote:
The imx5* machines need separate S and B directories to build u-boot-fslc
otherwise the build fails with:

| make[1]: *** No rule to make target '/z/build-master/meta-freescale/build/tmp-glibc/work/imx53qsb-oe-linux-gnueabi/u-boot-fslc/v2019.07+gitAUTOINC+ca0ab15271-r0/git/arch//cpu/u-boot.lds', needed by 'u-boot.lds'. Stop.

Build-tested with imx51evk, imx53ard, and imx53qsb.

Signed-off-by: Trevor Woerner <twoerner@...>
Which branch did you use?
Master on everything:

Build Configuration:
BB_VERSION = "1.44.0"
BUILD_SYS = "x86_64-linux"
NATIVELSBSTRING = "opensuseleap-15.1"
TARGET_SYS = "arm-oe-linux-gnueabi"
MACHINE = "imx53qsb"
DISTRO = "nodistro"
DISTRO_VERSION = "nodistro.0"
TUNE_FEATURES = "arm armv7a vfp thumb neon callconvention-hard"
TARGET_FPU = "hard"
meta-freescale = "master:9227f4c9e6d77d3fa15f67d178ba9da02c5550fe"
meta = "master:44a4ac2294da0f53cbbfabc7ece836fe97f4d3f7"

https://git.yoctoproject.org/git/meta-freescale
git://git.openembedded.org/openembedded-core.git

conf/bblayers.conf:

# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
# changes incompatibly
LCONF_VERSION = "7"

BBPATH = "${TOPDIR}"
BBFILES ?= ""

BBLAYERS ?= " \
/opt/oe/configs/z/build-master/meta-freescale/layers/meta-freescale \
/opt/oe/configs/z/build-master/meta-freescale/layers/openembedded-core/meta \
"

conf/local.conf:

ACCEPT_FSL_EULA = "1"
MACHINE = "imx53qsb"
DISTRO = "nodistro"
DL_DIR = "/opt/Downloads"

PACKAGE_CLASSES ?= "package_ipk"
EXTRA_IMAGE_FEATURES ?= "debug-tweaks"
USER_CLASSES ?= "buildstats image-mklibs image-prelink"
PATCHRESOLVE ?= "noop"
BB_DISKMON_DIRS = "\
STOPTASKS,${TMPDIR},1G,100K \
STOPTASKS,${DL_DIR},1G,100K \
STOPTASKS,${SSTATE_DIR},1G,100K \
STOPTASKS,/tmp,100M,100K \
ABORT,${TMPDIR},100M,1K \
ABORT,${DL_DIR},100M,1K \
ABORT,${SSTATE_DIR},100M,1K \
ABORT,/tmp,10M,1K"
PACKAGECONFIG_append_pn-qemu-system-native = " sdl"
PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
ASSUME_PROVIDED += "libsdl2-native"
CONF_VERSION = "1"
Please open an issue on github?

IIRC, we are using different build directories for S and B so I am
wondering why it is failing.


--
Otavio Salvador O.S. Systems
http://www.ossystems.com.br http://code.ossystems.com.br
Mobile: +55 (53) 9 9981-7854 Mobile: +1 (347) 903-9750


Re: [PATCH] u-boot: set B directory for imx5's

Trevor Woerner
 

Hi Otavio,

On Tue 2020-02-11 @ 10:47:46 AM, Otavio Salvador wrote:
On Mon, Feb 10, 2020 at 8:14 PM Trevor Woerner <twoerner@...> wrote:
The imx5* machines need separate S and B directories to build u-boot-fslc
otherwise the build fails with:

| make[1]: *** No rule to make target '/z/build-master/meta-freescale/build/tmp-glibc/work/imx53qsb-oe-linux-gnueabi/u-boot-fslc/v2019.07+gitAUTOINC+ca0ab15271-r0/git/arch//cpu/u-boot.lds', needed by 'u-boot.lds'. Stop.

Build-tested with imx51evk, imx53ard, and imx53qsb.

Signed-off-by: Trevor Woerner <twoerner@...>
Which branch did you use?
Master on everything:

Build Configuration:
BB_VERSION = "1.44.0"
BUILD_SYS = "x86_64-linux"
NATIVELSBSTRING = "opensuseleap-15.1"
TARGET_SYS = "arm-oe-linux-gnueabi"
MACHINE = "imx53qsb"
DISTRO = "nodistro"
DISTRO_VERSION = "nodistro.0"
TUNE_FEATURES = "arm armv7a vfp thumb neon callconvention-hard"
TARGET_FPU = "hard"
meta-freescale = "master:9227f4c9e6d77d3fa15f67d178ba9da02c5550fe"
meta = "master:44a4ac2294da0f53cbbfabc7ece836fe97f4d3f7"

https://git.yoctoproject.org/git/meta-freescale
git://git.openembedded.org/openembedded-core.git

conf/bblayers.conf:

# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
# changes incompatibly
LCONF_VERSION = "7"

BBPATH = "${TOPDIR}"
BBFILES ?= ""

BBLAYERS ?= " \
/opt/oe/configs/z/build-master/meta-freescale/layers/meta-freescale \
/opt/oe/configs/z/build-master/meta-freescale/layers/openembedded-core/meta \
"

conf/local.conf:

ACCEPT_FSL_EULA = "1"
MACHINE = "imx53qsb"
DISTRO = "nodistro"
DL_DIR = "/opt/Downloads"

PACKAGE_CLASSES ?= "package_ipk"
EXTRA_IMAGE_FEATURES ?= "debug-tweaks"
USER_CLASSES ?= "buildstats image-mklibs image-prelink"
PATCHRESOLVE ?= "noop"
BB_DISKMON_DIRS = "\
STOPTASKS,${TMPDIR},1G,100K \
STOPTASKS,${DL_DIR},1G,100K \
STOPTASKS,${SSTATE_DIR},1G,100K \
STOPTASKS,/tmp,100M,100K \
ABORT,${TMPDIR},100M,1K \
ABORT,${DL_DIR},100M,1K \
ABORT,${SSTATE_DIR},100M,1K \
ABORT,/tmp,10M,1K"
PACKAGECONFIG_append_pn-qemu-system-native = " sdl"
PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
ASSUME_PROVIDED += "libsdl2-native"
CONF_VERSION = "1"


Re: [zeus] [PATCH] u-boot-fslc: missing lzop-native dependency for MACHINE imx6qdlsabreauto

Otavio Salvador
 

On Thu, Nov 21, 2019 at 7:04 PM Antoine Manache <a.manache@...> wrote:

When building u-boot-fslc_2019.07 for the imx6qdlsabreauto machine the
do_compile task fails with default configuration:

/bin/sh: 1: lzop: not found

Signed-off-by: Antoine Manache <a.manache@...>
Please prepare a PR on github against master, so we can later cherry-pick it.

--
Otavio Salvador O.S. Systems
http://www.ossystems.com.br http://code.ossystems.com.br
Mobile: +55 (53) 9 9981-7854 Mobile: +1 (347) 903-9750


Re: [PATCH] u-boot: set B directory for imx5's

Otavio Salvador
 

On Mon, Feb 10, 2020 at 8:14 PM Trevor Woerner <twoerner@...> wrote:
The imx5* machines need separate S and B directories to build u-boot-fslc
otherwise the build fails with:

| make[1]: *** No rule to make target '/z/build-master/meta-freescale/build/tmp-glibc/work/imx53qsb-oe-linux-gnueabi/u-boot-fslc/v2019.07+gitAUTOINC+ca0ab15271-r0/git/arch//cpu/u-boot.lds', needed by 'u-boot.lds'. Stop.

Build-tested with imx51evk, imx53ard, and imx53qsb.

Signed-off-by: Trevor Woerner <twoerner@...>
Which branch did you use?

--
Otavio Salvador O.S. Systems
http://www.ossystems.com.br http://code.ossystems.com.br
Mobile: +55 (53) 9 9981-7854 Mobile: +1 (347) 903-9750


[PATCH] u-boot: set B directory for imx5's

Trevor Woerner
 

The imx5* machines need separate S and B directories to build u-boot-fslc
otherwise the build fails with:

| make[1]: *** No rule to make target '/z/build-master/meta-freescale/bu=
ild/tmp-glibc/work/imx53qsb-oe-linux-gnueabi/u-boot-fslc/v2019.07+gitAUTO=
INC+ca0ab15271-r0/git/arch//cpu/u-boot.lds', needed by 'u-boot.lds'. Sto=
p.

Build-tested with imx51evk, imx53ard, and imx53qsb.

Signed-off-by: Trevor Woerner <twoerner@...>
---
recipes-bsp/u-boot/u-boot-fslc-common_2019.07.inc | 1 +
1 file changed, 1 insertion(+)

diff --git a/recipes-bsp/u-boot/u-boot-fslc-common_2019.07.inc b/recipes-=
bsp/u-boot/u-boot-fslc-common_2019.07.inc
index 575f76f8..44dd5125 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-common_2019.07.inc
+++ b/recipes-bsp/u-boot/u-boot-fslc-common_2019.07.inc
@@ -16,3 +16,4 @@ SRCBRANCH =3D "2019.07+fslc"
PV =3D "v2019.07+git${SRCPV}"
=20
S =3D "${WORKDIR}/git"
+B_mx5 =3D "${WORKDIR}/build"
--=20
2.25.0.114.g5b0ca878e0


Re: [zeus] [PATCH] u-boot-fslc: missing lzop-native dependency for MACHINE imx6qdlsabreauto

Trevor Woerner
 

The master branch needs this as well.

On Thu, Nov 21, 2019 at 5:04 PM Antoine Manache <a.manache@...> wrote:
When building u-boot-fslc_2019.07 for the imx6qdlsabreauto machine the
do_compile task fails with default configuration:

/bin/sh: 1: lzop: not found

Signed-off-by: Antoine Manache <a.manache@...>
---
 recipes-bsp/u-boot/u-boot-fslc_2019.07.bb | 1 +
 1 file changed, 1 insertion(+)

diff --git a/recipes-bsp/u-boot/u-boot-fslc_2019.07.bb b/recipes-bsp/u-boot/u-boot-fslc_2019.07.bb
index 2a17792f..464627d1 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2019.07.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2019.07.bb
@@ -7,6 +7,7 @@ was submitted for revision and it takes some time to become part of a stable \
 version, or because it is not applicable for upstreaming."
 
 DEPENDS_append = " bc-native dtc-native"
+DEPENDS_append_imx6qdlsabreauto = " lzop-native"
 
 PROVIDES += "u-boot"
 
--
2.11.0

--
_______________________________________________
meta-freescale mailing list
meta-freescale@...
https://lists.yoctoproject.org/listinfo/meta-freescale


imx8mm with 32-bit eglfs qt5 applications

Daniel Ammann
 

Hi all

I'm working on a custom imx8mm board. The idea is to have a 64-bit kernel and a
32-bit userland (The kernel is compiled with a imx8mm machine, the rootfs with
imx6d.) I'm using zeus with linux-imx 4.14. The "normal" userland tools work
without any problems. What is missing so far is qt5 with eglfs support. The
galcore kernel module is loaded, but a simple qt5 test application that is
using platform eglfs is segfaulting. The same application works fine with
linuxfb.

Is it even possible that get this combination working?

Kind regards

Daniel

581 - 600 of 24851