Date   

Re: repo sync of hardknott fails

Brian Hutchinson
 



On Wed, May 5, 2021 at 5:00 PM Otavio Salvador <otavio.salvador@...> wrote:
Em qua., 5 de mai. de 2021 às 09:50, Brian Hutchinson
<b.hutchman@...> escreveu:
> repo sync fails with hardknott:
>
> repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b hardknott
>
> hutch@Gondor:~/yocto/imx8/fsl-community-bsp_hardknott$ repo sync
> Fetching:  0% (0/7) warming uperror: Cannot fetch Documentation from https://github.com/Freescale/Documentation
> Fetching: 100% (7/7), done in 2m2.588s
> Garbage collecting: 100% (7/7), done in 0.012s
> error: Cannot fetch Documentation from https://github.com/Freescale/Documentation
> Fetching: 100% (1/1), done in 4.451s
> Garbage collecting: 100% (1/1), done in 0.003s
> error: Cannot checkout Documentation: ManifestInvalidRevisionError: revision hardknott in Documentation not found
> error: in `sync`: revision hardknott in Documentation not found

Please try again :)

Very good sir!  You are the man!  Works now!

I checked the layers out manually and did a build and had other problems ... will post another mail about it but tried repo init/sync and that worked.

Regards,

Brian


Re: repo sync of hardknott fails

Otavio Salvador
 

Em qua., 5 de mai. de 2021 às 09:50, Brian Hutchinson
<b.hutchman@...> escreveu:
repo sync fails with hardknott:

repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b hardknott

hutch@Gondor:~/yocto/imx8/fsl-community-bsp_hardknott$ repo sync
Fetching: 0% (0/7) warming uperror: Cannot fetch Documentation from https://github.com/Freescale/Documentation
Fetching: 100% (7/7), done in 2m2.588s
Garbage collecting: 100% (7/7), done in 0.012s
error: Cannot fetch Documentation from https://github.com/Freescale/Documentation
Fetching: 100% (1/1), done in 4.451s
Garbage collecting: 100% (1/1), done in 0.003s
error: Cannot checkout Documentation: ManifestInvalidRevisionError: revision hardknott in Documentation not found
error: in `sync`: revision hardknott in Documentation not found
Please try again :)


--
Otavio Salvador O.S. Systems
http://www.ossystems.com.br http://code.ossystems.com.br
Mobile: +55 (53) 9 9981-7854 Mobile: +1 (347) 903-9750


repo sync of hardknott fails

Brian Hutchinson
 

Hi,

repo sync fails with hardknott:


hutch@Gondor:~/yocto/imx8/fsl-community-bsp_hardknott$ repo sync
Fetching:  0% (0/7) warming uperror: Cannot fetch Documentation from https://github.com/Freescale/Documentation
Fetching: 100% (7/7), done in 2m2.588s
Garbage collecting: 100% (7/7), done in 0.012s
error: Cannot fetch Documentation from https://github.com/Freescale/Documentation
Fetching: 100% (1/1), done in 4.451s
Garbage collecting: 100% (1/1), done in 0.003s
error: Cannot checkout Documentation: ManifestInvalidRevisionError: revision hardknott in Documentation not found
error: in `sync`: revision hardknott in Documentation not found

Result is sources directory does not get populated:

hutch@Gondor:~/yocto/imx8/fsl-community-bsp_hardknott/sources$ ls -al
total 12
drwxrwxr-x 3 hutch hutch 4096 May  5 08:46 .
drwxrwxr-x 4 hutch hutch 4096 May  5 08:46 ..
drwxrwxr-x 3 hutch hutch 4096 May  5 08:46 Documentation



Can't file to patch while cooking recipe with bitbake

Zunzunegui Abad, Mario-Sergio <mario.zunzunegui@...>
 

Airbus Amber

Hello all.

I receive this error when compiling a récipe with bitbake.

 

ERROR: Command Error: exit status: 1  Output:

Applying patch work-with-openssl-1.0.2.patch

can't find file to patch at input line 5

Perhaps you used the wrong -p or --strip option?

The text leading up to this was:

--------------------------

|diff --git a/src/cryptography/hazmat/bindings/openssl/bio.py b/src/cryptography/hazmat/bindings/openssl/bio.py

|index 6cc1bcb..7e7abe7 100644

|--- a/src/cryptography/hazmat/bindings/openssl/bio.py

|+++ b/src/cryptography/hazmat/bindings/openssl/bio.py

--------------------------

No file to patch.  Skipping patch.

1 out of 1 hunk ignored

Patch work-with-openssl-1.0.2.patch does not apply (enforce with -f)

ERROR: Function failed: patch_do_patch

 

File is present but unreachable for any reason. Is there any way to change –p or –strip option for patch command in the recipe?

All ideas are welcomed.

Regards.

Sergio.

This Item has been reviewed and was determined as not listed under regulation, nor EU export controls, nor U.S. export controls. However, in the case of the item has to be resold, transferred, or otherwise disposed of to an embargoed country, to an end user of concern or in support of a prohibited end use, you may be required to obtain an export license.

Airbus has updated its Security classifications scheme. It is based on two classification levels: Airbus Amber and Airbus Red.
Both must be handled carefully and not disclosed to any other recipients than the ones mentioned into the email addresses list.

 

The information in this e-mail is confidential. The contents may not be disclosed or used by anyone other than the addressee. Access to this e-mail by anyone else is unauthorised.
If you are not the intended recipient, please notify Airbus immediately and delete this e-mail.
Airbus cannot accept any responsibility for the accuracy or completeness of this e-mail as it has been sent over public networks. If you have any concerns over the content of this message or its Accuracy or Integrity, please contact Airbus immediately.
All outgoing e-mails from Airbus are checked using regularly updated virus scanning software but you should take whatever measures you deem to be appropriate to ensure that this message and any attachments are virus free.


Re: [meta-freescale-3rdparty] [PATCH] colibri*.conf: define UBOOT_IMAGE

Otavio Salvador
 

Em ter., 4 de mai. de 2021 às 09:24, Ming Liu <liu.ming50@...> escreveu:

From: Ming Liu <liu.ming50@...>

We have renamed UBOOT_BINARY with '-nand' suffix to indicate it's a
image that should be flashed to NAND device, do the same to
UBOOT_IMAGE, otherwise developers might get confused about how to deal
with it.

Signed-off-by: Ming Liu <liu.ming50@...>
Please use the GitHub for this PR. Also, please include a background
why this change is required. Up to now, it seems to be going on the
wrong direction.


--
Otavio Salvador O.S. Systems
http://www.ossystems.com.br http://code.ossystems.com.br
Mobile: +55 (53) 9 9981-7854 Mobile: +1 (347) 903-9750


[meta-freescale-3rdparty] [PATCH] colibri*.conf: define UBOOT_IMAGE

Ming Liu <liu.ming50@...>
 

From: Ming Liu <liu.ming50@...>

We have renamed UBOOT_BINARY with '-nand' suffix to indicate it's a
image that should be flashed to NAND device, do the same to
UBOOT_IMAGE, otherwise developers might get confused about how to deal
with it.

Signed-off-by: Ming Liu <liu.ming50@...>
---
conf/machine/colibri-imx6ull.conf | 1 +
conf/machine/colibri-imx7-nand.conf | 1 +
conf/machine/colibri-vf.conf | 1 +
3 files changed, 3 insertions(+)

diff --git a/conf/machine/colibri-imx6ull.conf b/conf/machine/colibri-imx=
6ull.conf
index 1e1fd93..896fa1c 100644
--- a/conf/machine/colibri-imx6ull.conf
+++ b/conf/machine/colibri-imx6ull.conf
@@ -22,6 +22,7 @@ PREFERRED_RPROVIDER_u-boot-fw-utils ?=3D "u-boot-torade=
x-fw-utils"
PREFERRED_PROVIDER_u-boot-default-script ?=3D "u-boot-script-toradex"
=20
UBOOT_BINARY =3D "u-boot-nand.imx"
+UBOOT_IMAGE =3D "u-boot-nand-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
UBOOT_MAKE_TARGET =3D "u-boot.imx"
UBOOT_MACHINE ?=3D "colibri-imx6ull_defconfig"
=20
diff --git a/conf/machine/colibri-imx7-nand.conf b/conf/machine/colibri-i=
mx7-nand.conf
index 4ab7a95..03794c9 100644
--- a/conf/machine/colibri-imx7-nand.conf
+++ b/conf/machine/colibri-imx7-nand.conf
@@ -35,6 +35,7 @@ PREFERRED_PROVIDER_u-boot-default-script ?=3D "u-boot-s=
cript-toradex"
=20
# U-Boot NAND binary includes 0x400 padding required for NAND boot
UBOOT_BINARY =3D "u-boot-nand.imx"
+UBOOT_IMAGE =3D "u-boot-nand-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
UBOOT_MAKE_TARGET =3D "u-boot.imx"
UBOOT_MACHINE ?=3D "colibri_imx7_defconfig"
=20
diff --git a/conf/machine/colibri-vf.conf b/conf/machine/colibri-vf.conf
index 8c66ced..7e00e89 100644
--- a/conf/machine/colibri-vf.conf
+++ b/conf/machine/colibri-vf.conf
@@ -39,6 +39,7 @@ PREFERRED_VERSION_weston_use-nxp-bsp =3D ""
=20
# U-Boot NAND binary includes 0x400 padding required for NAND boot
UBOOT_BINARY =3D "u-boot-nand.imx"
+UBOOT_IMAGE =3D "u-boot-nand-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
UBOOT_MAKE_TARGET =3D "u-boot.imx"
UBOOT_MACHINE ?=3D "colibri_vf_defconfig"
=20
--=20
2.29.0


Re: Need support for Playing video with QT Application with X11 Support on Rootfs created with Yocto Rocko version.

Andrey Zhizhikin
 

Hello Rohit,

On Sun, May 2, 2021 at 6:37 PM rohit jadhav <rohitbjadhav1@...> wrote:

Hi Andrey,
Thank you for your guidance, But i Did find any Doc related Yocto or imx-linux-dunfell.
I may be wrong in my search, but I find Docs related to ZEUS and Gatesgarth.
Have a look at this repo:
https://github.com/Freescale/fsl-community-bsp-platform

You can use it as a platform development base, adding layers you need
into the BSP as you go. Default branch in that repo points to Dunfell
branch, so you would start the development on it straight away.


Can I start with anyone of the above but ZEUS is also recently EOL?
I would not recommend to start off Zeus, as it is also EOL.

And I have one doubt regarding meta-printing layer, as per my search its present upto Rocko version
Will I get this support any of the latest Yocto version?
This I do not know, your best bet would be to contact the layer
maintainer to discuss this.


Thanks and regards
Rohit

On Sun, May 2, 2021 at 9:02 PM Andrey Zhizhikin <andrey.z@...> wrote:

Hello Rohit,

On Sun, May 2, 2021 at 9:40 AM rohit jadhav <rohitbjadhav1@...> wrote:

I have crated rootfs with Yocto Rocko . I am running Qt application on it with X11 support.
Rocko branch is EOL since already 2,5 years, see
https://wiki.yoctoproject.org/wiki/Releases

Not sure if there would be any advise or support provided here for
versions that are already pas their EOL.

Have you tried the same setup with either Dunfell or Master?


What I observed booting log :
RandR extension missing
matchbox: Cant find a keycode for keysym 269025056
matchbox: ignoring key shortcut XF86Calendar=!$contacts

matchbox: Cant find a keycode for keysym 2809
matchbox: ignoring key shortcut telephone=!$dates

matchbox: Cant find a keycode for keysym 269025050
matchbox: ignoring key shortcut XF86Start=!matchbox-remote -desktop

And main observation is new rootfs {created with Rocko}is not supporting video playing feature with qt app.
But old rootfs {created with Krogoth} was supporting Video playing.

Did Imissed any Package in rootfs ?
Please guide me for this Solution.

Note : for Both Rootfs I have same Packages mentioned in local.conf


--
Regards,
Andrey.


--
Regards,
Andrey.


Re: Need support for Playing video with QT Application with X11 Support on Rootfs created with Yocto Rocko version.

rohit jadhav
 

Hi Andrey,
    Thank you for your guidance, But i Did find any Doc related Yocto or imx-linux-dunfell.
I may be wrong in my search, but I find Docs related to ZEUS and Gatesgarth.

Can I start with anyone of the above but ZEUS is also recently EOL?
And I have one doubt regarding meta-printing layer, as per my search its present upto Rocko version
Will I get this support any of the latest Yocto version?

Thanks and regards
Rohit


On Sun, May 2, 2021 at 9:02 PM Andrey Zhizhikin <andrey.z@...> wrote:
Hello Rohit,

On Sun, May 2, 2021 at 9:40 AM rohit jadhav <rohitbjadhav1@...> wrote:
>
> I have crated rootfs with Yocto Rocko . I am running Qt application on it with X11 support.

Rocko branch is EOL since already 2,5 years, see
https://wiki.yoctoproject.org/wiki/Releases

Not sure if there would be any advise or support provided here for
versions that are already pas their EOL.

Have you tried the same setup with either Dunfell or Master?

>
> What I observed booting log :
> RandR extension missing
> matchbox: Cant find a keycode for keysym 269025056
> matchbox: ignoring key shortcut XF86Calendar=!$contacts
>
> matchbox: Cant find a keycode for keysym 2809
> matchbox: ignoring key shortcut telephone=!$dates
>
> matchbox: Cant find a keycode for keysym 269025050
> matchbox: ignoring key shortcut XF86Start=!matchbox-remote -desktop
>
> And main observation is new rootfs {created with Rocko}is not supporting video playing feature with qt app.
> But old rootfs {created with Krogoth} was supporting Video playing.
>
> Did Imissed any Package in rootfs ?
> Please guide me for this Solution.
>
> Note : for Both Rootfs I have same Packages mentioned in local.conf
>
>


--
Regards,
Andrey.


Re: Need support for Playing video with QT Application with X11 Support on Rootfs created with Yocto Rocko version.

Andrey Zhizhikin
 

Hello Rohit,

On Sun, May 2, 2021 at 9:40 AM rohit jadhav <rohitbjadhav1@...> wrote:

I have crated rootfs with Yocto Rocko . I am running Qt application on it with X11 support.
Rocko branch is EOL since already 2,5 years, see
https://wiki.yoctoproject.org/wiki/Releases

Not sure if there would be any advise or support provided here for
versions that are already pas their EOL.

Have you tried the same setup with either Dunfell or Master?


What I observed booting log :
RandR extension missing
matchbox: Cant find a keycode for keysym 269025056
matchbox: ignoring key shortcut XF86Calendar=!$contacts

matchbox: Cant find a keycode for keysym 2809
matchbox: ignoring key shortcut telephone=!$dates

matchbox: Cant find a keycode for keysym 269025050
matchbox: ignoring key shortcut XF86Start=!matchbox-remote -desktop

And main observation is new rootfs {created with Rocko}is not supporting video playing feature with qt app.
But old rootfs {created with Krogoth} was supporting Video playing.

Did Imissed any Package in rootfs ?
Please guide me for this Solution.

Note : for Both Rootfs I have same Packages mentioned in local.conf


--
Regards,
Andrey.


Need support for Playing video with QT Application with X11 Support on Rootfs created with Yocto Rocko version.

rohit jadhav
 

I have crated rootfs with Yocto Rocko . I am running Qt application on it with X11 support.

What I observed booting log :
RandR extension missing
matchbox: Cant find a keycode for keysym 269025056
matchbox: ignoring key shortcut XF86Calendar=!$contacts

matchbox: Cant find a keycode for keysym 2809
matchbox: ignoring key shortcut telephone=!$dates

matchbox: Cant find a keycode for keysym 269025050
matchbox: ignoring key shortcut XF86Start=!matchbox-remote -desktop

And main observation is new rootfs {created with Rocko}is not supporting video playing feature with qt app.
But old rootfs {created with Krogoth} was supporting Video playing.

Did Imissed any Package in rootfs ?
Please guide me for this Solution.

Note : for Both Rootfs I have same Packages mentioned in local.conf


Re: Can't build weston image due to missing xserver-xorg-xwayland dependency

Andrey Zhizhikin
 

Hello Carlos,

On Thu, Apr 29, 2021 at 7:54 AM Carlos Rafael Giani via
lists.yoctoproject.org <crg7475=mailbox.org@...>
wrote:

I tried building latest master. core-image-base builds fine.
core-image-weston fails with this error:

nothing provides xserver-xorg-xwayland needed by
weston-xwayland-9.0.0.imx-r0.cortexa53-crypto-mx8m

What is confusing is that I can't find "xserver-xorg-xwayland" anywhere
in meta-freescale or any other layer. There is xwayland, but not
xserver-xorg-xwayland.

Is this a known bug? Or am I missing some settings somewhere?
There has been few patches from Alex in OE-Core regarding the xserver
and moving to xwayland, some examples are:
9fc863bcdb weston: use standalone xwayland instead of outdated
xserver-xorg version
07d33c8ec8 xwayland: add a standalone recipe

My best guess would be the recipe that builds NXP fork should be
adapted in the similar manner.





--
Regards,
Andrey.


Can't build weston image due to missing xserver-xorg-xwayland dependency

Carlos Rafael Giani
 

I tried building latest master. core-image-base builds fine. core-image-weston fails with this error:

    nothing provides xserver-xorg-xwayland needed by weston-xwayland-9.0.0.imx-r0.cortexa53-crypto-mx8m

What is confusing is that I can't find "xserver-xorg-xwayland" anywhere in meta-freescale or any other layer. There is xwayland, but not xserver-xorg-xwayland.

Is this a known bug? Or am I missing some settings somewhere?


Error when compiling an image based on imx8 when machine configuration file doesn't include "imx8" in the name #dunfell #compilation #meta-freescale #yocto

asconcepcion
 

Hi,

I'm getting an error when compiling an extended version of fsl-image-multimedia-full.bb for an i.mx8 based machine. However, I get this error only when the machine configuration file (which is exactly the same as meta-freescale/conf/machine/imx8qmmek.conf) doesn't include the "imx8" string in the filename. Is this something enforced somewhere?

Thanks in advanced.
BR,
Ale


Re: kernel-localversion, removing custom def configs, with linux-boundary #meta-freescale #compilation #yocto

Daniel Cox
 

Thank you for your efforts, 

The latest commit has resolved the issue.


Re: #yocto #meta-freescale #qca9377 #imx7ulpevk #gatesgarth #yocto #meta-freescale #qca9377 #imx7ulpevk #gatesgarth

Otavio Salvador
 

Hello,

Em sex., 16 de abr. de 2021 às 09:55, <jovanalukovic0@...> escreveu:
I am trying to include qca9377 module in my image (yocto-gatesgarth). I am using command bitbake imx-image-full, and i added two lines in my local.conf file: MACHINE_FEATURES += " qca9377"
IMAGE_INSTALL_append += " kernel-module-qca9377", but i get constantly the same mistake:
ERROR: kernel-module-qca9377-3.1-r0 do_compile: oe_runmake failed
ERROR: kernel-module-qca9377-3.1-r0 do_compile: Execution of '/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work/imx7ulpevk-poky-linux-gnueabi/kernel-module-qca9377/3.1-r0/temp/run.do_compile.25256' failed with exit code 1:
make -C /home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work-shared/imx7ulpevk/kernel-source M=/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work/imx7ulpevk-poky-linux-gnueabi/kernel-module-qca9377/3.1-r0/git modules WLAN_ROOT=/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work/imx7ulpevk-poky-linux-gnueabi/kernel-module-qca9377/3.1-r0/git MODNAME?=wlan CONFIG_QCA_WIFI_ISOC=0 CONFIG_QCA_WIFI_2_0=1 CONFIG_QCA_CLD_WLAN=m WLAN_OPEN_SOURCE=1
make[1]: Entering directory '/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work-shared/imx7ulpevk/kernel-source'
make[2]: Entering directory '/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work-shared/imx7ulpevk/kernel-build-artifacts'
and this is just a part of whole group of mistakes. There are a lot of mistakes, for examples:
cc1: some warnings being treated as errors
| /home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work-shared/imx7ulpevk/kernel-source/scripts/Makefile.build:279: recipe for target '/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work/imx7ulpevk-poky-linux-gnueabi/kernel-module-qca9377/3.1-r0/git/CORE/HDD/src/wlan_hdd_oemdata.o' failed
| make[3]: *** [/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work/imx7ulpevk-poky-linux-gnueabi/kernel-module-qca9377/3.1-r0/git/CORE/HDD/src/wlan_hdd_oemdata.o] Error 1
| /home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work-shared/imx7ulpevk/kernel-source/scripts/Makefile.build:279: recipe for target '/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work/imx7ulpevk-poky-linux-gnueabi/kernel-module-qca9377/3.1-r0/git/CORE/HDD/src/wlan_hdd_early_suspend.o' failed.
Do you have eny ideas what can i do? Do i miss something for my compiling? I am using Hi,
I am trying to include qca9377 module in my image (yocto-gatesgarth). I am using command bitbake imx-image-full, and i added two lines in my local.conf file: MACHINE_FEATURES += " qca9377"
IMAGE_INSTALL_append += " kernel-module-qca9377", but i get constantly the same mistake:
ERROR: kernel-module-qca9377-3.1-r0 do_compile: oe_runmake failed
ERROR: kernel-module-qca9377-3.1-r0 do_compile: Execution of '/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work/imx7ulpevk-poky-linux-gnueabi/kernel-module-qca9377/3.1-r0/temp/run.do_compile.25256' failed with exit code 1:
make -C /home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work-shared/imx7ulpevk/kernel-source M=/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work/imx7ulpevk-poky-linux-gnueabi/kernel-module-qca9377/3.1-r0/git modules WLAN_ROOT=/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work/imx7ulpevk-poky-linux-gnueabi/kernel-module-qca9377/3.1-r0/git MODNAME?=wlan CONFIG_QCA_WIFI_ISOC=0 CONFIG_QCA_WIFI_2_0=1 CONFIG_QCA_CLD_WLAN=m WLAN_OPEN_SOURCE=1
make[1]: Entering directory '/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work-shared/imx7ulpevk/kernel-source'
make[2]: Entering directory '/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work-shared/imx7ulpevk/kernel-build-artifacts'
and this is just a part of whole group of mistakes. There are a lot of mistakes, for examples:
cc1: some warnings being treated as errors
| /home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work-shared/imx7ulpevk/kernel-source/scripts/Makefile.build:279: recipe for target '/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work/imx7ulpevk-poky-linux-gnueabi/kernel-module-qca9377/3.1-r0/git/CORE/HDD/src/wlan_hdd_oemdata.o' failed
| make[3]: *** [/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work/imx7ulpevk-poky-linux-gnueabi/kernel-module-qca9377/3.1-r0/git/CORE/HDD/src/wlan_hdd_oemdata.o] Error 1
| /home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work-shared/imx7ulpevk/kernel-source/scripts/Makefile.build:279: recipe for target '/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work/imx7ulpevk-poky-linux-gnueabi/kernel-module-qca9377/3.1-r0/git/CORE/HDD/src/wlan_hdd_early_suspend.o' failed.
Do you have eny ideas what can i do? Do i miss something for my compiling? I am using imx7ulpevk.

Best regards and thanks a lot!
Please check if this happens on master; please report it here
https://github.com/Freescale/meta-freescale/issues if it does.


--
Otavio Salvador O.S. Systems
http://www.ossystems.com.br http://code.ossystems.com.br
Mobile: +55 (53) 9 9981-7854 Mobile: +1 (347) 903-9750


Re: kernel-localversion, removing custom def configs, with linux-boundary #meta-freescale #compilation #yocto

Otavio Salvador
 

Hello,

Em sex., 16 de abr. de 2021 às 09:55, <daniel.cox@...> escreveu:
We have seen an issue in a recent update to the dunfell branch.
Our image uses the linux-boundary, which requires the linux-imx.inc files.

What we have found thought with the latest dunfull branch. the changes made in commit. d6cb0a63d1a77da21e7f9cb7ca6561371b3fc896

Have caused custom configuration fragments to no longer be applied, these have been places in the linux-boundary bbappend file, as described in section 2.3.3 of the Kernel Development Manual.

We would like to understand if we are doing something wrong, or is there an issue with the aforementioned commit.
Reported here https://github.com/Freescale/meta-freescale/issues/733


--
Otavio Salvador O.S. Systems
http://www.ossystems.com.br http://code.ossystems.com.br
Mobile: +55 (53) 9 9981-7854 Mobile: +1 (347) 903-9750


Re: #meta-freescale #meta-freescale

Otavio Salvador
 

Em sex., 16 de abr. de 2021 às 11:10, <c.sarmat@...> escreveu:

After the commit d6cb0a63d1a77da21e7f9cb7ca6561371b3fc896 the functionality that inserts the configuration from the file deviceconfig.cfg to .conf was broken. I guess it is related to changing order of tasks.
Issue reported here: https://github.com/Freescale/meta-freescale/issues/733

Please provide any information there.

--
Otavio Salvador O.S. Systems
http://www.ossystems.com.br http://code.ossystems.com.br
Mobile: +55 (53) 9 9981-7854 Mobile: +1 (347) 903-9750


#meta-freescale #meta-freescale

c.sarmat@...
 

After the commit d6cb0a63d1a77da21e7f9cb7ca6561371b3fc896 the functionality that inserts the configuration from the file deviceconfig.cfg to .conf was broken. I guess it is related to changing order of tasks.


kernel-localversion, removing custom def configs, with linux-boundary #meta-freescale #compilation #yocto

Daniel Cox
 

Hi, 

We have seen an issue in a recent update to the dunfell branch.
Our image uses the linux-boundary, which requires the linux-imx.inc files. 

What we have found thought with the latest dunfull branch. the changes made in commit. d6cb0a63d1a77da21e7f9cb7ca6561371b3fc896 

Have caused custom configuration fragments to no longer be applied, these have been places in the linux-boundary bbappend file, as described in section 2.3.3 of the Kernel Development Manual. 

We would like to understand if we are doing something wrong, or is there an issue with the aforementioned commit.

Regards


#yocto #meta-freescale #qca9377 #imx7ulpevk #gatesgarth #yocto #meta-freescale #qca9377 #imx7ulpevk #gatesgarth

jovanalukovic0@...
 
Edited

Hi,
I am trying to include qca9377 module in my image (yocto-gatesgarth). I am using command  bitbake imx-image-full, and i added two lines in my local.conf file: MACHINE_FEATURES += " qca9377"
IMAGE_INSTALL_append += " kernel-module-qca9377", but i get constantly the same mistake:
ERROR: kernel-module-qca9377-3.1-r0 do_compile: oe_runmake failed
ERROR: kernel-module-qca9377-3.1-r0 do_compile: Execution of '/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work/imx7ulpevk-poky-linux-gnueabi/kernel-module-qca9377/3.1-r0/temp/run.do_compile.25256' failed with exit code 1:
make -C /home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work-shared/imx7ulpevk/kernel-source M=/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work/imx7ulpevk-poky-linux-gnueabi/kernel-module-qca9377/3.1-r0/git modules WLAN_ROOT=/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work/imx7ulpevk-poky-linux-gnueabi/kernel-module-qca9377/3.1-r0/git MODNAME?=wlan CONFIG_QCA_WIFI_ISOC=0 CONFIG_QCA_WIFI_2_0=1 CONFIG_QCA_CLD_WLAN=m WLAN_OPEN_SOURCE=1  
make[1]: Entering directory '/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work-shared/imx7ulpevk/kernel-source'
make[2]: Entering directory '/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work-shared/imx7ulpevk/kernel-build-artifacts'
and this is just a part of whole group of mistakes. There are a lot of mistakes, for examples:
cc1: some warnings being treated as errors
| /home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work-shared/imx7ulpevk/kernel-source/scripts/Makefile.build:279: recipe for target '/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work/imx7ulpevk-poky-linux-gnueabi/kernel-module-qca9377/3.1-r0/git/CORE/HDD/src/wlan_hdd_oemdata.o' failed
| make[3]: *** [/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work/imx7ulpevk-poky-linux-gnueabi/kernel-module-qca9377/3.1-r0/git/CORE/HDD/src/wlan_hdd_oemdata.o] Error 1
| /home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work-shared/imx7ulpevk/kernel-source/scripts/Makefile.build:279: recipe for target '/home/jovana/Projects/imx-yocto-bsp-gates/build-xwayland/tmp/work/imx7ulpevk-poky-linux-gnueabi/kernel-module-qca9377/3.1-r0/git/CORE/HDD/src/wlan_hdd_early_suspend.o' failed.
Do you have any ideas what can i do?  I am using imx7ulpevk.

Best regards and thanks a lot!

221 - 240 of 24894